aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/keebio/fourier/keymaps
diff options
context:
space:
mode:
authorDanny <nooges@users.noreply.github.com>2019-02-12 19:57:24 -0500
committerDrashna Jaelre <drashna@live.com>2019-02-12 16:57:24 -0800
commitb2ee290c9f506e42dd9c4577c8147646c405aeb0 (patch)
tree4338c3ee37d2f8380c24624a24d8a4cb81d54693 /keyboards/keebio/fourier/keymaps
parent994852712dbd183e2c764d624ae8ba7d3efb385a (diff)
downloadfirmware-b2ee290c9f506e42dd9c4577c8147646c405aeb0.tar.gz
firmware-b2ee290c9f506e42dd9c4577c8147646c405aeb0.tar.bz2
firmware-b2ee290c9f506e42dd9c4577c8147646c405aeb0.zip
[Keyboard] Move Keebio boards to own folder (#5109)
* Move boards into keebio folder * Rename keymap * Update BDN9 files * Update BFO-9000 files * Update Chocopad files * Update Dilly files * Update Fourier files, collapse rev1 into main * Update Iris files * Update Laplace files * Update Levinson files, fix buswerks keymap * Update Nyquist files * Fix keymap issues * Update Quefrency files * Update Rorschach files * Update TF68 files * Update Viterbi files * Update Viterbi files * Update Wavelet files * Reformat default layout * Fix up default folder for Iris * Remove already defined aliases
Diffstat (limited to 'keyboards/keebio/fourier/keymaps')
-rw-r--r--keyboards/keebio/fourier/keymaps/default/config.h24
-rw-r--r--keyboards/keebio/fourier/keymaps/default/keymap.c42
-rw-r--r--keyboards/keebio/fourier/keymaps/default/rules.mk0
-rw-r--r--keyboards/keebio/fourier/keymaps/jennetters/config.h28
-rw-r--r--keyboards/keebio/fourier/keymaps/jennetters/keymap.c146
-rw-r--r--keyboards/keebio/fourier/keymaps/jennetters/rules.mk1
-rw-r--r--keyboards/keebio/fourier/keymaps/maxim/config.h29
-rw-r--r--keyboards/keebio/fourier/keymaps/maxim/keymap.c45
-rw-r--r--keyboards/keebio/fourier/keymaps/valgrahf/config.h31
-rw-r--r--keyboards/keebio/fourier/keymaps/valgrahf/keymap.c69
-rw-r--r--keyboards/keebio/fourier/keymaps/valgrahf/rules.mk0
-rw-r--r--keyboards/keebio/fourier/keymaps/xyverz/config.h33
-rw-r--r--keyboards/keebio/fourier/keymaps/xyverz/keymap.c84
13 files changed, 532 insertions, 0 deletions
diff --git a/keyboards/keebio/fourier/keymaps/default/config.h b/keyboards/keebio/fourier/keymaps/default/config.h
new file mode 100644
index 000000000..8cea39218
--- /dev/null
+++ b/keyboards/keebio/fourier/keymaps/default/config.h
@@ -0,0 +1,24 @@
+/*
+This is the c configuration file for the keymap
+
+Copyright 2012 Jun Wako <wakojun@gmail.com>
+Copyright 2015 Jack Humbert
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 2 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#pragma once
+
+/* Use I2C or Serial, not both */
+// #define USE_I2C
diff --git a/keyboards/keebio/fourier/keymaps/default/keymap.c b/keyboards/keebio/fourier/keymaps/default/keymap.c
new file mode 100644
index 000000000..341bc99a7
--- /dev/null
+++ b/keyboards/keebio/fourier/keymaps/default/keymap.c
@@ -0,0 +1,42 @@
+#include QMK_KEYBOARD_H
+
+// Each layer gets a name for readability, which is then used in the keymap matrix below.
+// The underscores don't mean anything - you can have a layer called STUFF or any other name.
+// Layer names don't all need to be of the same length, obviously, and you can also skip them
+// entirely and just use numbers.
+#define _BASE 0
+#define _FN1 1
+#define _FN2 2
+
+enum custom_keycodes {
+ QWERTY = SAFE_RANGE,
+};
+
+#define KC_FN1 MO(_FN1)
+#define KC_FN2 MO(_FN2)
+#define SPFN1 LT(_FN1, KC_SPACE)
+#define BSFN2 LT(_FN2, KC_BSPC)
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+ [_BASE] = LAYOUT(
+ KC_ESC, KC_Q, KC_W, KC_E, KC_R, KC_T, KC_Y, KC_U, KC_I, KC_O, KC_P, KC_DEL, KC_BSPC,
+ KC_TAB, KC_A, KC_S, KC_D, KC_F, KC_G, KC_H, KC_J, KC_K, KC_L, KC_QUOT, KC_ENT,
+ KC_LSFT, KC_Z, KC_X, KC_C, KC_V, KC_B, KC_N, KC_M, KC_COMM, KC_DOT, KC_SLSH, KC_RSFT,
+ KC_LCTL, KC_LALT, KC_LGUI, KC_FN1, SPFN1, BSFN2, KC_RGUI, KC_RALT, KC_FN2, KC_RCTL
+ ),
+
+ [_FN1] = LAYOUT(
+ KC_GRV, KC_1, KC_2, KC_3, KC_4, KC_5, KC_6, KC_7, KC_8, KC_9, KC_0, KC_MINS, KC_EQL,
+ RESET, RGB_HUI, RGB_SAI, RGB_VAI, KC_VOLU, KC_LBRC, KC_RBRC, KC_4, KC_5, KC_6, KC_SCLN, _______,
+ RGB_MOD, RGB_HUD, RGB_SAD, RGB_VAD, KC_VOLD, KC_LCBR, KC_RCBR, KC_1, KC_2, KC_3, KC_UP, _______,
+ RGB_TOG, _______, _______, _______, _______, KC_DEL, KC_0, KC_LEFT, KC_DOWN, KC_RGHT
+ ),
+
+ [_FN2] = LAYOUT(
+ KC_TILD, KC_EXLM, KC_AT, KC_HASH, KC_DLR, KC_PERC, KC_CIRC, KC_AMPR, KC_ASTR, KC_LPRN, KC_RPRN, KC_UNDS, KC_PLUS,
+ _______, _______, _______, KC_INS, KC_PGUP, KC_HOME, _______, _______, _______, _______, KC_COLN, _______,
+ _______, _______, _______, KC_DEL, KC_PGDN, KC_END, _______, _______, _______, _______, _______, _______,
+ _______, _______, _______, _______, KC_DEL, _______, _______, _______, _______, _______
+ )
+
+};
diff --git a/keyboards/keebio/fourier/keymaps/default/rules.mk b/keyboards/keebio/fourier/keymaps/default/rules.mk
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/keyboards/keebio/fourier/keymaps/default/rules.mk
diff --git a/keyboards/keebio/fourier/keymaps/jennetters/config.h b/keyboards/keebio/fourier/keymaps/jennetters/config.h
new file mode 100644
index 000000000..5f99c65ad
--- /dev/null
+++ b/keyboards/keebio/fourier/keymaps/jennetters/config.h
@@ -0,0 +1,28 @@
+/*
+This is the c configuration file for the keymap
+
+Copyright 2012 Jun Wako <wakojun@gmail.com>
+Copyright 2015 Jack Humbert
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 2 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#pragma once
+
+#define TAPPING_TERM 100
+
+/* Use I2C or Serial, not both */
+
+#define USE_SERIAL
+// #define USE_I2C
diff --git a/keyboards/keebio/fourier/keymaps/jennetters/keymap.c b/keyboards/keebio/fourier/keymaps/jennetters/keymap.c
new file mode 100644
index 000000000..a6ec95e1e
--- /dev/null
+++ b/keyboards/keebio/fourier/keymaps/jennetters/keymap.c
@@ -0,0 +1,146 @@
+#include QMK_KEYBOARD_H
+
+extern keymap_config_t keymap_config;
+
+// Each layer gets a name for readability, which is then used in the keymap matrix below.
+// The underscores don't mean anything - you can have a layer called STUFF or any other name.
+// Layer names don't all need to be of the same length, obviously, and you can also skip them
+// entirely and just use numbers.
+#define _BASE 0
+#define _FN1 1
+#define _FN2 2
+
+enum custom_keycodes {
+ QWERTY = SAFE_RANGE,
+};
+
+#define KC_ KC_TRNS
+#define KC_FN1 MO(_FN1)
+#define KC_FN2 MO(_FN2)
+#define KC_SPFN1 LT(_FN1, KC_SPACE)
+#define KC_SPFN2 LT(_FN2, KC_SPACE)
+#define KC_BSFN1 LT(_FN1, KC_BSPC)
+#define KC_BSFN2 LT(_FN2, KC_BSPC)
+#define KC_RST RESET
+#define KC_DBUG DEBUG
+#define KC_RTOG RGB_TOG
+#define KC_RMOD RGB_MOD
+#define KC_RHUI RGB_HUI
+#define KC_RHUD RGB_HUD
+#define KC_RSAI RGB_SAI
+#define KC_RSAD RGB_SAD
+#define KC_RVAI RGB_VAI
+#define KC_RVAD RGB_VAD
+
+//Tap Dance Declarations
+enum {
+ ESC_GR = 0,
+ Q_1,
+ W_2,
+ E_3,
+ R_4,
+ T_5,
+ Y_6,
+ U_7,
+ I_8,
+ O_9,
+ P_0,
+ MIN_LB,
+ EQL_RB,
+ SCL_QUO
+};
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+[_BASE] = LAYOUT(
+ // ,----+----+----+----+----+----|----+----+----+----+----+----+----.
+ // |ESC | Q1 | W2 | E3 | R4 | T5 | Y6 | U7 | I8 | O9 | P0 | -[ | =] |
+ // |----`----`----`----`----`----|----`----`----`----`----`----`----|
+ // | TAB | A | S | D | F | G | H | H | J | K | L | BKSP |
+ // |-----`----`----`----`----`----|----`----`----`----`----`--------|
+ // | SHIFT | Z | X | C | V | B | N | M | , | . | / | SHFT |
+ // |-------`----`----`----`----`----|----`----`----`----`----`------|
+ // | CTL | SYS| ALT | SP SPACE | SPACE | FN1 | CTL | \ | ENT |
+ // `-----+----+-----+----+--------|--------+-----+------+----+------'
+
+ TD(ESC_GR), TD(Q_1), TD(W_2), TD(E_3), TD(R_4), TD(T_5), TD(Y_6), TD(U_7), TD(I_8), TD(O_9), TD(P_0),TD(MIN_LB),TD(EQL_RB), \
+ KC_TAB, KC_A, KC_S, KC_D, KC_F, KC_G, KC_H, KC_J, KC_K, KC_L, TD(SCL_QUO), KC_BSPC, \
+ KC_LSPO, KC_Z, KC_X, KC_C, KC_V, KC_B, KC_N, KC_M, KC_COMM, KC_DOT, KC_SLSH, KC_RSPC, \
+ KC_LCTL, KC_LGUI, KC_LALT, KC_SPACE, KC_SPACE, KC_SPACE, KC_FN1, KC_LCTL, KC_NUBS, KC_ENTER
+ ),
+
+ [_FN1] = LAYOUT_kc(
+ // ,----+----+----+----+----+----|----+----+----+----+----+----+----.
+ // | | | UP | | | | | | | | | | |
+ // |----`----`----`----`----`----|----`----`----`----`----`----`----|
+ // | | LT | DN | RT | | | | | | | ' | DEL |
+ // |-----`----`----`----`----`----|----`----`----`----`----`--------|
+ // | | | | | | | | | | |PIPE| |
+ // |-------`----`----`----`----`----|----`----`----`----`----`------|
+ // | | | | | | | | | | |
+ // `-----+----+-----+----+--------|--------+-----+------+----+------'
+
+ , , UP, , , , , , , , , , , \
+ , LEFT, DOWN, RIGHT, , , , , , , QUOT, DEL, \
+ , , , , , , , , , , NUBS, , \
+ , , , , , , , , ,
+ ),
+
+ [_FN2] = LAYOUT_kc(
+ // ,----+----+----+----+----+----|----+----+----+----+----+----+----.
+ // | | | | | | | | | | | | | |
+ // |----`----`----`----`----`----|----`----`----`----`----`----`----|
+ // | | | | | | | | | | | | |
+ // |-----`----`----`----`----`----|----`----`----`----`----`--------|
+ // | | | | | | | | | | | | |
+ // |-------`----`----`----`----`----|----`----`----`----`----`------|
+ // | | | | | | | | | | |
+ // `-----+----+-----+----+--------|--------+-----+------+----+------'
+
+ , , , , , , , , , , , , , \
+ , , , , , , , , , , , , \
+ , , , , , , , , , , , , \
+ , , , , , , , , ,
+ )
+
+};
+
+void esc_gr_finished (qk_tap_dance_state_t *state, void *user_data) {
+ if (state->count == 1) {
+ register_code (KC_ESC);
+ } else if (state->count == 2) {
+ register_code (KC_GRV);
+ } else {
+ register_code (KC_LSFT);
+ register_code (KC_GRV);
+ }
+}
+
+void esc_gr_reset (qk_tap_dance_state_t *state, void *user_data) {
+ if (state->count == 1) {
+ unregister_code (KC_ESC);
+ } else if (state->count == 2) {
+ unregister_code (KC_GRV);
+ } else {
+ unregister_code (KC_LSFT);
+ unregister_code (KC_GRV);
+ }
+}
+
+//Tap Dance Definitions
+qk_tap_dance_action_t tap_dance_actions[] = {
+[ESC_GR] = ACTION_TAP_DANCE_FN_ADVANCED (NULL, esc_gr_finished, esc_gr_reset), //Tap once for ESC, twice for `, thrice for ~
+[Q_1] = ACTION_TAP_DANCE_DOUBLE(KC_Q, KC_1), //Tap once for Q, twice for 1/!
+[W_2] = ACTION_TAP_DANCE_DOUBLE(KC_W, KC_2), //Tap once for W, twice for 2/@
+[E_3] = ACTION_TAP_DANCE_DOUBLE(KC_E, KC_3), //Tap once for E, twice for 3/#
+[R_4] = ACTION_TAP_DANCE_DOUBLE(KC_R, KC_4), //Tap once for R, twice for 4/$
+[T_5] = ACTION_TAP_DANCE_DOUBLE(KC_T, KC_5), //Tap once for T, twice for 5/%
+[Y_6] = ACTION_TAP_DANCE_DOUBLE(KC_Y, KC_6), //Tap once for Y, twice for 6/^
+[U_7] = ACTION_TAP_DANCE_DOUBLE(KC_U, KC_7), //Tap once for U, twice for 7/&
+[I_8] = ACTION_TAP_DANCE_DOUBLE(KC_I, KC_8), //Tap once for I, twice for 8/*
+[O_9] = ACTION_TAP_DANCE_DOUBLE(KC_O, KC_9), //Tap once for O, twice for 9/(
+[P_0] = ACTION_TAP_DANCE_DOUBLE(KC_P, KC_0), //Tap once for P, twice for 0/)
+[MIN_LB] = ACTION_TAP_DANCE_DOUBLE(KC_MINS, KC_LBRC), //Tap once for -, twice for [/{
+[EQL_RB] = ACTION_TAP_DANCE_DOUBLE(KC_EQL, KC_RBRC), //Tap once for =, twice for ]/}
+[SCL_QUO] = ACTION_TAP_DANCE_DOUBLE(KC_SCLN, KC_QUOT) //Tap once for ;, '/"
+// Other declarations would go here, separated by commas, if you have them
+};
diff --git a/keyboards/keebio/fourier/keymaps/jennetters/rules.mk b/keyboards/keebio/fourier/keymaps/jennetters/rules.mk
new file mode 100644
index 000000000..1ba2fa8fb
--- /dev/null
+++ b/keyboards/keebio/fourier/keymaps/jennetters/rules.mk
@@ -0,0 +1 @@
+TAP_DANCE_ENABLE = yes \ No newline at end of file
diff --git a/keyboards/keebio/fourier/keymaps/maxim/config.h b/keyboards/keebio/fourier/keymaps/maxim/config.h
new file mode 100644
index 000000000..fb13b56cd
--- /dev/null
+++ b/keyboards/keebio/fourier/keymaps/maxim/config.h
@@ -0,0 +1,29 @@
+/*
+This is the c configuration file for the keymap
+
+Copyright 2012 Jun Wako <wakojun@gmail.com>
+Copyright 2015 Jack Humbert
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 2 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#pragma once
+
+#include "config_common.h"
+
+/* Use I2C or Serial, not both */
+
+#define USE_SERIAL
+// #define USE_I2C
+
diff --git a/keyboards/keebio/fourier/keymaps/maxim/keymap.c b/keyboards/keebio/fourier/keymaps/maxim/keymap.c
new file mode 100644
index 000000000..68bd649ec
--- /dev/null
+++ b/keyboards/keebio/fourier/keymaps/maxim/keymap.c
@@ -0,0 +1,45 @@
+#include QMK_KEYBOARD_H
+
+extern keymap_config_t keymap_config;
+
+// Each layer gets a name for readability, which is then used in the keymap matrix below.
+// The underscores don't mean anything - you can have a layer called STUFF or any other name.
+// Layer names don't all need to be of the same length, obviously, and you can also skip them
+// entirely and just use numbers.
+#define _BASE 0
+#define _FN1 1
+#define _FN2 2
+
+enum custom_keycodes {
+ QWERTY = SAFE_RANGE,
+};
+
+
+#define FN1 MO(_FN1)
+#define FN2 MO(_FN2)
+#define SPFN1 LT(_FN1, KC_SPACE)
+#define BSFN2 LT(_FN2, KC_BSPC)
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+ [_BASE] = LAYOUT(
+ KC_ESC, KC_Q, KC_W, KC_E, KC_R, KC_T, KC_Y, KC_U, KC_I, KC_O, KC_P, KC_DEL, KC_BSPC,
+ KC_TAB, KC_A, KC_S, KC_D, KC_F, KC_G, KC_H, KC_J, KC_K, KC_L, KC_QUOT, KC_ENT,
+ KC_LSFT, KC_Z, KC_X, KC_C, KC_V, KC_B, KC_N, KC_M, KC_COMM, KC_DOT, KC_SLSH, KC_RSFT,
+ XXXXXXX, KC_LCTL, KC_LALT, XXXXXXX, KC_SPC, FN1, KC_RCTL, KC_RGUI, FN2, XXXXXXX
+ ),
+
+ [_FN1] = LAYOUT(
+ KC_GRV, KC_1, KC_2, KC_3, KC_4, KC_5, KC_6, KC_7, KC_8, KC_9, KC_0, KC_MINS, KC_EQL,
+ RESET, RGB_HUI, RGB_SAI, RGB_VAI, KC_VOLU, KC_LBRC, KC_RBRC, KC_4, KC_5, KC_6, KC_SCLN, _______,
+ RGB_MOD, RGB_HUD, RGB_SAD, RGB_VAD, KC_VOLD, KC_LCBR, KC_RCBR, KC_1, KC_2, KC_3, KC_UP, _______,
+ RGB_TOG, _______, _______, _______, _______, KC_DEL, KC_0, KC_LEFT, KC_DOWN, KC_RGHT
+ ),
+
+ [_FN2] = LAYOUT(
+ KC_TILD, KC_EXLM, KC_AT, KC_HASH, KC_DLR, KC_PERC, KC_CIRC, KC_AMPR, KC_ASTR, KC_LPRN, KC_RPRN, KC_UNDS, KC_PLUS,
+ _______, _______, _______, KC_INS, KC_PGUP, KC_HOME, _______, _______, _______, _______, KC_COLN, _______,
+ _______, _______, _______, KC_DEL, KC_PGDN, KC_END, _______, _______, _______, _______, _______, _______,
+ _______, _______, _______, _______, KC_DEL, _______, _______, _______, _______, _______
+ )
+
+};
diff --git a/keyboards/keebio/fourier/keymaps/valgrahf/config.h b/keyboards/keebio/fourier/keymaps/valgrahf/config.h
new file mode 100644
index 000000000..20e49c421
--- /dev/null
+++ b/keyboards/keebio/fourier/keymaps/valgrahf/config.h
@@ -0,0 +1,31 @@
+/*
+This is the c configuration file for the keymap
+
+Copyright 2012 Jun Wako <wakojun@gmail.com>
+Copyright 2015 Jack Humbert
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 2 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#ifndef CONFIG_USER_H
+#define CONFIG_USER_H
+
+#include "config_common.h"
+
+/* Use I2C or Serial, not both */
+
+#define USE_SERIAL
+// #define USE_I2C
+
+#endif
diff --git a/keyboards/keebio/fourier/keymaps/valgrahf/keymap.c b/keyboards/keebio/fourier/keymaps/valgrahf/keymap.c
new file mode 100644
index 000000000..a31c88475
--- /dev/null
+++ b/keyboards/keebio/fourier/keymaps/valgrahf/keymap.c
@@ -0,0 +1,69 @@
+#include QMK_KEYBOARD_H
+
+extern keymap_config_t keymap_config;
+
+// Each layer gets a name for readability, which is then used in the keymap matrix below.
+// The underscores don't mean anything - you can have a layer called STUFF or any other name.
+// Layer names don't all need to be of the same length, obviously, and you can also skip them
+// entirely and just use numbers.
+#define _BASE 0
+#define _FN1 1
+#define _FN2 2
+
+enum custom_keycodes {
+ QWERTY = SAFE_RANGE,
+};
+
+#define KC_ KC_TRNS
+#define KC_FN1 LT(_FN1, KC_NO)
+#define KC_FN2 LT(_FN2, KC_NO)
+#define KC_SPFN LT(_FN1, KC_SPACE)
+#define KC_RST RESET
+#define KC_DBUG DEBUG
+#define KC_RTOG RGB_TOG
+#define KC_RMOD RGB_MOD
+#define KC_RHUI RGB_HUI
+#define KC_RHUD RGB_HUD
+#define KC_RSAI RGB_SAI
+#define KC_RSAD RGB_SAD
+#define KC_RVAI RGB_VAI
+#define KC_RVAD RGB_VAD
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+ [_BASE] = LAYOUT_kc(
+ //,----+----+----+----+----+----|----+----+----+----+----+----+----.
+ TAB , Q , W , E , R , T , Y , U , I , O , P , DEL,BSPC,
+ //|----`----`----`----`----`----|----`----`----`----`----`----`----|
+ ESC , A , S , D , F , G , H , J , K , L ,QUOT, SCLN ,
+ //|-----`----`----`----`----`----|----`----`----`----`----`--------|
+ LSFT , Z , X , C , V , B , N , M ,COMM,DOT ,SLSH, PGUP ,
+ //|-------`----`----`----`----`----|----`----`----`----`----`------|
+ LCTL ,LALT, FN1, ,ENTER , SPACE , FN2 , HOME, END , PGDN
+ //`-----+----+-----+-------------|--------+-----+-----+-----+------'
+ ),
+
+ [_FN1] = LAYOUT_kc(
+ //,----+----+----+----+----+----|----+----+----+----+----+----+----.
+ GRV , 1 , 2 , 3 , 4 , 5 , 6 , 7 , 8 , 9 , 0 , , ,
+ //|----`----`----`----`----`----|----`----`----`----`----`----`----|
+ DEL , F1 ,F2 , F3 , F4 , F5 , F6 ,MINS, EQL,LBRC,RBRC, BSLS ,
+ //|-----`----`----`----`----`----|----`----`----`----`----`--------|
+ , F7 , F8 , F9 , F10, F11, F12, , , , UP , ,
+ //|-------`----`----`----`----`----|----`----`----`----`----`------|
+ , , , , , ,RGUI,LEFT ,DOWN ,RIGHT
+ //`-----+----+-----+-------------|--------+-----+-----+-----+------'
+ ),
+
+ [_FN2] = LAYOUT_kc(
+ //,----+----+----+----+----+----|----+----+----+----+----+----+----.
+ TILD,EXLM, AT ,HASH,DLR ,PERC,CIRC,AMPR,ASTR,LPRN,RPRN, , ,
+ //|----`----`----`----`----`----|----`----`----`----`----`----`----|
+ DEL ,RHUI,RSAI,RVAI, , , ,UNDS,PLUS,LCBR,RCBR, PIPE ,
+ //|-----`----`----`----`----`----|----`----`----`----`----`--------|
+ ,RHUD,RSAD,RVAD, , ,VOLU,VOLD, , , UP , ,
+ //|-------`----`----`----`----`----|----`----`----`----`----`------|
+ ,RTOG,RMOD , , , , , LEFT, DOWN, RIGHT
+ //`-----+----+-----+-------------|--------+-----+-----+-----+------'
+ )
+
+};
diff --git a/keyboards/keebio/fourier/keymaps/valgrahf/rules.mk b/keyboards/keebio/fourier/keymaps/valgrahf/rules.mk
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/keyboards/keebio/fourier/keymaps/valgrahf/rules.mk
diff --git a/keyboards/keebio/fourier/keymaps/xyverz/config.h b/keyboards/keebio/fourier/keymaps/xyverz/config.h
new file mode 100644
index 000000000..9b46a61cc
--- /dev/null
+++ b/keyboards/keebio/fourier/keymaps/xyverz/config.h
@@ -0,0 +1,33 @@
+/*
+This is the c configuration file for the keymap
+
+Copyright 2012 Jun Wako <wakojun@gmail.com>
+Copyright 2015 Jack Humbert
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 2 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#ifndef CONFIG_USER_H
+#define CONFIG_USER_H
+
+#include "config_common.h"
+
+/* Use I2C or Serial, not both */
+
+#define USE_SERIAL
+// #define USE_I2C
+
+#define EE_HANDS
+
+#endif
diff --git a/keyboards/keebio/fourier/keymaps/xyverz/keymap.c b/keyboards/keebio/fourier/keymaps/xyverz/keymap.c
new file mode 100644
index 000000000..4e864cdef
--- /dev/null
+++ b/keyboards/keebio/fourier/keymaps/xyverz/keymap.c
@@ -0,0 +1,84 @@
+#include QMK_KEYBOARD_H
+#include "action_layer.h"
+#include "eeconfig.h"
+
+extern keymap_config_t keymap_config;
+
+// Each layer gets a name for readability, which is then used in the keymap matrix below.
+// The underscores don't mean anything - you can have a layer called STUFF or any other name.
+// Layer names don't all need to be of the same length, obviously, and you can also skip them
+// entirely and just use numbers.
+#define _BASE 0
+#define _FN1 1
+#define _FN2 2
+
+enum custom_keycodes {
+ QWERTY = SAFE_RANGE,
+};
+
+#define KC_ KC_TRNS
+#define KC_FN1 MO(_FN1)
+#define KC_FN2 MO(_FN2)
+#define KC_ESFN1 LT(_FN1, KC_ESC)
+#define KC_SPFN1 LT(_FN1, KC_SPACE)
+#define KC_SPFN2 LT(_FN2, KC_SPACE)
+#define KC_BSFN1 LT(_FN1, KC_BSPC)
+#define KC_BSFN2 LT(_FN2, KC_BSPC)
+#define KC_RST RESET
+#define KC_DBUG DEBUG
+#define KC_RTOG RGB_TOG
+#define KC_RMOD RGB_MOD
+#define KC_RHUI RGB_HUI
+#define KC_RHUD RGB_HUD
+#define KC_RSAI RGB_SAI
+#define KC_RSAD RGB_SAD
+#define KC_RVAI RGB_VAI
+#define KC_RVAD RGB_VAD
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+ [_BASE] = LAYOUT_kc(
+ //,----+----+----+----+----+----|----+----+----+----+----+----+----.
+ TAB ,QUOT,COMM,DOT , P , Y , F , G , C , R , L ,SLSH,MINS,
+ //|----`----`----`----`----`----|----`----`----`----`----`----`----|
+ ESC , A , O , E , U , I , D , H , T , N , S , ENTER ,
+ //|-----`----`----`----`----`----|----`----`----`----`----`--------|
+ LSFT ,SCLN, Q , J , K , X , B , M , W , V , Z , RSFT ,
+ //|-------`----`----`----`----`----|----`----`----`----`----`------|
+ LCTL ,LALT,LGUI ,FN2 , BSPC , SPC , FN1 ,RGUI ,RALT , RCTL
+ //`-----+----+-----+----+--------|--------+-----+-----+-----+------'
+ ),
+
+ [_FN1] = LAYOUT_kc(
+ //,----+----+----+----+----+----|----+----+----+----+----+----+----.
+ GRV , 1 , 2 , 3 , 4 , 5 , 6 , 7 , 8 , 9 , 0 ,MINS,EQL ,
+ //|----`----`----`----`----`----|----`----`----`----`----`----`----|
+ CAPS ,RHUI,RSAI,RVAI,VOLU,LBRC,RBRC, , , ,SCLN, ,
+ //|-----`----`----`----`----`----|----`----`----`----`----`--------|
+ RMOD ,RHUD,RSAD,RVAD,VOLD,LCBR,RCBR, , , , UP , ,
+ //|-------`----`----`----`----`----|----`----`----`----`----`------|
+ RTOG , , , , DEL , INS , ,LEFT ,DOWN , RGHT
+ //`-----+----+-----+----+--------|--------+-----+-----+-----+------'
+ ),
+
+ [_FN2] = LAYOUT_kc(
+ //,----+----+----+----+----+----|----+----+----+----+----+----+----.
+ TILD,EXLM, AT ,HASH,DLR ,PERC,CIRC,AMPR,ASTR,LPRN,RPRN,UNDS,PLUS,
+ //|----`----`----`----`----`----|----`----`----`----`----`----`----|
+ CAPS , , ,INS ,PGUP,HOME, F1 , F2 , F3 , F4 , F5 , F6 ,
+ //|-----`----`----`----`----`----|----`----`----`----`----`--------|
+ , , ,DEL ,PGDN,END , F7 , F8 , F9 ,F10 ,F11 , F12 ,
+ //|-------`----`----`----`----`----|----`----`----`----`----`------|
+ , , , , DEL , INS , , , ,
+ //`-----+----+-----+----+--------|--------+-----+-----+-----+------'
+ )
+
+};
+
+void matrix_init_user(void) {
+ // This will disable the red LEDs on the ProMicros
+ DDRD &= ~(1<<5);
+ PORTD &= ~(1<<5);
+ DDRB &= ~(1<<0);
+ PORTB &= ~(1<<0);
+};
+