aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/keebio/iris
diff options
context:
space:
mode:
authorfauxpark <fauxpark@gmail.com>2019-10-22 15:43:18 +1100
committernoroadsleft <18669334+noroadsleft@users.noreply.github.com>2019-10-21 21:43:18 -0700
commit2ee961c9e873d577e711431ae0960aa21629525e (patch)
tree0ab1aa27f879c732cf29a75f49e7d6ab3e4ad125 /keyboards/keebio/iris
parentc44aff5f18b287bae718c934a9943eae97585cba (diff)
downloadfirmware-2ee961c9e873d577e711431ae0960aa21629525e.tar.gz
firmware-2ee961c9e873d577e711431ae0960aa21629525e.tar.bz2
firmware-2ee961c9e873d577e711431ae0960aa21629525e.zip
Cleanup rules.mk for 32U4 keyboards, I-K (#7097)
* Cleanup rules.mk for 32U4 keyboards, I-K * Clean up ivy rules.mk
Diffstat (limited to 'keyboards/keebio/iris')
-rw-r--r--keyboards/keebio/iris/rules.mk19
1 files changed, 9 insertions, 10 deletions
diff --git a/keyboards/keebio/iris/rules.mk b/keyboards/keebio/iris/rules.mk
index 83b13b160..ed730b02b 100644
--- a/keyboards/keebio/iris/rules.mk
+++ b/keyboards/keebio/iris/rules.mk
@@ -1,12 +1,14 @@
+# MCU name
MCU = atmega32u4
-F_CPU = 16000000
-ARCH = AVR8
-F_USB = $(F_CPU)
-# Bootloader
-# This definition is optional, and if your keyboard supports multiple bootloaders of
-# different sizes, comment this out, and the correct address will be loaded
-# automatically (+60). See bootloader.mk for all options.
+# Bootloader selection
+# Teensy halfkay
+# Pro Micro caterina
+# Atmel DFU atmel-dfu
+# LUFA DFU lufa-dfu
+# QMK DFU qmk-dfu
+# ATmega32A bootloadHID
+# ATmega328P USBasp
ifneq (, $(findstring rev3, $(KEYBOARD)))
BOOTLOADER = qmk-dfu
else ifneq (, $(findstring rev4, $(KEYBOARD)))
@@ -15,9 +17,6 @@ else
BOOTLOADER = caterina
endif
-# Interrupt driven control endpoint task(+60)
-OPT_DEFS += -DINTERRUPT_CONTROL_ENDPOINT
-
# Build Options
# change to "no" to disable the options, or define them in the Makefile in
# the appropriate keymap folder that will get included automatically