aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/keybage/radpad/radpad.c
diff options
context:
space:
mode:
authorBrandon Schlack <brandonschlack@gmail.com>2020-07-26 14:32:04 -0700
committerGitHub <noreply@github.com>2020-07-26 22:32:04 +0100
commita6a13f96262ef1e8c91546f24cff5067f8026c23 (patch)
treef447259c07ca4e5d04d6e9d7e2080792a35673a2 /keyboards/keybage/radpad/radpad.c
parentd2be3a7339fe42629f3616a00708c5e74d84fe61 (diff)
downloadfirmware-a6a13f96262ef1e8c91546f24cff5067f8026c23.tar.gz
firmware-a6a13f96262ef1e8c91546f24cff5067f8026c23.tar.bz2
firmware-a6a13f96262ef1e8c91546f24cff5067f8026c23.zip
[Keyboard] Add Keybage folder for RadPad (#9745)
* [Keyboard] Initial Keybage/RadPad firmware * [Keyboard] RadPad apply pull request feedback - Change `LAYOUT_***_Encoders` to `LAYOUT_***_encoders` in <keyboard>.h - Remove bootloader comments and unnecessary build options from rules.mk - Use `LTO_ENABLE` - Remove empty config.h from default keymap - Remove trailing ` \` from keymap * [Keyboard] RadPad fix info.json - Change `LAYOUT_***_Encoders` to `LAYOUT_***_encoders` in info.json * [Keyboard] Add host LED status to OLED display * [Keyboard] Use LAYOUT_4x4_encoders, not LAYOUT * [Keyboard] Use LAYOUT_4x4_encoders, not LAYOUT * [Keyboard] Remove DESCRIPTION from config.h
Diffstat (limited to 'keyboards/keybage/radpad/radpad.c')
-rw-r--r--keyboards/keybage/radpad/radpad.c17
1 files changed, 17 insertions, 0 deletions
diff --git a/keyboards/keybage/radpad/radpad.c b/keyboards/keybage/radpad/radpad.c
new file mode 100644
index 000000000..4a31d8f57
--- /dev/null
+++ b/keyboards/keybage/radpad/radpad.c
@@ -0,0 +1,17 @@
+/* Copyright 2020 Brandon Schlack
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#include "radpad.h"