aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/kyria/keymaps/ninjonas/rules.mk
diff options
context:
space:
mode:
authorJonas Avellana <14019120+ninjonas@users.noreply.github.com>2020-02-03 18:50:50 -0700
committerGitHub <noreply@github.com>2020-02-04 12:50:50 +1100
commit50554ca270ae4c58dfa156ae4960e06a7ec6ef31 (patch)
tree0fded0ea9435f3cb05ae8ad5a753a1a22cd76bdb /keyboards/kyria/keymaps/ninjonas/rules.mk
parentc6f389b527e04e11e62a11e329f8f52b67a47d63 (diff)
downloadfirmware-50554ca270ae4c58dfa156ae4960e06a7ec6ef31.tar.gz
firmware-50554ca270ae4c58dfa156ae4960e06a7ec6ef31.tar.bz2
firmware-50554ca270ae4c58dfa156ae4960e06a7ec6ef31.zip
Ninjonas userspace (#8070)
* [keymap(kyria)] moved OLED & encoder implementation to separate classes * [feat] created logic to cycle through hue wheel when starting keyboard * [feat] created logic to cycle through hue wheel and return to user's default color * [refactor] updating OLED layout for crkbd & lily58 * [refactor] updating OLED layout for crkbd & lily58 * [fix(8070)] updating encoder.c logic based off drashna's code review * [refactor(8070)] added key to send  + Shift + M
Diffstat (limited to 'keyboards/kyria/keymaps/ninjonas/rules.mk')
-rw-r--r--keyboards/kyria/keymaps/ninjonas/rules.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/keyboards/kyria/keymaps/ninjonas/rules.mk b/keyboards/kyria/keymaps/ninjonas/rules.mk
index 13bc4cf97..3b2894a17 100644
--- a/keyboards/kyria/keymaps/ninjonas/rules.mk
+++ b/keyboards/kyria/keymaps/ninjonas/rules.mk
@@ -1,4 +1,7 @@
OLED_DRIVER_ENABLE = yes # Enables the use of OLED displays
ENCODER_ENABLE = yes # Enables the use of one or more encoders
RGBLIGHT_ENABLE = yes # Enable keyboard RGB underglow
-LINK_TIME_OPTIMIZATION_ENABLE = yes \ No newline at end of file
+LINK_TIME_OPTIMIZATION_ENABLE = yes
+
+SRC += encoder.c \
+ oled.c \ No newline at end of file