aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/marksard/rhymestone/rules.mk
diff options
context:
space:
mode:
authormarksard <38324387+marksard@users.noreply.github.com>2020-09-04 20:14:34 +0900
committerGitHub <noreply@github.com>2020-09-04 04:14:34 -0700
commit6e32dd123ff0ff49768f43c97bbc10836ff8a629 (patch)
tree02e1288b9873a41af13707447985d4318372b9d4 /keyboards/marksard/rhymestone/rules.mk
parent82a830196f5a71ced413af302ce4dd12ec034782 (diff)
downloadfirmware-6e32dd123ff0ff49768f43c97bbc10836ff8a629.tar.gz
firmware-6e32dd123ff0ff49768f43c97bbc10836ff8a629.tar.bz2
firmware-6e32dd123ff0ff49768f43c97bbc10836ff8a629.zip
[Keyboard] add rhymestone by marksard (#9708)
* Keyboard: add treeadstone48 * rename layout defines * Use of pragma once * move common include code * fixed info.json * change keymap layout from kc to normal * fix alpha revision keymap * fixed info.json * remove USE_Link_Time_Optimization * Add keyboard the Rhymestone * fixed by PR review * fixed by review * Update keyboards/rhymestone/readme.md fixed * Fixed possible changes to oled_write_P * Change the name of the layout definition * Update keyboards/rhymestone/info.json * Update keyboards/rhymestone/keymaps/default/keymap.c * Update keyboards/rhymestone/keymaps/default/keymap.c * Update keyboards/rhymestone/keymaps/default/keymap.c * Update keyboards/rhymestone/keymaps/default/keymap.c * Update keyboards/rhymestone/keymaps/switch_tester/keymap.c * Update keyboards/rhymestone/keymaps/switch_tester/keymap.c * Update keyboards/rhymestone/rev1/rev1.h * add empty rules.mk in rev1 * Update from other review * Update keyboards/rhymestone/rules.mk * fixed other review * move rhymestone to marksard directory * move rhymestone to marksard directory (Commit the necessary modifications) * remove
Diffstat (limited to 'keyboards/marksard/rhymestone/rules.mk')
-rw-r--r--keyboards/marksard/rhymestone/rules.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/keyboards/marksard/rhymestone/rules.mk b/keyboards/marksard/rhymestone/rules.mk
new file mode 100644
index 000000000..1f58665ef
--- /dev/null
+++ b/keyboards/marksard/rhymestone/rules.mk
@@ -0,0 +1,27 @@
+# MCU name
+MCU = atmega32u4
+
+# Bootloader selection
+BOOTLOADER = caterina
+
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = no # Mouse keys
+EXTRAKEY_ENABLE = no # Audio control and System control
+CONSOLE_ENABLE = no # Console for debug
+COMMAND_ENABLE = no # Commands for debug and configuration
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+NKRO_ENABLE = yes # USB Nkey Rollover
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = no # Enable keyboard RGB underglow
+BLUETOOTH_ENABLE = no # Enable Bluetooth
+AUDIO_ENABLE = no # Audio output
+SPLIT_KEYBOARD = yes
+
+DEFAULT_FOLDER = marksard/rhymestone/rev1
+
+LAYOUTS = ortho_4x10