aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/mechlovin/hannah910/rules.mk
diff options
context:
space:
mode:
authormechlovin <57231893+mechlovin@users.noreply.github.com>2019-11-02 08:47:26 +0700
committerDrashna Jaelre <drashna@live.com>2019-11-01 18:47:26 -0700
commitf5cf5b950f04659ae7faf1534650092023adb468 (patch)
treed2c693409ccb9b46c2f769230ebd678e08c02459 /keyboards/mechlovin/hannah910/rules.mk
parent3546932a8b25ea199f33b8a39c49ccaa5f7ca3c9 (diff)
downloadfirmware-f5cf5b950f04659ae7faf1534650092023adb468.tar.gz
firmware-f5cf5b950f04659ae7faf1534650092023adb468.tar.bz2
firmware-f5cf5b950f04659ae7faf1534650092023adb468.zip
[Keyboard] Add Hannah910 (#7234)
* Add new PCB Hannah910 a replace pcb for tgr910 keyboard * Update readme.md * update
Diffstat (limited to 'keyboards/mechlovin/hannah910/rules.mk')
-rw-r--r--keyboards/mechlovin/hannah910/rules.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/keyboards/mechlovin/hannah910/rules.mk b/keyboards/mechlovin/hannah910/rules.mk
new file mode 100644
index 000000000..5e17282eb
--- /dev/null
+++ b/keyboards/mechlovin/hannah910/rules.mk
@@ -0,0 +1,33 @@
+# MCU name
+MCU = atmega32u4
+
+# Bootloader selection
+# Teensy halfkay
+# Pro Micro caterina
+# Atmel DFU atmel-dfu
+# LUFA DFU lufa-dfu
+# QMK DFU qmk-dfu
+# ATmega32A bootloadHID
+# ATmega328P USBasp
+BOOTLOADER = atmel-dfu
+
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = lite # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = no # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = no # Console for debug
+COMMAND_ENABLE = no # Commands for debug and configuration
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+NKRO_ENABLE = no # USB Nkey Rollover
+BACKLIGHT_ENABLE = yes # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = yes # Enable keyboard RGB underglow
+MIDI_ENABLE = no # MIDI support
+UNICODE_ENABLE = no # Unicode
+BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
+AUDIO_ENABLE = no # Audio output on port C6
+FAUXCLICKY_ENABLE = no # Use buzzer to emulate clicky switches
+HD44780_ENABLE = no # Enable support for HD44780 based LCDs \ No newline at end of file