aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/mechlovin/kanu/rules.mk
diff options
context:
space:
mode:
authormechlovin <57231893+mechlovin@users.noreply.github.com>2020-08-01 03:19:47 +0700
committerGitHub <noreply@github.com>2020-07-31 13:19:47 -0700
commita1c89fec72fd448aee5991da1a537aa235878f15 (patch)
tree9938b1683ff1dcac89c05550cd8e50c16659f157 /keyboards/mechlovin/kanu/rules.mk
parent1a49eb5be12fd5a32d59103427c71ee4869eea49 (diff)
downloadfirmware-a1c89fec72fd448aee5991da1a537aa235878f15.tar.gz
firmware-a1c89fec72fd448aee5991da1a537aa235878f15.tar.bz2
firmware-a1c89fec72fd448aee5991da1a537aa235878f15.zip
[Keyboard] Kanu PCB (#9729)
* add Kanu PCB * update * update * update * Update info.json * Update config.h * Update info.json * Update info.json * update * Update rules.mk
Diffstat (limited to 'keyboards/mechlovin/kanu/rules.mk')
-rw-r--r--keyboards/mechlovin/kanu/rules.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/keyboards/mechlovin/kanu/rules.mk b/keyboards/mechlovin/kanu/rules.mk
new file mode 100644
index 000000000..47edeec7c
--- /dev/null
+++ b/keyboards/mechlovin/kanu/rules.mk
@@ -0,0 +1,24 @@
+# MCU name
+MCU = atmega32u4
+
+# Bootloader selection
+BOOTLOADER = atmel-dfu
+
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = lite # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = yes # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = no # Console for debug
+COMMAND_ENABLE = no # Commands for debug and configuration
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+NKRO_ENABLE = yes # USB Nkey Rollover
+BACKLIGHT_ENABLE = yes # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = yes # Enable keyboard RGB underglow
+BLUETOOTH_ENABLE = no # Enable Bluetooth
+AUDIO_ENABLE = no # Audio output
+
+LAYOUTS = 65_ansi_blocker