aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/mschwingen/modelm/led_ws2812
diff options
context:
space:
mode:
authorMichael Schwingen <spam-github@discworld.dascon.de>2020-08-23 01:02:16 +0200
committerGitHub <noreply@github.com>2020-08-22 16:02:16 -0700
commit42eeb315a5424fc576239b7e57061affc2ffa8ab (patch)
treeeb04ba06dfe91fea8c530c056e068e50bce2accf /keyboards/mschwingen/modelm/led_ws2812
parentac3dfa742a92de541f86846b94269aab87d55d3c (diff)
downloadfirmware-42eeb315a5424fc576239b7e57061affc2ffa8ab.tar.gz
firmware-42eeb315a5424fc576239b7e57061affc2ffa8ab.tar.bz2
firmware-42eeb315a5424fc576239b7e57061affc2ffa8ab.zip
[Keyboard] add support for ModelM USB board (#9846)
* add support for ModelM USB board * EMI improvement: remove unnecessary toggling of MOSI pin * address review comments * Update keyboards/mschwingen/modelm/rules.mk Co-authored-by: James Young <18669334+noroadsleft@users.noreply.github.com> * Update keyboards/mschwingen/modelm/rules.mk Co-authored-by: James Young <18669334+noroadsleft@users.noreply.github.com> * Update keyboards/mschwingen/modelm/config.h Co-authored-by: James Young <18669334+noroadsleft@users.noreply.github.com> * Update keyboards/mschwingen/modelm/config.h Co-authored-by: James Young <18669334+noroadsleft@users.noreply.github.com> * Update keyboards/mschwingen/modelm/rules.mk Co-authored-by: Drashna Jaelre <drashna@live.com> * Update keyboards/mschwingen/modelm/keymaps/default/keymap.c Co-authored-by: Drashna Jaelre <drashna@live.com> * update printf usage * add comment * EMI improvement: remove unnecessary toggling of MOSI signal * remove trailing space * use shorter macros as suggested in review by noroadsleft, re-format table to line up columns * Update keyboards/mschwingen/modelm/config.h Co-authored-by: Ryan <fauxpark@gmail.com> * Update keyboards/mschwingen/modelm/rules.mk Co-authored-by: Ryan <fauxpark@gmail.com> * Update keyboards/mschwingen/modelm/rules.mk Co-authored-by: Ryan <fauxpark@gmail.com> * Update keyboards/mschwingen/modelm/rules.mk Co-authored-by: Ryan <fauxpark@gmail.com> * Update keyboards/mschwingen/modelm/README.md Co-authored-by: Ryan <fauxpark@gmail.com> * Update keyboards/mschwingen/modelm/README.md Co-authored-by: Ryan <fauxpark@gmail.com> * Apply suggestions from code review use spi_read from core insteads of our own copy Co-authored-by: Ryan <fauxpark@gmail.com> * include spi_master.c to use spi_read() * Update keyboards/mschwingen/modelm/README.md Co-authored-by: James Young <18669334+noroadsleft@users.noreply.github.com> * Apply suggestions from code review: correct indenting in keymap Co-authored-by: James Young <18669334+noroadsleft@users.noreply.github.com> * Apply suggestions from code review use automatic variant defines from makefile instead of defining our own Co-authored-by: Drashna Jaelre <drashna@live.com> * Update keyboards/mschwingen/modelm/rules.mk: use QUANTUM_LIB_SRC for uart.c Co-authored-by: Drashna Jaelre <drashna@live.com> Co-authored-by: Michael Schwingen <michael@schwingen.org> Co-authored-by: James Young <18669334+noroadsleft@users.noreply.github.com> Co-authored-by: Drashna Jaelre <drashna@live.com> Co-authored-by: Ryan <fauxpark@gmail.com>
Diffstat (limited to 'keyboards/mschwingen/modelm/led_ws2812')
-rw-r--r--keyboards/mschwingen/modelm/led_ws2812/rules.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/keyboards/mschwingen/modelm/led_ws2812/rules.mk b/keyboards/mschwingen/modelm/led_ws2812/rules.mk
new file mode 100644
index 000000000..424388fd8
--- /dev/null
+++ b/keyboards/mschwingen/modelm/led_ws2812/rules.mk
@@ -0,0 +1,2 @@
+# variant for WS2812 LEDs
+SRC += ws2812.c