aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/nafuda/nafuda.h
diff options
context:
space:
mode:
authorSalicylic-acid3 <46864619+Salicylic-acid3@users.noreply.github.com>2019-11-16 03:20:57 +0900
committerJames Young <18669334+noroadsleft@users.noreply.github.com>2019-11-15 10:20:57 -0800
commitad36bb37dd775de5132a68fbd6ad9cdf73b0c070 (patch)
tree25e68a9a00e4958d77e8f7537f723bef2c79b57f /keyboards/nafuda/nafuda.h
parent1c9e4502181dc36ed9853dec4341765c87530240 (diff)
downloadfirmware-ad36bb37dd775de5132a68fbd6ad9cdf73b0c070.tar.gz
firmware-ad36bb37dd775de5132a68fbd6ad9cdf73b0c070.tar.bz2
firmware-ad36bb37dd775de5132a68fbd6ad9cdf73b0c070.zip
[Keyboard] Add keyboard Nafuda (#7367)
* [Keyboard] Add keyboard Nafuda Add Nafuda keyboard. A 7 keys keyboard. Salicylic-acid3 * Update keyboards/nafuda/info.json * Update keyboards/nafuda/readme.md * Update keyboards/nafuda/readme.md * Update keyboards/nafuda/nafuda.h * Update keyboards/nafuda/readme.md * Update keyboards/nafuda/rules.mk * Update keyboards/nafuda/rules.mk * Update keyboards/nafuda/rules.mk * Update keyboards/nafuda/rules.mk * info.json Update * Update keyboards/nafuda/rules.mk
Diffstat (limited to 'keyboards/nafuda/nafuda.h')
-rw-r--r--keyboards/nafuda/nafuda.h24
1 files changed, 24 insertions, 0 deletions
diff --git a/keyboards/nafuda/nafuda.h b/keyboards/nafuda/nafuda.h
new file mode 100644
index 000000000..008a9c16f
--- /dev/null
+++ b/keyboards/nafuda/nafuda.h
@@ -0,0 +1,24 @@
+#pragma once
+
+#include "quantum.h"
+
+/*
+ * ,-----------------.
+ * | | L01 | |
+ * |-----------------+
+ * | L10 | L11 | L12 |
+ * |-----------------+
+ * | L20 | L21 | L22 |
+ * |-----------------'
+ */
+
+#define LAYOUT( \
+ L01, \
+ L10, L11, L12, \
+ L20, L21, L22 \
+ ) \
+ { \
+ {KC_NO, L01,KC_NO }, \
+ { L10, L11, L12 }, \
+ { L20, L21, L22 } \
+ }