aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/nckiibs/vaneelaex/info.json
diff options
context:
space:
mode:
authorWoongki Sung <noclew@users.noreply.github.com>2020-08-09 10:50:48 -0400
committerGitHub <noreply@github.com>2020-08-09 07:50:48 -0700
commit98e1e18f6bcae6977ef56747243158eb94c6bd69 (patch)
tree569df17e2ddc6a0881188a5ec9edf3cb1c70ccf0 /keyboards/nckiibs/vaneelaex/info.json
parent215b71716a90f1a258645ad4f924609afa9cb886 (diff)
downloadfirmware-98e1e18f6bcae6977ef56747243158eb94c6bd69.tar.gz
firmware-98e1e18f6bcae6977ef56747243158eb94c6bd69.tar.bz2
firmware-98e1e18f6bcae6977ef56747243158eb94c6bd69.zip
[Keyboard] Add Flatbread60, Vaneela, and VaneelaEx by nckiibs (#9817)
* creOnic added * made requested changed by a moderator * device name changed * fixed flatbread60 files * add vaneela and vaneelaEX support * Update keyboards/nckiibs/vaneelaex/rules.mk * vaneela rgb disabled * include error fxied * vaneelaex Via keymap fixed * vaneelaex keymap fixed * all fixed except clang part * vaneelaex config.h error fixed, clang fixed * Update keyboards/nckiibs/flatbread60/keymaps/default/keymap.c * Update keyboards/nckiibs/flatbread60/keymaps/default/keymap.c done * Update keyboards/nckiibs/flatbread60/keymaps/default/keymap.c done * Update keyboards/nckiibs/flatbread60/keymaps/default/keymap.c done * Update keyboards/nckiibs/flatbread60/keymaps/default/keymap.c done * Update keyboards/nckiibs/flatbread60/keymaps/default/keymap.c * Update keyboards/nckiibs/flatbread60/keymaps/default/keymap.c * Update keyboards/nckiibs/flatbread60/keymaps/default/keymap.c * Update keyboards/nckiibs/flatbread60/keymaps/default/keymap.c * Update keyboards/nckiibs/flatbread60/keymaps/default/keymap.c * Update keyboards/nckiibs/flatbread60/rules.mk done * line endings were fixed as requested * Apply suggestions from code review Thank you! * requests applied and rebased * pics changed * flatbread via fixed * Apply suggestions from code review Thanks! * Apply suggestions from code review Done! * Apply suggestions from code review except VIA keymaps Questions regarding VIA keymaps are pending * Update keyboards/nckiibs/flatbread60/keymaps/default/keymap.c * flatbread via keymap changed * Apply suggestions from code review
Diffstat (limited to 'keyboards/nckiibs/vaneelaex/info.json')
-rw-r--r--keyboards/nckiibs/vaneelaex/info.json326
1 files changed, 326 insertions, 0 deletions
diff --git a/keyboards/nckiibs/vaneelaex/info.json b/keyboards/nckiibs/vaneelaex/info.json
new file mode 100644
index 000000000..aa5b81f4d
--- /dev/null
+++ b/keyboards/nckiibs/vaneelaex/info.json
@@ -0,0 +1,326 @@
+{
+ "keyboard_name": "VaneelaEx",
+ "url": "http://www.keyboard-layout-editor.com/#/gists/f605c1a2cb2fea256161964740bd2a52",
+ "maintainer": "qmk",
+ "width": 16.5,
+ "height": 4,
+ "layouts": {
+ "LAYOUT_ss_6x12": {
+ "layout": [
+ {
+ "x": 0,
+ "y": 0
+ },
+ {
+ "label": "7",
+ "x": 1,
+ "y": 0
+ },
+ {
+ "label": "8",
+ "x": 2,
+ "y": 0
+ },
+ {
+ "label": "9",
+ "x": 3,
+ "y": 0
+ },
+ {
+ "label": "TAB",
+ "x": 4,
+ "y": 0
+ },
+ {
+ "label": "Q",
+ "x": 5,
+ "y": 0
+ },
+ {
+ "label": "W",
+ "x": 6,
+ "y": 0
+ },
+ {
+ "label": "E",
+ "x": 7,
+ "y": 0
+ },
+ {
+ "label": "R",
+ "x": 8,
+ "y": 0
+ },
+ {
+ "label": "T",
+ "x": 9,
+ "y": 0
+ },
+ {
+ "label": "Y",
+ "x": 10,
+ "y": 0
+ },
+ {
+ "label": "U",
+ "x": 11,
+ "y": 0
+ },
+ {
+ "label": "I",
+ "x": 12,
+ "y": 0
+ },
+ {
+ "label": "O",
+ "x": 13,
+ "y": 0
+ },
+ {
+ "label": "P",
+ "x": 14,
+ "y": 0
+ },
+ {
+ "label": "BS",
+ "x": 15,
+ "y": 0,
+ "w": 1.5
+ },
+ {
+ "x": 0,
+ "y": 1
+ },
+ {
+ "label": "4",
+ "x": 1,
+ "y": 1
+ },
+ {
+ "label": "5",
+ "x": 2,
+ "y": 1
+ },
+ {
+ "label": "6",
+ "x": 3,
+ "y": 1
+ },
+ {
+ "label": "ESC",
+ "x": 4,
+ "y": 1,
+ "w": 1.25
+ },
+ {
+ "label": "A",
+ "x": 5.25,
+ "y": 1
+ },
+ {
+ "label": "S",
+ "x": 6.25,
+ "y": 1
+ },
+ {
+ "label": "D",
+ "x": 7.25,
+ "y": 1
+ },
+ {
+ "label": "F",
+ "x": 8.25,
+ "y": 1
+ },
+ {
+ "label": "G",
+ "x": 9.25,
+ "y": 1
+ },
+ {
+ "label": "H",
+ "x": 10.25,
+ "y": 1
+ },
+ {
+ "label": "J",
+ "x": 11.25,
+ "y": 1
+ },
+ {
+ "label": "K",
+ "x": 12.25,
+ "y": 1
+ },
+ {
+ "label": "L",
+ "x": 13.25,
+ "y": 1
+ },
+ {
+ "label": ";",
+ "x": 14.25,
+ "y": 1
+ },
+ {
+ "label": "ENTER",
+ "x": 15.25,
+ "y": 1,
+ "w": 1.25
+ },
+ {
+ "x": 0,
+ "y": 2
+ },
+ {
+ "label": "1",
+ "x": 1,
+ "y": 2
+ },
+ {
+ "label": "2",
+ "x": 2,
+ "y": 2
+ },
+ {
+ "label": "3",
+ "x": 3,
+ "y": 2
+ },
+ {
+ "label": "SHIFT",
+ "x": 4,
+ "y": 2,
+ "w": 1.5
+ },
+ {
+ "label": "Z",
+ "x": 5.5,
+ "y": 2
+ },
+ {
+ "label": "X",
+ "x": 6.5,
+ "y": 2
+ },
+ {
+ "label": "C",
+ "x": 7.5,
+ "y": 2
+ },
+ {
+ "label": "V",
+ "x": 8.5,
+ "y": 2
+ },
+ {
+ "label": "B",
+ "x": 9.5,
+ "y": 2
+ },
+ {
+ "label": "N",
+ "x": 10.5,
+ "y": 2
+ },
+ {
+ "label": "M",
+ "x": 11.5,
+ "y": 2
+ },
+ {
+ "label": ",",
+ "x": 12.5,
+ "y": 2
+ },
+ {
+ "label": ".",
+ "x": 13.5,
+ "y": 2
+ },
+ {
+ "label": "/",
+ "x": 14.5,
+ "y": 2
+ },
+ {
+ "label": "SHIFT",
+ "x": 15.5,
+ "y": 2
+ },
+ {
+ "x": 0,
+ "y": 3
+ },
+ {
+ "x": 1,
+ "y": 3
+ },
+ {
+ "x": 2,
+ "y": 3
+ },
+ {
+ "label": "0",
+ "x": 3,
+ "y": 3
+ },
+ {
+ "label": "CTRL",
+ "x": 4,
+ "y": 3
+ },
+ {
+ "label": "GUI",
+ "x": 5,
+ "y": 3
+ },
+ {
+ "label": "ALT",
+ "x": 6,
+ "y": 3
+ },
+ {
+ "x": 7,
+ "y": 3
+ },
+ {
+ "label": "LOWER",
+ "x": 8,
+ "y": 3,
+ "w": 1.25
+ },
+ {
+ "x": 9.25,
+ "y": 3
+ },
+ {
+ "x": 10.25,
+ "y": 3
+ },
+ {
+ "label": "RAISE",
+ "x": 11.25,
+ "y": 3,
+ "w": 1.25
+ },
+ {
+ "x": 12.5,
+ "y": 3
+ },
+ {
+ "x": 13.5,
+ "y": 3
+ },
+ {
+ "x": 14.5,
+ "y": 3
+ },
+ {
+ "x": 15.5,
+ "y": 3
+ }
+ ]
+ }
+ }
+}