aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/nebula65/rules.mk
diff options
context:
space:
mode:
authoryiancar <yiangosyiangou@cytanet.com.cy>2020-06-16 22:02:01 +0100
committerGitHub <noreply@github.com>2020-06-16 14:02:01 -0700
commit0b7b74f56a68bdae82e74c61de22f9eae42488d7 (patch)
treeb4fc45bec829f9adf9e1f81d88e867d2a2aca957 /keyboards/nebula65/rules.mk
parent80b2b710da1795940ec519909594bd19872346ec (diff)
downloadfirmware-0b7b74f56a68bdae82e74c61de22f9eae42488d7.tar.gz
firmware-0b7b74f56a68bdae82e74c61de22f9eae42488d7.tar.bz2
firmware-0b7b74f56a68bdae82e74c61de22f9eae42488d7.zip
Nebula65 (#9368)
* Initial nebula65 commit * Use PWM driver * Polishing * Remove random rgblight settings * Spelling fix * Update keyboards/nebula65/keymaps/default/readme.md Co-authored-by: Ryan <fauxpark@gmail.com> * Update keyboards/nebula65/keymaps/via/readme.md Co-authored-by: Ryan <fauxpark@gmail.com> * Update keyboards/nebula65/readme.md Co-authored-by: Ryan <fauxpark@gmail.com> * Update keyboards/nebula65/readme.md Co-authored-by: Ryan <fauxpark@gmail.com> * Clean includes in .h file * Update keyboards/nebula65/readme.md Co-authored-by: Drashna Jaelre <drashna@live.com> * Further cleanup Co-authored-by: Ryan <fauxpark@gmail.com> Co-authored-by: Drashna Jaelre <drashna@live.com>
Diffstat (limited to 'keyboards/nebula65/rules.mk')
-rwxr-xr-xkeyboards/nebula65/rules.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/keyboards/nebula65/rules.mk b/keyboards/nebula65/rules.mk
new file mode 100755
index 000000000..399385b3e
--- /dev/null
+++ b/keyboards/nebula65/rules.mk
@@ -0,0 +1,34 @@
+# MCU name
+MCU = STM32F303
+
+# Do not put the microcontroller into power saving mode
+# when we get USB suspend event. We want it to keep updating
+# backlight effects.
+OPT_DEFS += -DNO_SUSPEND_POWER_DOWN
+
+# Build Options
+# comment out to disable the options.
+#
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+BOOTMAGIC_ENABLE = lite # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = yes # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = no # Console for debug
+COMMAND_ENABLE = no # Commands for debug and configuration
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+NKRO_ENABLE = yes # USB Nkey Rollover
+AUDIO_ENABLE = no # Audio output on port C6
+NO_USB_STARTUP_CHECK = no # Disable initialization only when usb is plugged in
+RGBLIGHT_ENABLE = yes # Underglow RGB
+WS2812_DRIVER = pwm # Underglow RGB Driver
+
+CIE1931_CURVE = yes
+
+LAYOUTS = 68_ansi
+
+# project specific files
+SRC += keyboards/wilba_tech/wt_main.c \
+ keyboards/wilba_tech/wt_rgb_backlight.c \
+ drivers/issi/is31fl3733.c \
+ quantum/color.c
+QUANTUM_LIB_SRC += drivers/chibios/i2c_master.c