aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/ortho5by12/ortho5by12.c
diff options
context:
space:
mode:
authoritsnoteasy <pyrosoma1@yahoo.ie>2020-06-05 07:55:39 +0100
committerGitHub <noreply@github.com>2020-06-04 23:55:39 -0700
commita68b0ed9a25dcbfd616faabab10a123c3c0710fd (patch)
tree11b3f0ef4def38a83b1d430a96fb2f1d50e6cc98 /keyboards/ortho5by12/ortho5by12.c
parenta2dee4494d27a0a7d6075317a1b41e0ff4db194f (diff)
downloadfirmware-a68b0ed9a25dcbfd616faabab10a123c3c0710fd.tar.gz
firmware-a68b0ed9a25dcbfd616faabab10a123c3c0710fd.tar.bz2
firmware-a68b0ed9a25dcbfd616faabab10a123c3c0710fd.zip
[Keyboard] Add ortho5by12 keyboard (#9141)
* Add files via upload * Update keyboards/ortho5by12/rules.mk * Add files via upload * Add files via upload * Update keyboards/ortho5by12/ortho5by12.h * Update keyboards/ortho5by12/ortho5by12.h * Add files via upload * Add files via upload * Update keyboards/ortho5by12/readme.md * Update keyboards/ortho5by12/readme.md * Update keyboards/ortho5by12/readme.md * Update keyboards/ortho5by12/readme.md * Update keyboards/ortho5by12/readme.md * Update keyboards/ortho5by12/readme.md * Update keyboards/ortho5by12/info.json * Update keyboards/ortho5by12/ortho5by12.h * Apply suggestions from code review * Update rules.mk * Update config.h * Update config.h * Update config.h * Delete rules.mk * Delete config.h * Delete info.json * Delete ortho5by12.c * Delete ortho5by12.h * Delete readme.md * Delete keymap.c
Diffstat (limited to 'keyboards/ortho5by12/ortho5by12.c')
-rw-r--r--keyboards/ortho5by12/ortho5by12.c30
1 files changed, 30 insertions, 0 deletions
diff --git a/keyboards/ortho5by12/ortho5by12.c b/keyboards/ortho5by12/ortho5by12.c
new file mode 100644
index 000000000..615ab9d04
--- /dev/null
+++ b/keyboards/ortho5by12/ortho5by12.c
@@ -0,0 +1,30 @@
+/* Copyright 2019 Takuya Urakawa (dm9records.com)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+#include "ortho5by12.h"
+
+void matrix_init_kb(void) {
+ setPinOutput(C4);
+ setPinOutput(C5);
+}
+
+bool led_update_kb(led_t led_state) {
+ bool res = led_update_user(led_state);
+ if(res) {
+ writePin(C4, led_state.num_lock);
+ writePin(C5, led_state.caps_lock);
+ }
+ return res;
+}