aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/palette1202/keymaps/default/config.h
diff options
context:
space:
mode:
authorTakashi Shibusawa <futurabodoni@gmail.com>2020-03-10 17:38:37 +0900
committerGitHub <noreply@github.com>2020-03-10 01:38:37 -0700
commit20a0fa9209756288b014f65671bcaab12a028229 (patch)
treeca4aeb513bb1a652584b37e0e0d02d39b882e29b /keyboards/palette1202/keymaps/default/config.h
parent2d14d12c7409e8de3f8d465635be115e06ba26f7 (diff)
downloadfirmware-20a0fa9209756288b014f65671bcaab12a028229.tar.gz
firmware-20a0fa9209756288b014f65671bcaab12a028229.tar.bz2
firmware-20a0fa9209756288b014f65671bcaab12a028229.zip
[Keyboard] Palette1202 (#7736)
* added Palette1202 * removed currently unused cords * Update keyboards/palette1202/config.h Co-Authored-By: Drashna Jaelre <drashna@live.com> * Apply suggestions from code review Co-Authored-By: Drashna Jaelre <drashna@live.com> Co-Authored-By: James Young <18669334+noroadsleft@users.noreply.github.com> * Update readme.md removed unnecessary horizontal line from readme.md * Update readme.md Fixed style, make command example * Removed spaces * removed unused config.h * fixed defines * fixed send string on rotate encoder * fixed layer numbers for OLED Display * fixed to use existing function to set default layer https://github.com/qmk/qmk_firmware/pull/7736#discussion_r366699616 * flipped rotary encoder directions * Added layer for Clip studio on iOS * Update keyboards/palette1202/rules.mk Co-Authored-By: Ryan <fauxpark@gmail.com> * Update keyboards/palette1202/lib/oled_helper.h Co-Authored-By: James Young <18669334+noroadsleft@users.noreply.github.com> Co-authored-by: Drashna Jaelre <drashna@live.com> Co-authored-by: James Young <18669334+noroadsleft@users.noreply.github.com> Co-authored-by: Ryan <fauxpark@gmail.com>
Diffstat (limited to 'keyboards/palette1202/keymaps/default/config.h')
-rw-r--r--keyboards/palette1202/keymaps/default/config.h20
1 files changed, 20 insertions, 0 deletions
diff --git a/keyboards/palette1202/keymaps/default/config.h b/keyboards/palette1202/keymaps/default/config.h
new file mode 100644
index 000000000..a5bb9bbfc
--- /dev/null
+++ b/keyboards/palette1202/keymaps/default/config.h
@@ -0,0 +1,20 @@
+/* Copyright 2019 niltea
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#pragma once
+
+#define TAPPING_FORCE_HOLD
+#define TAPPING_TERM 100