aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/panc60/rules.mk
diff options
context:
space:
mode:
authorMechMerlin <30334081+mechmerlin@users.noreply.github.com>2019-04-06 18:08:57 -0700
committerDrashna Jaelre <drashna@live.com>2019-04-06 18:08:57 -0700
commit5c1ef2bddc0fa5d4753d33a5ec8fed5d9da736c8 (patch)
tree4bb67d40c1bb3d90204977d4d47306859fb2ec2a /keyboards/panc60/rules.mk
parent410984486b0a5c61174c6e4e5a3570f1b09f97dc (diff)
downloadfirmware-5c1ef2bddc0fa5d4753d33a5ec8fed5d9da736c8.tar.gz
firmware-5c1ef2bddc0fa5d4753d33a5ec8fed5d9da736c8.tar.bz2
firmware-5c1ef2bddc0fa5d4753d33a5ec8fed5d9da736c8.zip
[Keyboard] Panc60 Refactor (#5559)
* remove unneeded uart setting * use pragma once everywhere * remove custom matrix support * fixup readme * set bootmagic to lite * remove dependency on custom i2c code * use the right header files and function calls
Diffstat (limited to 'keyboards/panc60/rules.mk')
-rw-r--r--keyboards/panc60/rules.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/keyboards/panc60/rules.mk b/keyboards/panc60/rules.mk
index 588562a95..843875182 100644
--- a/keyboards/panc60/rules.mk
+++ b/keyboards/panc60/rules.mk
@@ -31,7 +31,7 @@ F_CPU = 12000000
BOOTLOADER = bootloadHID
# build options
-BOOTMAGIC_ENABLE = yes
+BOOTMAGIC_ENABLE = lite
MOUSEKEY_ENABLE = yes
EXTRAKEY_ENABLE = yes
CONSOLE_ENABLE = yes
@@ -43,8 +43,7 @@ RGBLIGHT_CUSTOM_DRIVER = yes
OPT_DEFS = -DDEBUG_LEVEL=0
# custom matrix setup
-CUSTOM_MATRIX = yes
-SRC = matrix.c i2c.c
+SRC = i2c_master.c
# programming options
PROGRAM_CMD = ./util/atmega32a_program.py $(TARGET).hex