aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/pegasushoof/keymaps/blowrak/Makefile
diff options
context:
space:
mode:
authorLior Haim <lior@dotcore.co.il>2016-10-23 20:22:28 +0300
committerLior Haim <lior@dotcore.co.il>2016-10-23 20:22:28 +0300
commit0d26320cf34f5b1c823e0f3b28bdb963805bd609 (patch)
treed0c22fc29b456013c671c86c35243da8ee49da19 /keyboards/pegasushoof/keymaps/blowrak/Makefile
parent8727976a1a6d0a1e6749f093828b23265c59a39a (diff)
parent2e2b9962cdc20e9f46dd0194f25a68ffa05e7d36 (diff)
downloadfirmware-0d26320cf34f5b1c823e0f3b28bdb963805bd609.tar.gz
firmware-0d26320cf34f5b1c823e0f3b28bdb963805bd609.tar.bz2
firmware-0d26320cf34f5b1c823e0f3b28bdb963805bd609.zip
merge upstream
Diffstat (limited to 'keyboards/pegasushoof/keymaps/blowrak/Makefile')
-rw-r--r--keyboards/pegasushoof/keymaps/blowrak/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/keyboards/pegasushoof/keymaps/blowrak/Makefile b/keyboards/pegasushoof/keymaps/blowrak/Makefile
new file mode 100644
index 000000000..fec0d2d97
--- /dev/null
+++ b/keyboards/pegasushoof/keymaps/blowrak/Makefile
@@ -0,0 +1,22 @@
+# Build Options
+# change to "no" to disable the options, or define them in the Makefile in
+# the appropriate keymap folder that will get included automatically
+#
+BOOTMAGIC_ENABLE ?= yes # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE ?= yes # Mouse keys(+4700)
+EXTRAKEY_ENABLE ?= yes # Audio control and System control(+450)
+CONSOLE_ENABLE ?= yes # Console for debug(+400)
+COMMAND_ENABLE ?= yes # Commands for debug and configuration
+CUSTOM_MATRIX ?= yes # Custom matrix file for the Pegasus Hoof due to the 2x74HC42
+NKRO_ENABLE ?= no # Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+BACKLIGHT_ENABLE ?= no # Enable keyboard backlight functionality
+MIDI_ENABLE ?= no # MIDI controls
+AUDIO_ENABLE ?= no # Audio output on port C6
+UNICODE_ENABLE ?= no # Unicode
+BLUETOOTH_ENABLE ?= no # Enable Bluetooth with the Adafruit EZ-Key HID
+RGBLIGHT_ENABLE ?= no # Enable WS2812 RGB underlight. Do not enable this with audio at the same time.
+
+
+ifndef QUANTUM_DIR
+ include ../../../../Makefile
+endif