aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/pinky/4/keymaps/via/config.h
diff options
context:
space:
mode:
authorIngar Almklov <ingara@gmail.com>2020-07-25 18:42:50 +0200
committerGitHub <noreply@github.com>2020-07-25 09:42:50 -0700
commit65f4b94cda57a6118b99d36ea0b0ca462e56de5e (patch)
tree20dcc76354370a572a79a16c5bed4471ae7697fe /keyboards/pinky/4/keymaps/via/config.h
parent70a37b9cf5a52fe2d606157c916a561ed954cfc2 (diff)
downloadfirmware-65f4b94cda57a6118b99d36ea0b0ca462e56de5e.tar.gz
firmware-65f4b94cda57a6118b99d36ea0b0ca462e56de5e.tar.bz2
firmware-65f4b94cda57a6118b99d36ea0b0ca462e56de5e.zip
Pinky4: add via support (#9711)
* Pinky4: add via support * Pinky4/via: simplify rules.mk * Pinky4/via: use built-in for KC_TRANS, enum for layer _names * Pinky4/via: remove redundant rules * Pinky4/via: remove unnecessary slashes * Pinky4/via: don't override default bootloader
Diffstat (limited to 'keyboards/pinky/4/keymaps/via/config.h')
-rw-r--r--keyboards/pinky/4/keymaps/via/config.h31
1 files changed, 31 insertions, 0 deletions
diff --git a/keyboards/pinky/4/keymaps/via/config.h b/keyboards/pinky/4/keymaps/via/config.h
new file mode 100644
index 000000000..db7977672
--- /dev/null
+++ b/keyboards/pinky/4/keymaps/via/config.h
@@ -0,0 +1,31 @@
+/* Copyright 2018 'Masayuki Sunahara'
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#pragma once
+
+//#define USE_MATRIX_I2C
+
+/* Select hand configuration */
+
+#define MASTER_LEFT
+// #define MASTER_RIGHT
+// #define EE_HANDS
+
+#define USE_SERIAL_PD2
+
+#define TAPPING_FORCE_HOLD
+#define TAPPING_TERM 200
+#define RETRO_TAPPPING