aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/planck/rules.mk
diff options
context:
space:
mode:
authorJack Humbert <jack.humb@gmail.com>2019-01-10 11:22:57 -0500
committerMechMerlin <30334081+mechmerlin@users.noreply.github.com>2019-01-10 08:22:57 -0800
commit3cf179be61a10860b2b66aecf2ec5ca6f0e30605 (patch)
tree960c7bdde165f4419a96c2d48049e22226912882 /keyboards/planck/rules.mk
parentebbc372f72993123cd24fe27228e8d07c9b8d7fb (diff)
downloadfirmware-3cf179be61a10860b2b66aecf2ec5ca6f0e30605.tar.gz
firmware-3cf179be61a10860b2b66aecf2ec5ca6f0e30605.tar.bz2
firmware-3cf179be61a10860b2b66aecf2ec5ca6f0e30605.zip
Adds Proton C Conversion (#4661)
* adds proton c base * fixes custom matrix include * adds readme.md * initial proton coversion, no pin mapping * start of mcu selection * add pin mapping and sweet16 test * add at90 to list * disable backlight, fix d7 * update flag names * doc updates * proton c update for mcu selection
Diffstat (limited to 'keyboards/planck/rules.mk')
-rw-r--r--keyboards/planck/rules.mk33
1 files changed, 0 insertions, 33 deletions
diff --git a/keyboards/planck/rules.mk b/keyboards/planck/rules.mk
index e194dcd51..609790238 100644
--- a/keyboards/planck/rules.mk
+++ b/keyboards/planck/rules.mk
@@ -1,39 +1,6 @@
# MCU name
-#MCU = at90usb1287
MCU = atmega32u4
-# Processor frequency.
-# This will define a symbol, F_CPU, in all source code files equal to the
-# processor frequency in Hz. You can then use this symbol in your source code to
-# calculate timings. Do NOT tack on a 'UL' at the end, this will be done
-# automatically to create a 32-bit value in your source code.
-#
-# This will be an integer division of F_USB below, as it is sourced by
-# F_USB after it has run through any CPU prescalers. Note that this value
-# does not *change* the processor frequency - it should merely be updated to
-# reflect the processor speed set externally so that the code can use accurate
-# software delays.
-F_CPU = 16000000
-
-#
-# LUFA specific
-#
-# Target architecture (see library "Board Types" documentation).
-ARCH = AVR8
-
-# Input clock frequency.
-# This will define a symbol, F_USB, in all source code files equal to the
-# input clock frequency (before any prescaling is performed) in Hz. This value may
-# differ from F_CPU if prescaling is used on the latter, and is required as the
-# raw input clock is fed directly to the PLL sections of the AVR for high speed
-# clock generation for the USB and other AVR subsections. Do NOT tack on a 'UL'
-# at the end, this will be done automatically to create a 32-bit value in your
-# source code.
-#
-# If no clock division is performed on the input clock inside the AVR (via the
-# CPU clock adjust registers or the clock division fuses), this will be equal to F_CPU.
-F_USB = $(F_CPU)
-
# Bootloader
# This definition is optional, and if your keyboard supports multiple bootloaders of
# different sizes, comment this out, and the correct address will be loaded