aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/qwertyydox/info.json
diff options
context:
space:
mode:
authornoroadsleft <18669334+noroadsleft@users.noreply.github.com>2019-08-01 09:33:13 -0700
committerDrashna Jaelre <drashna@live.com>2019-08-01 09:33:13 -0700
commit9609ae60a657dd6ed6e5ba9830f41ed3c0039c09 (patch)
tree22cecd8b016e7cf105f61e91186788f027413c8b /keyboards/qwertyydox/info.json
parent2a9856dff01c08fe712e97c8e403ba43df507c79 (diff)
downloadfirmware-9609ae60a657dd6ed6e5ba9830f41ed3c0039c09.tar.gz
firmware-9609ae60a657dd6ed6e5ba9830f41ed3c0039c09.tar.bz2
firmware-9609ae60a657dd6ed6e5ba9830f41ed3c0039c09.zip
[Keyboard] QWERTYYdox refactor (#6446)
* Delete null key `__` key in keymap.c doesn't actually exist on the physical hardware. Removed key from keymap.c and removed its argument from the layout macro. * Delete unused keycode aliases * Replace layer index definitions with an enum * Replace redundant numpad keycodes with native aliases * Use native layer change keycodes instead of aliases * Visually align the keycodes It makes the keymap pretty. * Correct Configurator layout data * Clean up header files - convert to pragma once include guard - remove redundant definitions - remove commented code blocks * Delete LAYOUT_kc macro Was copied from ergotravel; not valid for this keyboard. * Consolidate rev1 rules.mk settings to keyboard level Previous codebase enabled Backlight at keyboard level then disabled it at revision level. * Delete unused rules * Consolidate config.h settings from keymap level to keyboard level * Modernize keyboard's config.h file Aligns the keyboard-level config.h file more closely with the current QMK template for AVR keyboards.
Diffstat (limited to 'keyboards/qwertyydox/info.json')
-rw-r--r--keyboards/qwertyydox/info.json58
1 files changed, 56 insertions, 2 deletions
diff --git a/keyboards/qwertyydox/info.json b/keyboards/qwertyydox/info.json
index 3dd6b3ec7..8616f274e 100644
--- a/keyboards/qwertyydox/info.json
+++ b/keyboards/qwertyydox/info.json
@@ -5,12 +5,66 @@
"url": "",
"maintainer": "qmk",
"processor": "atmega32u4",
- "width": 16,
+ "width": 16.25,
"height": 5,
"layouts": {
"LAYOUT": {
"key_count": 53,
- "layout": [{"label":"L00", "x":0, "y":0.375}, {"label":"L01", "x":1, "y":0.25}, {"label":"L02", "x":2, "y":0.125}, {"label":"L03", "x":3, "y":0}, {"label":"L04", "x":4, "y":0.125}, {"label":"L05", "x":5, "y":0.25}, {"label":"L06", "x":6, "y":0.5}, {"label":"R00", "x":9, "y":0.5}, {"label":"R01", "x":10, "y":0.25}, {"label":"R02", "x":11, "y":0.125}, {"label":"R03", "x":12, "y":0}, {"label":"R04", "x":13, "y":0.125}, {"label":"R05", "x":14, "y":0.25}, {"label":"R06", "x":15, "y":0.375}, {"label":"L10", "x":0, "y":1.375}, {"label":"L11", "x":1, "y":1.25}, {"label":"L12", "x":2, "y":1.125}, {"label":"L13", "x":3, "y":1}, {"label":"L14", "x":4, "y":1.125}, {"label":"L15", "x":5, "y":1.25}, {"label":"L16", "x":6, "y":1.5}, {"label":"R10", "x":9, "y":1.5}, {"label":"R11", "x":10, "y":1.25}, {"label":"R12", "x":11, "y":1.125}, {"label":"R13", "x":12, "y":1}, {"label":"R14", "x":13, "y":1.125}, {"label":"R15", "x":14, "y":1.25}, {"label":"R16", "x":15, "y":1.375}, {"label":"L20", "x":0, "y":2.375}, {"label":"L21", "x":1, "y":2.25}, {"label":"L22", "x":2, "y":2.125}, {"label":"L23", "x":3, "y":2}, {"label":"L24", "x":4, "y":2.125}, {"label":"L25", "x":5, "y":2.25}, {"label":"L26", "x":6.5, "y":3}, {"label":"R20", "x":8.5, "y":3}, {"label":"R21", "x":10, "y":2.25}, {"label":"R22", "x":11, "y":2.125}, {"label":"R23", "x":12, "y":2}, {"label":"R24", "x":13, "y":2.125}, {"label":"R25", "x":14, "y":2.25}, {"label":"R26", "x":15, "y":2.375}, {"label":"L30", "x":0, "y":3.375}, {"label":"L31", "x":1, "y":3.25}, {"label":"L32", "x":2, "y":3.125}, {"label":"L33", "x":3, "y":3}, {"label":"L34", "x":5.5, "y":4}, {"label":"L35", "x":6.5, "y":4}, {"label":"R30", "x":8.5, "y":4}, {"label":"R31", "x":9.5, "y":4}, {"label":"R32", "x":12, "y":3}, {"label":"R33", "x":13, "y":3.125}, {"label":"R34", "x":14, "y":3.25}, {"label":"R35", "x":15, "y":3.375}]
+ "layout": [
+ {"label":"Tab", "x":0, "y":0},
+ {"label":"Q", "x":1, "y":0},
+ {"label":"W", "x":2, "y":0},
+ {"label":"E", "x":3, "y":0},
+ {"label":"R", "x":4, "y":0},
+ {"label":"T", "x":5, "y":0},
+ {"label":"Y", "x":6, "y":0},
+ {"label":"Y", "x":9, "y":0},
+ {"label":"U", "x":10, "y":0},
+ {"label":"I", "x":11, "y":0},
+ {"label":"O", "x":12, "y":0},
+ {"label":"P", "x":13, "y":0},
+ {"label":"{", "x":14, "y":0},
+ {"label":"}", "x":15, "y":0},
+ {"label":"Caps Lock", "x":0.25, "y":1},
+ {"label":"A", "x":1.25, "y":1},
+ {"label":"S", "x":2.25, "y":1},
+ {"label":"D", "x":3.25, "y":1},
+ {"label":"F", "x":4.25, "y":1},
+ {"label":"G", "x":5.25, "y":1},
+ {"label":"H", "x":9.25, "y":1},
+ {"label":"J", "x":10.25, "y":1},
+ {"label":"K", "x":11.25, "y":1},
+ {"label":"L", "x":12.25, "y":1},
+ {"label":":", "x":13.25, "y":1},
+ {"label":"\"", "x":14.25, "y":1},
+ {"label":"|", "x":15.25, "y":1},
+ {"label":"Shift", "x":0.75, "y":2},
+ {"label":"Z", "x":1.75, "y":2},
+ {"label":"X", "x":2.75, "y":2},
+ {"label":"C", "x":3.75, "y":2},
+ {"label":"V", "x":4.75, "y":2},
+ {"label":"B", "x":5.75, "y":2},
+ {"label":"N", "x":9.75, "y":2},
+ {"label":"M", "x":10.75, "y":2},
+ {"label":"<", "x":11.75, "y":2},
+ {"label":">", "x":12.75, "y":2},
+ {"label":"?", "x":13.75, "y":2},
+ {"label":"Shift", "x":14.75, "y":2},
+ {"label":"Ctrl", "x":0.75, "y":3},
+ {"label":"GUI", "x":1.75, "y":3},
+ {"label":"Alt", "x":2.75, "y":3},
+ {"label":"\"-QWERTY\"", "x":3.75, "y":3},
+ {"label":"Enter", "x":4.75, "y":3.33},
+ {"label":"Delete", "x":5.75, "y":3.67},
+ {"label":"TO(_NUM)", "x":6.75, "y":4},
+ {"label":"TO(_NAV)", "x":8.75, "y":4},
+ {"label":"Space", "x":9.75, "y":3.67},
+ {"label":"Back Space", "x":10.75, "y":3.33},
+ {"label":"Left", "x":11.75, "y":3},
+ {"label":"Alt", "x":12.75, "y":3},
+ {"label":"GUI", "x":13.75, "y":3},
+ {"label":"Ctrl", "x":14.75, "y":3}
+ ]
}
}
}