aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/rama/m6_a/rules.mk
diff options
context:
space:
mode:
authorWilba <Jason.S.Williams@gmail.com>2018-11-14 03:31:25 +1100
committerDrashna Jaelre <drashna@live.com>2018-11-13 08:31:25 -0800
commit2dea540afbfcffaea82f70b6642c39aedb9e3b5b (patch)
treec61a59306a52a4d12d6b62eec5370721e0777bf4 /keyboards/rama/m6_a/rules.mk
parentcaa293a8f77447891b02d5f8c91b209f9a082cc9 (diff)
downloadfirmware-2dea540afbfcffaea82f70b6642c39aedb9e3b5b.tar.gz
firmware-2dea540afbfcffaea82f70b6642c39aedb9e3b5b.tar.bz2
firmware-2dea540afbfcffaea82f70b6642c39aedb9e3b5b.zip
Refactoring M6-A, M6-B, Zeal60, Zeal65, WT60-A, WT65-A, WT80-A (#4417)
* Refactored M6-B to use Zeal60 RGB backlight code * Fixed M6-B LED co-ordinates * Minor changes to RGB config for Zeal65 * Added dynamic keymaps to WT80-A, WT60-A, WT-80A, U80-A
Diffstat (limited to 'keyboards/rama/m6_a/rules.mk')
-rw-r--r--keyboards/rama/m6_a/rules.mk32
1 files changed, 20 insertions, 12 deletions
diff --git a/keyboards/rama/m6_a/rules.mk b/keyboards/rama/m6_a/rules.mk
index ed85ac36d..ff1706918 100644
--- a/keyboards/rama/m6_a/rules.mk
+++ b/keyboards/rama/m6_a/rules.mk
@@ -1,5 +1,5 @@
# project specific files
-SRC = keyboards/rama/m6_b/m6_b.c
+SRC = ../zeal60/zeal60.c
# MCU name
MCU = atmega32u4
@@ -43,24 +43,32 @@ OPT_DEFS += -DINTERRUPT_CONTROL_ENDPOINT
# Boot Section
BOOTLOADER = atmel-dfu
+# Do not put the microcontroller into power saving mode
+# when we get USB suspend event. We want it to keep updating
+# backlight effects.
+OPT_DEFS += -DNO_SUSPEND_POWER_DOWN
+
+
# Build Options
# change yes to no to disable
#
-BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration(+1000)
+BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration(+1000)
MOUSEKEY_ENABLE = no # Mouse keys(+4700)
EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
-CONSOLE_ENABLE = no # Console for debug(+400)
+CONSOLE_ENABLE = no # Console for debug(+400)
COMMAND_ENABLE = no # Commands for debug and configuration
-# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
-SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
-# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
-NKRO_ENABLE = yes # USB Nkey Rollover
-BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality on B7 by default
-MIDI_ENABLE = no # MIDI support (+2400 to 4200, depending on config)
+NKRO_ENABLE = yes # Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+MIDI_ENABLE = no # MIDI controls
+AUDIO_ENABLE = no # Audio output on port C6
UNICODE_ENABLE = no # Unicode
BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
-AUDIO_ENABLE = no # Audio output on port C6
-FAUXCLICKY_ENABLE = no # Use buzzer to emulate clicky switches
+RGBLIGHT_ENABLE = no # Enable WS2812 RGB underlight. Do not enable this with audio at the same time.
+
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
RAW_ENABLE = yes
-DYNAMIC_KEYMAP_ENABLE = yes \ No newline at end of file
+DYNAMIC_KEYMAP_ENABLE = yes
+CIE1931_CURVE = no
+