aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/s65_x/keymaps/s65plus
diff options
context:
space:
mode:
authornoroadsleft <18669334+noroadsleft@users.noreply.github.com>2019-01-04 21:47:13 -0800
committerMechMerlin <30334081+mechmerlin@users.noreply.github.com>2019-01-04 21:47:13 -0800
commitd6cc90d0277cf084ab16215190ad64d24164f1bc (patch)
treea5b506e29909fb72a46b86d5513b9d1f711ef918 /keyboards/s65_x/keymaps/s65plus
parent3527efcbd21231cf9e7bf7a8de0fa02aa177a957 (diff)
downloadfirmware-d6cc90d0277cf084ab16215190ad64d24164f1bc.tar.gz
firmware-d6cc90d0277cf084ab16215190ad64d24164f1bc.tar.bz2
firmware-d6cc90d0277cf084ab16215190ad64d24164f1bc.zip
S65-X and S65-Plus updates and refactoring (#4780)
* S65-X: remove S65-Plus support The original QMK codebase for the Sentraq S65-X actually supported both the S65-X and the S65-Plus. In the interim, the S65-Plus has been broken off into its own directory. This commit removes support for the S65-Plus from the `keyboards/s65_x/` directory, as that code has been superseded by the code in the S65-Plus directory (`keyboards/s65_plus/`). - deleted S65-Plus layout macros from s65_x.h and info.json - deleted s65plus keymap directory - removed references to the unused column pins - removed the two unused columns for the switch matrices - renamed switch K300 in LAYOUT_ansi to K301 (reflects matrix position) - renamed switch K214 in LAYOUT_iso to K114 (reflects matrix position) * S65-X: keymap refactor - all keymaps now use #include QMK_KEYBOARD_H - default and iso keymaps refactored for readability - deleted redundant KC_TRNS and KC_NO keycode definitions from smt keymap * S65-X: readme update - updated Hardware Availability link - updated Docs links * S65-Plus: add LAYOUT_iso data Adds LAYOUT_iso macro to s65_plus.h and info.json, and an ISO layout version of the default keymap. * S65-Plus: refactor default keymap - refactor for alignment/readability - removed fn_actions code block - add empty process_record_user block * S65-Plus: readme update - Hardware Availability link is now a hyperlink - updated Docs links * S65-X: enable 65_ansi and 65_iso community layouts Thi commit allows the Sentraq S65-X to use the 65_ansi and 65_iso community layouts. - LAYOUT_ansi renamed to LAYOUT_65_ansi - LAYOUT_iso renamed to LAYOUT_65_iso - added LAYOUTS rule to rules.mk
Diffstat (limited to 'keyboards/s65_x/keymaps/s65plus')
-rw-r--r--keyboards/s65_x/keymaps/s65plus/keymap.c30
-rw-r--r--keyboards/s65_x/keymaps/s65plus/readme.md5
2 files changed, 0 insertions, 35 deletions
diff --git a/keyboards/s65_x/keymaps/s65plus/keymap.c b/keyboards/s65_x/keymaps/s65plus/keymap.c
deleted file mode 100644
index 1f3ffa3ab..000000000
--- a/keyboards/s65_x/keymaps/s65plus/keymap.c
+++ /dev/null
@@ -1,30 +0,0 @@
-#include QMK_KEYBOARD_H
-
-#define _BL 0
-#define _FL 1
-
-// readability
-#define _______ KC_TRNS
-#define XXXXXXX KC_NO
-
-
-const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
- /* 0: ANSI qwerty */
- [_BL] = LAYOUT_plus_ansi( \
- KC_F1, KC_F2, KC_ESC, KC_1, KC_2, KC_3, KC_4, KC_5, KC_6, KC_7, KC_8, KC_9, KC_0, KC_MINS, KC_EQL, KC_BSPC, KC_DEL, \
- KC_F3, KC_F4, KC_TAB, KC_Q, KC_W, KC_E, KC_R, KC_T, KC_Y, KC_U, KC_I, KC_O, KC_P, KC_LBRC, KC_RBRC, KC_BSLS, KC_END, \
- KC_F5, KC_F6, KC_CAPS, KC_A, KC_S, KC_D, KC_F, KC_G, KC_H, KC_J, KC_K, KC_L, KC_SCLN, KC_QUOT, KC_ENT, KC_PGUP, \
- KC_F7, KC_F8, KC_LSFT, KC_Z, KC_X, KC_C, KC_V, KC_B, KC_N, KC_M, KC_COMM, KC_DOT, KC_SLSH, KC_RSFT, KC_UP, KC_PGDN, \
- KC_F9, KC_F10, KC_LCTL, KC_LGUI, KC_LALT, KC_SPC, KC_RALT, MO(_FL), KC_RCTL, KC_LEFT, KC_DOWN, KC_RGHT \
- ),
-
-
- [_FL] = LAYOUT_plus_ansi( \
- KC_F1, KC_F2, RESET, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, BL_TOGG, BL_STEP, \
- KC_F3, KC_F4, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, \
- KC_F5, KC_F6, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, \
- KC_F7, KC_F8, _______, RGB_TOG, RGB_MOD, RGB_HUI, RGB_HUD, RGB_SAI, RGB_SAD, RGB_VAI, RGB_VAD, _______, _______, _______, KC_VOLU, _______, \
- KC_F9, KC_F10, _______, _______, _______, _______, _______, _______, _______, KC_MPRV, KC_VOLD, KC_MNXT \
- ),
-
-};
diff --git a/keyboards/s65_x/keymaps/s65plus/readme.md b/keyboards/s65_x/keymaps/s65plus/readme.md
deleted file mode 100644
index f083fb8fd..000000000
--- a/keyboards/s65_x/keymaps/s65plus/readme.md
+++ /dev/null
@@ -1,5 +0,0 @@
-# S65-Plus default keymap
-
-This is the default keymap for the Sentraq S65-Plus.
-
-[S65-Plus default keymap](http://www.keyboard-layout-editor.com/##@@_a:6&f:9&w:9&d:true;&=S65-Plus%20default%20keymap&_w:9&d:true;&=%0A%0ABase%20layer;&@_a:4&f:3;&=F1&=F2&=Esc&=!%0A1&=/@%0A2&=#%0A3&=$%0A4&=%25%0A5&=%5E%0A6&=/&%0A7&=*%0A8&=(%0A9&=)%0A0&=/_%0A-&=+%0A/=&_w:2;&=Backspace&=Delete;&@=F3&=F4&_w:1.5;&=Tab&=Q&=W&=E&=R&=T&=Y&=U&=I&=O&=P&=%7B%0A%5B&=%7D%0A%5D&_w:1.5;&=%7C%0A%5C&=PgUp;&@=F5&=F6&_w:1.75;&=Caps%20Lock&=A&=S&=D&=F&=G&=H&=J&=K&=L&=/:%0A/;&=%22%0A%27&_w:2.25;&=Enter&=PgDn;&@=F7&=F8&_w:2.25;&=Shift&=Z&=X&=C&=V&=B&=N&=M&=%3C%0A,&=%3E%0A.&=?%0A//&_w:1.75;&=Shift&=%E2%86%91&=End;&@=F9&=F10&_w:1.25;&=Ctrl&_w:1.25;&=Win&_w:1.25;&=Alt&_a:7&w:6.25;&=&_a:4;&=Alt&=Fn&=Ctrl&=%E2%86%90&=%E2%86%93&=%E2%86%92;&@_x:9&a:6&f:9&w:9&d:true;&=%0A%0AFunction%20layer;&@_a:7&f:3;&=&=&_a:4;&=Reset&_a:7;&=&=&=&=&=&=&=&=&=&=&=&=&_a:4&w:2;&=Backlight%20Toggle&=Back-light%20Step;&@_a:7;&=&=&_w:1.5;&=&=&=&=&=&=&=&=&=&=&=&=&=&_w:1.5;&=&=;&@=&=&_w:1.75;&=&=&=&=&=&=&=&=&=&=&=&=&_w:2.25;&=&=;&@=&=&_w:2.25;&=&_a:4;&=RGB%20Tog-gle&=RGB%20Mode&=RGB%20Hue%20Inc&=RGB%20Hue%20Dec&=RGB%20Sat%20Inc&=RGB%20Sat%20Dec&=RGB%20Value%20Inc&=RGB%20Value%20Dec&_a:7;&=&=&_w:1.75;&=&_a:4;&=Vol%20Up&_a:7;&=;&@=&=&_w:1.25;&=&_w:1.25;&=&_w:1.25;&=&_w:6.25;&=&=&=&=&_a:4;&=Prev.%20Track%20(Win)&=Vol%20Down&=Next%20Track%20(Win))