aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/satan/keymaps/midi/Makefile
diff options
context:
space:
mode:
authorJack Humbert <jack.humb@gmail.com>2017-03-28 09:26:54 -0400
committerGitHub <noreply@github.com>2017-03-28 09:26:54 -0400
commit7e37daa2ce6edad82de3835384176b51a8081537 (patch)
tree58f349edb063667c9ae0affd99cec2bf7a7f93cb /keyboards/satan/keymaps/midi/Makefile
parent216f669276b30393fb35a409011ccdad8b521156 (diff)
parent0734f569409974624b40735fcd498dac9adba2d2 (diff)
downloadfirmware-7e37daa2ce6edad82de3835384176b51a8081537.tar.gz
firmware-7e37daa2ce6edad82de3835384176b51a8081537.tar.bz2
firmware-7e37daa2ce6edad82de3835384176b51a8081537.zip
Merge pull request #1112 from newsboytko/newsboytko/midi-keycodes
Flesh out MIDI support
Diffstat (limited to 'keyboards/satan/keymaps/midi/Makefile')
-rw-r--r--keyboards/satan/keymaps/midi/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/keyboards/satan/keymaps/midi/Makefile b/keyboards/satan/keymaps/midi/Makefile
new file mode 100644
index 000000000..89c34b394
--- /dev/null
+++ b/keyboards/satan/keymaps/midi/Makefile
@@ -0,0 +1,21 @@
+# Build Options
+# change to "no" to disable the options, or define them in the Makefile in
+# the appropriate keymap folder that will get included automatically
+#
+BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE = yes # Mouse keys(+4700)
+EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
+CONSOLE_ENABLE = no # Console for debug(+400)
+COMMAND_ENABLE = yes # Commands for debug and configuration
+NKRO_ENABLE = yes # Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+BACKLIGHT_ENABLE = yes # Enable keyboard backlight functionality
+MIDI_ENABLE = yes # MIDI support (+2400 to 4200, depending on config)
+AUDIO_ENABLE = no # Audio output on port C6
+UNICODE_ENABLE = no # Unicode
+BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
+RGBLIGHT_ENABLE = no # Enable WS2812 RGB underlight. Do not enable this with audio at the same time.
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+
+ifndef QUANTUM_DIR
+ include ../../../../Makefile
+endif