aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/satt/vision/rules.mk
diff options
context:
space:
mode:
authorsatt99 <satt99kbd@gmail.com>2020-08-20 03:18:52 +0900
committerGitHub <noreply@github.com>2020-08-19 11:18:52 -0700
commite4a0a5f4e1e1a561939596fff09380dab8434d79 (patch)
treeb1a99bd03779c25574075c3c9c1ebbba2681fafd /keyboards/satt/vision/rules.mk
parent993d4058a1537f82ee8eb0006e155ac8c8620af1 (diff)
downloadfirmware-e4a0a5f4e1e1a561939596fff09380dab8434d79.tar.gz
firmware-e4a0a5f4e1e1a561939596fff09380dab8434d79.tar.bz2
firmware-e4a0a5f4e1e1a561939596fff09380dab8434d79.zip
[Keyboard] Vision keyboard by SatT (#9768)
* Add vision keyboard * Remove bootloader_defs.h * Update keyboards/satt/vision/readme.md * Change Vendor ID * Update keyboards/satt/vision/config.h * Update keyboards/satt/vision/rules.mk * Fix info.json * Apply suggestions from code review * Add license header * Apply suggestions from code review
Diffstat (limited to 'keyboards/satt/vision/rules.mk')
-rw-r--r--keyboards/satt/vision/rules.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/keyboards/satt/vision/rules.mk b/keyboards/satt/vision/rules.mk
new file mode 100644
index 000000000..888e650d5
--- /dev/null
+++ b/keyboards/satt/vision/rules.mk
@@ -0,0 +1,20 @@
+# MCU name
+MCU = STM32F072
+
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = lite # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = yes # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = yes # Console for debug
+COMMAND_ENABLE = yes # Commands for debug and configuration
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+NKRO_ENABLE = yes # USB Nkey Rollover
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = no # Enable keyboard RGB underglow
+BLUETOOTH_ENABLE = no # Enable Bluetooth
+AUDIO_ENABLE = no # Audio output
+
+# Enter lower-power sleep mode when on the ChibiOS idle thread
+OPT_DEFS += -DCORTEX_ENABLE_WFI_IDLE=TRUE