aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/sck/osa/osa.c
diff options
context:
space:
mode:
authorJ.Flanagan <jrfhoutx@comcast.net>2019-10-05 12:44:55 -0500
committerDrashna Jaelre <drashna@live.com>2019-10-05 10:44:55 -0700
commit19b60c273ab63c250db748e5eead6baba88cd0d8 (patch)
tree72a0fa65515e4d25e099c3ae68250ed0a8e39184 /keyboards/sck/osa/osa.c
parentdbce3f648b342418f79de977068f2005d534cff7 (diff)
downloadfirmware-19b60c273ab63c250db748e5eead6baba88cd0d8.tar.gz
firmware-19b60c273ab63c250db748e5eead6baba88cd0d8.tar.bz2
firmware-19b60c273ab63c250db748e5eead6baba88cd0d8.zip
[Keyboard] Add OSA keyboard (#6849)
* initial commit restart of osa development * minor changes Minor changes mostly changing naming and comment out rgb modes * initial commit restart of osa development * minor changes Minor changes mostly changing naming and comment out rgb modes * more minor changes comment out some functions correct some spelling errors change some of the descriptive text * Minor Changes Minor changers per PR requests * Minor Changes Minor changes per PR suggestions * Major Changes Per PR suggestion from noroadsleft: - changed macro to LAYOUT_all in info.json, dualsplit/keymap.c and ocm/keymap.c, and osa.h - added osa.h macros for other layouts per suggestion and used suggested naming - changed naming of layout macros to correspond to macros and naming in default/keymap.c, dualsplit/keymap.c, ocm/keymap.c, splitbs/keymap.c, and splitrs/keymap.c - removed duplicate layers from all keymaps and edited per suggestions - compiled each keymap to check for and correct any potential errors. all compiled with no errors * Minor Change - fixed imgur image link in readme.md to be correct format * Minor Changes changes to macro layouts in osa.h changes to dualsplit/keymap.c - added arrows to layer 1 * Changes - Made changes to info.json to match osa.h - changes to osa.c enabling indicator LEDs - changed "dualsplit" directory name to "all" to match keymap naming in osa.h, info.json, and keymap.c - minor changes to all/keymap.c * Update keyboards/sck/osa/rules.mk Co-Authored-By: fauxpark <fauxpark@gmail.com> * Update keyboards/sck/osa/readme.md Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Changes to info.json - revert to info.json from version in b3b49c3 per requested changes
Diffstat (limited to 'keyboards/sck/osa/osa.c')
-rw-r--r--keyboards/sck/osa/osa.c73
1 files changed, 73 insertions, 0 deletions
diff --git a/keyboards/sck/osa/osa.c b/keyboards/sck/osa/osa.c
new file mode 100644
index 000000000..138a28893
--- /dev/null
+++ b/keyboards/sck/osa/osa.c
@@ -0,0 +1,73 @@
+/* Copyright 2019 jrfhoutx
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+#include "osa.h"
+
+
+// Optional override functions below.
+// You can leave any or all of these undefined.
+// These are only required if you want to perform custom actions.
+
+/*
+
+void matrix_init_kb(void) {
+ // put your keyboard start-up code here
+ // runs once when the firmware starts up
+
+ matrix_init_user();
+}
+
+void matrix_scan_kb(void) {
+ // put your looping keyboard code here
+ // runs every cycle (a lot)
+
+ matrix_scan_user();
+}
+
+bool process_record_kb(uint16_t keycode, keyrecord_t *record) {
+ // put your per-action keyboard code here
+ // runs for every action, just before processing by the firmware
+
+ return process_record_user(keycode, record);
+}
+*/
+
+void matrix_init_board(void){
+ setPinOutput(C7);
+ setPinOutput(C6);
+ setPinOutput(B6);
+}
+
+void led_set_kb(uint8_t usb_led) {
+ // put your keyboard LED indicator (ex: Caps Lock LED) toggling code here
+
+ if (IS_LED_ON(usb_led, USB_LED_NUM_LOCK)) {
+ writePinHigh(C7);
+ } else {
+ writePinLow(C7);
+ }
+ if (IS_LED_ON(usb_led, USB_LED_CAPS_LOCK)) {
+ writePinHigh(C6);
+ } else {
+ writePinLow(C6);
+ }
+ if (IS_LED_ON(usb_led, USB_LED_SCROLL_LOCK)) {
+ writePinHigh(B6);
+ } else {
+ writePinLow(B6);
+ }
+ led_set_user(usb_led);
+}
+