aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/spacetime/rev1
diff options
context:
space:
mode:
authorKyle Terry <kyle@kyleterry.com>2019-05-26 13:05:42 -0700
committerDrashna Jaelre <drashna@live.com>2019-05-26 13:05:42 -0700
commitdf73a81db8d21af8c2ac45229eb7873787312d6a (patch)
tree8b1c8e841fdbe9f0cec7d0aef4b068c443218832 /keyboards/spacetime/rev1
parent2f961265a147dbf568dcc86fad8123b2d02656bc (diff)
downloadfirmware-df73a81db8d21af8c2ac45229eb7873787312d6a.tar.gz
firmware-df73a81db8d21af8c2ac45229eb7873787312d6a.tar.bz2
firmware-df73a81db8d21af8c2ac45229eb7873787312d6a.zip
[Keyboard] adds spacetime keyboard (#5969)
* adds spacetime keyboard * removes custom tap and mod functions this commit replaces tap_key, control_key and shift_key with built-in tap_code16. * changes thumb layer and makes left palm key ralt
Diffstat (limited to 'keyboards/spacetime/rev1')
-rw-r--r--keyboards/spacetime/rev1/rev1.c40
-rw-r--r--keyboards/spacetime/rev1/rev1.h48
-rw-r--r--keyboards/spacetime/rev1/rules.mk1
3 files changed, 89 insertions, 0 deletions
diff --git a/keyboards/spacetime/rev1/rev1.c b/keyboards/spacetime/rev1/rev1.c
new file mode 100644
index 000000000..6fde622c2
--- /dev/null
+++ b/keyboards/spacetime/rev1/rev1.c
@@ -0,0 +1,40 @@
+/* Copyright 2019 Kyle Terry
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+#include "rev1.h"
+
+bool process_record_kb(uint16_t keycode, keyrecord_t *record) {
+ return process_record_user(keycode, record);
+}
+
+void matrix_init_kb(void) {
+ // put your keyboard start-up code here
+ // runs once when the firmware starts up
+
+ matrix_init_user();
+}
+
+void matrix_scan_kb(void) {
+ // put your looping keyboard code here
+ // runs every cycle (a lot)
+
+ matrix_scan_user();
+}
+
+void led_set_kb(uint8_t usb_led) {
+ // put your keyboard LED indicator (ex: Caps Lock LED) toggling code here
+
+ led_set_user(usb_led);
+}
diff --git a/keyboards/spacetime/rev1/rev1.h b/keyboards/spacetime/rev1/rev1.h
new file mode 100644
index 000000000..dd5420456
--- /dev/null
+++ b/keyboards/spacetime/rev1/rev1.h
@@ -0,0 +1,48 @@
+/* Copyright 2019 Kyle Terry
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+#pragma once
+
+#include "quantum.h"
+#define ___ KC_NO
+
+/* This a shortcut to help you visually see your layout.
+ *
+ * The first section contains all of the arguments representing the physical
+ * layout of the board and position of the keys.
+ *
+ * The second converts the arguments into a two-dimensional array which
+ * represents the switch matrix.
+ */
+#define LAYOUT( \
+ L00, L01, L02, L03, L04, L05, L06, R00, R01, R02, R03, R04, R05, R06, \
+ L10, L11, L12, L13, L14, L15, L16, R10, R11, R12, R13, R14, R15, R16, \
+ L20, L21, L22, L23, L24, L25, L26, R20, R21, R22, R23, R24, R25, R26, \
+ L30, L34, L35, L36, R30, R31, R32, R36 \
+) { \
+ { L00, L01, L02, L03, L04, L05, L06 }, \
+ { L10, L11, L12, L13, L14, L15, L16 }, \
+ { L20, L21, L22, L23, L24, L25, L26 }, \
+ { L30, ___, ___, ___, L34, L35, L36 }, \
+\
+ { R06, R05, R04, R03, R02, R01, R00 }, \
+ { R16, R15, R14, R13, R12, R11, R10 }, \
+ { R26, R25, R24, R23, R22, R21, R20 }, \
+ { R36, ___, ___, ___, R32, R31, R30 } \
+}
+
+#ifdef USE_I2C
+ #error "I2C not Supported"
+#endif
diff --git a/keyboards/spacetime/rev1/rules.mk b/keyboards/spacetime/rev1/rules.mk
new file mode 100644
index 000000000..b595964f7
--- /dev/null
+++ b/keyboards/spacetime/rev1/rules.mk
@@ -0,0 +1 @@
+OLED_DRIVER_ENABLE = no