aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/stella/config.h
diff options
context:
space:
mode:
authorvuhopkep <boy9x0@gmail.com>2019-10-05 01:55:54 +0700
committernoroadsleft <18669334+noroadsleft@users.noreply.github.com>2019-10-04 11:55:54 -0700
commit3e6f7bc6bfacda10a731efdda9f669dca8b4a221 (patch)
tree794fe4037cc84a6f67258da450bb02c4a9424d4f /keyboards/stella/config.h
parentf166a22c98c6c2e055cbd81b2a309417b92b4f2a (diff)
downloadfirmware-3e6f7bc6bfacda10a731efdda9f669dca8b4a221.tar.gz
firmware-3e6f7bc6bfacda10a731efdda9f669dca8b4a221.tar.bz2
firmware-3e6f7bc6bfacda10a731efdda9f669dca8b4a221.zip
[Keyboard] Add Stella keyboard (#6848)
* Add Stella keyboard Tenkeyless keyboard for VGS Community * Update keymap.c * update
Diffstat (limited to 'keyboards/stella/config.h')
-rw-r--r--keyboards/stella/config.h65
1 files changed, 65 insertions, 0 deletions
diff --git a/keyboards/stella/config.h b/keyboards/stella/config.h
new file mode 100644
index 000000000..18a8c5a22
--- /dev/null
+++ b/keyboards/stella/config.h
@@ -0,0 +1,65 @@
+/*
+Copyright 2019 HnahKB
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 2 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#pragma once
+
+#include "config_common.h"
+
+/* USB Device descriptor parameter */
+#define VENDOR_ID 0xFEED
+#define PRODUCT_ID 0x0000
+#define DEVICE_VER 0x0001
+#define MANUFACTURER HnahKB
+#define PRODUCT Stella
+#define DESCRIPTION Custom PCB TKL keyboard for vgs community
+
+/* key matrix size */
+#define MATRIX_ROWS 10
+#define MATRIX_COLS 10
+
+/*
+ * Keyboard Matrix Assignments
+ *
+ * Change this to how you wired your keyboard
+ * COLS: AVR pins used for columns, left to right
+ * ROWS: AVR pins used for rows, top to bottom
+ * DIODE_DIRECTION: COL2ROW = COL = Anode (+), ROW = Cathode (-, marked on diode)
+ * ROW2COL = ROW = Anode (+), COL = Cathode (-, marked on diode)
+ *
+*/
+#define MATRIX_ROW_PINS { D3, B2, B1, B0, E6, F0, D2, D5, F4, F1 }
+#define MATRIX_COL_PINS { B4, D7, D6, D4, B5, C7, C6, F5, F6, F7 }
+#define UNUSED_PINS
+
+/* COL2ROW, ROW2COL*/
+#define DIODE_DIRECTION COL2ROW
+
+/*
+ * Split Keyboard specific options, make sure you have 'SPLIT_KEYBOARD = yes' in your rules.mk, and define SOFT_SERIAL_PIN.
+ */
+
+#define BACKLIGHT_PIN B6
+#define BACKLIGHT_BREATHING
+#define BACKLIGHT_LEVELS 3
+
+
+/* Debounce reduces chatter (unintended double-presses) - set 0 if debouncing is not needed */
+#define DEBOUNCE 5
+
+
+#define RGB_DI_PIN E2
+#define RGBLED_NUM 14 \ No newline at end of file