aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/sweet16
diff options
context:
space:
mode:
authorMechMerlin <30334081+mechmerlin@users.noreply.github.com>2018-08-26 09:30:12 -0700
committerDrashna Jaelre <drashna@live.com>2018-08-26 09:30:12 -0700
commit1ee545014a0415eee8cbe4a3773002fb13371d14 (patch)
tree2a4320e2dce1035b6b31909b9d93742418680178 /keyboards/sweet16
parenteb19fb5b57487747d608fad986a70296da4deb12 (diff)
downloadfirmware-1ee545014a0415eee8cbe4a3773002fb13371d14.tar.gz
firmware-1ee545014a0415eee8cbe4a3773002fb13371d14.tar.bz2
firmware-1ee545014a0415eee8cbe4a3773002fb13371d14.zip
Keyboard: Make a 1upkeyboards directory for visibility (#3759)
Diffstat (limited to 'keyboards/sweet16')
-rw-r--r--keyboards/sweet16/config.h58
-rw-r--r--keyboards/sweet16/info.json16
-rw-r--r--keyboards/sweet16/keymaps/default/keymap.c43
-rw-r--r--keyboards/sweet16/keymaps/dlaroe/keymap.c38
-rw-r--r--keyboards/sweet16/keymaps/dlaroe/readme.md3
-rw-r--r--keyboards/sweet16/readme.md14
-rw-r--r--keyboards/sweet16/rules.mk56
-rw-r--r--keyboards/sweet16/sweet16.c1
-rw-r--r--keyboards/sweet16/sweet16.h32
9 files changed, 0 insertions, 261 deletions
diff --git a/keyboards/sweet16/config.h b/keyboards/sweet16/config.h
deleted file mode 100644
index 77d9e276d..000000000
--- a/keyboards/sweet16/config.h
+++ /dev/null
@@ -1,58 +0,0 @@
-#ifndef CONFIG_H
-#define CONFIG_H
-
-#include "config_common.h"
-
-/* USB Device descriptor parameter */
-#define VENDOR_ID 0xFEED
-#define PRODUCT_ID 0x2010
-#define DEVICE_VER 0x0001
-#define MANUFACTURER 1up Keyboards
-#define PRODUCT Sweet16
-#define DESCRIPTION 4x4 grid
-
-/* key matrix size */
-#define MATRIX_ROWS 4
-#define MATRIX_COLS 4
-
-/* key matrix pins */
-#define MATRIX_ROW_PINS { F4, F5, F6, F7 }
-#define MATRIX_COL_PINS { D1, D0, D4, C6 }
-#define UNUSED_PINS
-
-/* COL2ROW or ROW2COL */
-#define DIODE_DIRECTION COL2ROW
-
-/* number of backlight levels */
-
-#ifdef BACKLIGHT_PIN
-#define BACKLIGHT_LEVELS 3
-#endif
-
-/* Set 0 if debouncing isn't needed */
-#define DEBOUNCING_DELAY 5
-
-/* Mechanical locking support. Use KC_LCAP, KC_LNUM or KC_LSCR instead in keymap */
-#define LOCKING_SUPPORT_ENABLE
-
-/* Locking resynchronize hack */
-#define LOCKING_RESYNC_ENABLE
-
-/* key combination for command */
-#define IS_COMMAND() ( \
- keyboard_report->mods == (MOD_BIT(KC_LSHIFT) | MOD_BIT(KC_RSHIFT)) \
-)
-
-/* prevent stuck modifiers */
-#define PREVENT_STUCK_MODIFIERS
-
-#define RGB_DI_PIN B1
-#ifdef RGB_DI_PIN
-#define RGBLIGHT_ANIMATIONS
-#define RGBLED_NUM 1
-#define RGBLIGHT_HUE_STEP 8
-#define RGBLIGHT_SAT_STEP 8
-#define RGBLIGHT_VAL_STEP 8
-#endif
-
-#endif \ No newline at end of file
diff --git a/keyboards/sweet16/info.json b/keyboards/sweet16/info.json
deleted file mode 100644
index 445a5909e..000000000
--- a/keyboards/sweet16/info.json
+++ /dev/null
@@ -1,16 +0,0 @@
-{
- "keyboard_name": "Sweet 16",
- "url": "",
- "maintainer": "qmk",
- "width": 4,
- "height": 4,
- "layouts": {
- "LAYOUT_ortho_4x4": {
- "layout": [{"x":0, "y":0}, {"x":1, "y":0}, {"x":2, "y":0}, {"x":3, "y":0}, {"x":0, "y":1}, {"x":1, "y":1}, {"x":2, "y":1}, {"x":3, "y":1}, {"x":0, "y":2}, {"x":1, "y":2}, {"x":2, "y":2}, {"x":3, "y":2}, {"x":0, "y":3}, {"x":1, "y":3}, {"x":2, "y":3}, {"x":3, "y":3}]
- },
-
- "LAYOUT_numpad_4x4": {
- "layout": [{"x":0, "y":0}, {"x":1, "y":0}, {"x":2, "y":0}, {"x":3, "y":0, "h":2}, {"x":0, "y":1}, {"x":1, "y":1}, {"x":2, "y":1}, {"x":0, "y":2}, {"x":1, "y":2}, {"x":2, "y":2}, {"x":3, "y":2, "h":2}, {"x":0, "y":3, "w":2}, {"x":2, "y":3}]
- }
- }
-}
diff --git a/keyboards/sweet16/keymaps/default/keymap.c b/keyboards/sweet16/keymaps/default/keymap.c
deleted file mode 100644
index 2ddf8acb4..000000000
--- a/keyboards/sweet16/keymaps/default/keymap.c
+++ /dev/null
@@ -1,43 +0,0 @@
-#include "sweet16.h"
-
-enum custom_keycodes {
- UP_URL = SAFE_RANGE
-};
-
-const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
- LAYOUT_ortho_4x4(
- KC_7, KC_8, KC_9, KC_ASTR,
- KC_4, KC_5, KC_6, KC_SLSH,
- KC_1, KC_2, KC_3, KC_MINS,
- KC_0, KC_ENT, KC_DOT, KC_EQL
- )
-};
-
-bool process_record_user(uint16_t keycode, keyrecord_t *record) {
- switch (keycode) {
- case UP_URL:
- if (record->event.pressed) {
- SEND_STRING("http://1upkeyboards.com");
- }
- return false;
- break;
- }
- return true;
-}
-
-void led_set_user(uint8_t usb_led) {
-
- /* Map RXLED to USB_LED_NUM_LOCK */
- if (usb_led & (1 << USB_LED_NUM_LOCK)) {
- DDRB |= (1 << 0); PORTB &= ~(1 << 0);
- } else {
- DDRB &= ~(1 << 0); PORTB &= ~(1 << 0);
- }
-
- /* Map TXLED to USB_LED_CAPS_LOCK */
- if (usb_led & (1 << USB_LED_CAPS_LOCK)) {
- DDRD |= (1 << 5); PORTD &= ~(1 << 5);
- } else {
- DDRD &= ~(1 << 5); PORTD &= ~(1 << 5);
- }
-}
diff --git a/keyboards/sweet16/keymaps/dlaroe/keymap.c b/keyboards/sweet16/keymaps/dlaroe/keymap.c
deleted file mode 100644
index b42c34edb..000000000
--- a/keyboards/sweet16/keymaps/dlaroe/keymap.c
+++ /dev/null
@@ -1,38 +0,0 @@
-#include "sweet16.h"
-
-enum layers {
- num,
- extra,
- mouse
-};
-
-
-
-const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
- [num] = LAYOUT_numpad_4x4(
- KC_P7, KC_P8, KC_P9, LT(extra, KC_PPLS),
- KC_P4, KC_P5, KC_P6,
- KC_P1, KC_P2, KC_P3, KC_PENT,
- LT(mouse, KC_P0), KC_DOT
- ),
-
- [extra] = LAYOUT_numpad_4x4(
- KC_PSLS, KC_PAST, KC_PMNS, KC_TRNS,
- KC_BSPC, KC_EXECUTE, KC_DEL,
- KC_LPRN, KC_RPRN, KC_PEQL, KC_PENT,
- KC_TAB, KC_NLCK
- ),
-
-
-[mouse] = LAYOUT_numpad_4x4(
- KC_WH_D, KC_MS_U, KC_WH_U, LT(extra, KC_PPLS),
- KC_MS_L, KC_MS_D, KC_MS_R,
- KC_BTN1, KC_BTN2, KC_BTN3, KC_PENT,
- KC_TRNS, KC_DOT
- )
-
-
-
-
-};
-
diff --git a/keyboards/sweet16/keymaps/dlaroe/readme.md b/keyboards/sweet16/keymaps/dlaroe/readme.md
deleted file mode 100644
index aabcf82c6..000000000
--- a/keyboards/sweet16/keymaps/dlaroe/readme.md
+++ /dev/null
@@ -1,3 +0,0 @@
-# Dale's keymap for the Sweet16
-
-I wanted to reuse a standard numpad keyset and have the full functionality of an larger numpad with a nod to Excel functionality.
diff --git a/keyboards/sweet16/readme.md b/keyboards/sweet16/readme.md
deleted file mode 100644
index 435aed68c..000000000
--- a/keyboards/sweet16/readme.md
+++ /dev/null
@@ -1,14 +0,0 @@
-Sweet16
-===
-
-A 4x4 numpad/macro pad sold by 1up Keyboards - designed by Bishop Keyboards
-
-Keyboard Maintainer: QMK Community
-Hardware Supported: Sweet16 Keyboard PCB
-Hardware Availability: [1up Keyboards](https://1upkeyboards.com/)
-
-Make example for this keyboard (after setting up your build environment):
-
- make sweet16:default
-
-See [build environment setup](https://docs.qmk.fm/build_environment_setup.html) then the [make instructions](https://docs.qmk.fm/make_instructions.html) for more information. \ No newline at end of file
diff --git a/keyboards/sweet16/rules.mk b/keyboards/sweet16/rules.mk
deleted file mode 100644
index 212e74059..000000000
--- a/keyboards/sweet16/rules.mk
+++ /dev/null
@@ -1,56 +0,0 @@
-# MCU name
-MCU = atmega32u4
-
-# Processor frequency.
-# This will define a symbol, F_CPU, in all source code files equal to the
-# processor frequency in Hz. You can then use this symbol in your source code to
-# calculate timings. Do NOT tack on a 'UL' at the end, this will be done
-# automatically to create a 32-bit value in your source code.
-#
-# This will be an integer division of F_USB below, as it is sourced by
-# F_USB after it has run through any CPU prescalers. Note that this value
-# does not *change* the processor frequency - it should merely be updated to
-# reflect the processor speed set externally so that the code can use accurate
-# software delays.
-F_CPU = 16000000
-
-#
-# LUFA specific
-#
-# Target architecture (see library "Board Types" documentation).
-ARCH = AVR8
-
-# Input clock frequency.
-# This will define a symbol, F_USB, in all source code files equal to the
-# input clock frequency (before any prescaling is performed) in Hz. This value may
-# differ from F_CPU if prescaling is used on the latter, and is required as the
-# raw input clock is fed directly to the PLL sections of the AVR for high speed
-# clock generation for the USB and other AVR subsections. Do NOT tack on a 'UL'
-# at the end, this will be done automatically to create a 32-bit value in your
-# source code.
-#
-# If no clock division is performed on the input clock inside the AVR (via the
-# CPU clock adjust registers or the clock division fuses), this will be equal to F_CPU.
-F_USB = $(F_CPU)
-
-# Interrupt driven control endpoint task(+60)
-OPT_DEFS += -DINTERRUPT_CONTROL_ENDPOINT
-
-
-# Boot Section Size in *bytes*
-OPT_DEFS += -DBOOTLOADER_SIZE=4096
-
-
-# Build Options
-# comment out to disable the options.
-#
-BOOTMAGIC_ENABLE = yes # Virtual DIP switch configuration(+1000)
-MOUSEKEY_ENABLE = yes # Mouse keys(+4700)
-EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
-CONSOLE_ENABLE = no # Console for debug(+400)
-COMMAND_ENABLE = no # Commands for debug and configuration
-SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
-NKRO_ENABLE = yes # USB Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
-BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
-AUDIO_ENABLE = no
-RGBLIGHT_ENABLE = yes \ No newline at end of file
diff --git a/keyboards/sweet16/sweet16.c b/keyboards/sweet16/sweet16.c
deleted file mode 100644
index 2f116c2a3..000000000
--- a/keyboards/sweet16/sweet16.c
+++ /dev/null
@@ -1 +0,0 @@
-#include "sweet16.h" \ No newline at end of file
diff --git a/keyboards/sweet16/sweet16.h b/keyboards/sweet16/sweet16.h
deleted file mode 100644
index 879f51fae..000000000
--- a/keyboards/sweet16/sweet16.h
+++ /dev/null
@@ -1,32 +0,0 @@
-#ifndef KB_H
-#define KB_H
-
-#include "quantum.h"
-
-// Any changes to the layout names and/or definitions must also be made to info.json
-
-#define LAYOUT_ortho_4x4( \
- K00, K01, K02, K03, \
- K10, K11, K12, K13, \
- K20, K21, K22, K23, \
- K30, K31, K32, K33 \
-) { \
- { K00, K01, K02, K03 }, \
- { K10, K11, K12, K13 }, \
- { K20, K21, K22, K23 }, \
- { K30, K31, K32, K33 } \
-}
-
-#define LAYOUT_numpad_4x4( \
- K00, K01, K02, K03, \
- K10, K11, K12, \
- K20, K21, K22, K23, \
- K31, K32 \
-) { \
- { K00, K01, K02, K03 }, \
- { K10, K11, K12, KC_NO }, \
- { K20, K21, K22, K23 }, \
- { KC_NO, K31, K32, KC_NO } \
-}
-
-#endif