aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/tgr/jane/keymaps/default/config.h
diff options
context:
space:
mode:
authorMechMerlin <30334081+mechmerlin@users.noreply.github.com>2019-07-26 21:49:29 -0700
committerDrashna Jaelre <drashna@live.com>2019-07-26 21:49:29 -0700
commit2367e3e1fd6e5b93fe998399befa26d4de6a93ab (patch)
treece87bf4818bd697c55d6dad09458327111c249e3 /keyboards/tgr/jane/keymaps/default/config.h
parent0bd03150e5952978e0a7044dcfea1bb617c2390d (diff)
downloadfirmware-2367e3e1fd6e5b93fe998399befa26d4de6a93ab.tar.gz
firmware-2367e3e1fd6e5b93fe998399befa26d4de6a93ab.tar.bz2
firmware-2367e3e1fd6e5b93fe998399befa26d4de6a93ab.zip
[Keyboard] TGR Jane v2 (#6361)
* initial commit TGR Jane * lighting support * use the default keymap lifted from community layouts for LAYOUT_tkl_ansi * add information regarding reset key, hardware supported, and hardware availability * document that it supports v1.1 as well thanks to nickheller's confirmation * update some verbage in the readme * add QMK Configurator support * establish switch matrix for three main layouts * add community layout support * readme fixes * Update keyboards/tgr/jane/info.json Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update keyboards/tgr/jane/rules.mk Co-Authored-By: Drashna Jaelre <drashna@live.com> * Update keyboards/tgr/jane/config.h Co-Authored-By: fauxpark <fauxpark@gmail.com>
Diffstat (limited to 'keyboards/tgr/jane/keymaps/default/config.h')
-rw-r--r--keyboards/tgr/jane/keymaps/default/config.h19
1 files changed, 19 insertions, 0 deletions
diff --git a/keyboards/tgr/jane/keymaps/default/config.h b/keyboards/tgr/jane/keymaps/default/config.h
new file mode 100644
index 000000000..93b81b57b
--- /dev/null
+++ b/keyboards/tgr/jane/keymaps/default/config.h
@@ -0,0 +1,19 @@
+/* Copyright 2018 amnesia0287
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#pragma once
+
+// place overrides here