aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/tgr/tris/tris.c
diff options
context:
space:
mode:
authorhalfenergized <half_energized@yahoo.co.uk>2020-05-27 07:20:32 +0700
committerGitHub <noreply@github.com>2020-05-27 01:20:32 +0100
commita9b3c0a807e00e7279bb039abb5d5696ecd6d0c1 (patch)
tree6937525c83a7e60d68c6a8744b5870d4e5ba4869 /keyboards/tgr/tris/tris.c
parentac447d8acb95658fd58e6504abbc92d7acb21960 (diff)
downloadfirmware-a9b3c0a807e00e7279bb039abb5d5696ecd6d0c1.tar.gz
firmware-a9b3c0a807e00e7279bb039abb5d5696ecd6d0c1.tar.bz2
firmware-a9b3c0a807e00e7279bb039abb5d5696ecd6d0c1.zip
Adding TGR Tris/Tris CE Numpad (#9139)
* Add TGR Tris * Update readme.md * Update rules.mk * Update keyboards/tgr/tris/keymaps/default/keymap.c Co-authored-by: Joel Challis <git@zvecr.com> * Update keyboards/tgr/tris/keymaps/via/keymap.c Co-authored-by: Joel Challis <git@zvecr.com> * Update keyboards/tgr/tris/keymaps/default/keymap.c Co-authored-by: Drashna Jaelre <drashna@live.com> * Update keyboards/tgr/tris/keymaps/via/keymap.c Co-authored-by: Drashna Jaelre <drashna@live.com> * Update keyboards/tgr/tris/tris.h Co-authored-by: Drashna Jaelre <drashna@live.com> * Update keyboards/tgr/tris/info.json Co-authored-by: Joel Challis <git@zvecr.com> * update formatting * Revert "update formatting" This reverts commit ae2d6832673985a874f7f43d42bdb56679d851d6. Co-authored-by: Joel Challis <git@zvecr.com> Co-authored-by: Drashna Jaelre <drashna@live.com>
Diffstat (limited to 'keyboards/tgr/tris/tris.c')
-rw-r--r--keyboards/tgr/tris/tris.c33
1 files changed, 33 insertions, 0 deletions
diff --git a/keyboards/tgr/tris/tris.c b/keyboards/tgr/tris/tris.c
new file mode 100644
index 000000000..f354d7a39
--- /dev/null
+++ b/keyboards/tgr/tris/tris.c
@@ -0,0 +1,33 @@
+/* Copyright 2020 halfenergized
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#include "tris.h"
+
+void keyboard_pre_init_kb(void) {
+ led_init_ports();
+ keyboard_pre_init_user();
+}
+
+void led_init_ports(void) {
+ setPinOutput(D0);
+}
+
+bool led_update_kb(led_t led_state) {
+ if (led_update_user(led_state)) {
+ writePin(D0, led_state.num_lock);
+ }
+ return true;
+}