aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/tkc1800/config.h
diff options
context:
space:
mode:
authornoroadsleft <18669334+noroadsleft@users.noreply.github.com>2019-01-18 07:32:21 -0800
committerMechMerlin <30334081+mechmerlin@users.noreply.github.com>2019-01-18 07:32:21 -0800
commit12406c646f917b7451ec265d767f07a34ecf906a (patch)
tree6a5bb1502bd082cd851471187bef3b59de1139d4 /keyboards/tkc1800/config.h
parente2f7c3d5a59933519e8cf7b4d9176587334d7b70 (diff)
downloadfirmware-12406c646f917b7451ec265d767f07a34ecf906a.tar.gz
firmware-12406c646f917b7451ec265d767f07a34ecf906a.tar.bz2
firmware-12406c646f917b7451ec265d767f07a34ecf906a.zip
TKC1800 refactor and Configurator visual fixes (#4870)
* TKC1800: refactor - tkc1800.h - updated to use #pragma once - visual alignment - update config.h files to use #pragma once - update all keymaps to use #include QMK_KEYBOARD_H - delete redundant mod mask, KC_TRNS, and KC_NO definitions - reformat keymap layers for readability - add block comment for Function layer in default keymap - delete commented action_get_macro code blocks (deprecated function) - update files to better conform with QMK coding conventions - update smt keymap to use set_single_persistent_default_layer (instead of persistent_default_layer_set) - replace instances of `?=` with `=` in rules.mk * TKC1800: Configurator visual fixes - correct key sizes and positioning - reformat file so each physical key object has its own line for readability - update and add `label` keys for readability * TKC1800: readme update - fix image gallery link - update Hardware Supported and Hardware Availability lines - update make example (add :default suffix) - update QMK Docs links (Newbs Guide; grammar) * Add missing semicolons to smt keymap
Diffstat (limited to 'keyboards/tkc1800/config.h')
-rw-r--r--keyboards/tkc1800/config.h5
1 files changed, 1 insertions, 4 deletions
diff --git a/keyboards/tkc1800/config.h b/keyboards/tkc1800/config.h
index b13620de3..92a5f1b38 100644
--- a/keyboards/tkc1800/config.h
+++ b/keyboards/tkc1800/config.h
@@ -15,8 +15,7 @@ You should have received a copy of the GNU General Public License
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
-#ifndef CONFIG_H
-#define CONFIG_H
+#pragma once
#include "config_common.h"
@@ -182,5 +181,3 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
/* override number of MIDI tone keycodes (each octave adds 12 keycodes and allocates 12 bytes) */
//#define MIDI_TONE_KEYCODE_OCTAVES 1
-
-#endif