aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/tr60w/config.h
diff options
context:
space:
mode:
authorJoule-Flow <github.julian@flores-it.de>2019-12-02 20:47:55 +0100
committerDrashna Jaelre <drashna@live.com>2019-12-02 11:47:55 -0800
commit680924777be7739b249bf0dc3b60a3185134bc94 (patch)
tree2eb2c2cbc707fa01c88d5442e754f9c04ee021bd /keyboards/tr60w/config.h
parent75c8a79d0e087d99299b1b273d343aacb8bed0b8 (diff)
downloadfirmware-680924777be7739b249bf0dc3b60a3185134bc94.tar.gz
firmware-680924777be7739b249bf0dc3b60a3185134bc94.tar.bz2
firmware-680924777be7739b249bf0dc3b60a3185134bc94.zip
[Keyboard] Added tr60w keyboard (#7450)
* Added tr60w configurations. I based these files on the fox-lab/qmk_firmware repository. After checking both licenses, which are identical, I added those files into this feature branch. For transparency reasons I'll add the url to the fox-lab repository. https://github.com/fox-lab/qmk_firmware * Using #pragma once in config.h. * Removed '#define CCONFIG_H' from config.h. * Changed PRODUCT_ID to '0x4140'. * Renamed setting to 'DEBOUNCE'. * Removed key combination, due to already default implementation. * Removed 'PREVENT_STUCK_MODIFIERS', defaulted by QMK. * Removed not uneccessary '#endif' statement. * Renamed include to 'QMK_KEYBOARD_H'. * Changed keymap structure according to pull request suggestion. * Removed 'void matrix_init_user(void)'. * Removed 'void matrix_scan_user(void)'. * Removed 'bool process_record_user(...)'. * Removed non-standard configuration in favor for 'led_update_kb'. * Using default setup based on 'MCU' setting. * Replaced Build Option configuration with suggested information. * Fixed include statements as requested. * Changed 'KEYMAP' to suggestion. * Removed obsolete '#endif' statement. * Added readme.md file. * Updated readme.md with further information. * Reverted include statement, to check if this caused ci error. * Revert "Reverted include statement." This reverts commit ebd992dc01133169be38ae7201bb00b4d01cc737. * Fixed wrong mapped key * Fixed include as per suggestion. * Replaced 'KC_TRNS' with '_______'for readability. * Added personal keymap.c file. * Updated the readme.md file according to template/avr/readme.md. * Fixed Link to Image. * Updated readme.md as per request. * Updated rules.mk, as per suggestion. Set 'BOOTMAGIC_ENABLE = lite'.
Diffstat (limited to 'keyboards/tr60w/config.h')
-rw-r--r--keyboards/tr60w/config.h47
1 files changed, 47 insertions, 0 deletions
diff --git a/keyboards/tr60w/config.h b/keyboards/tr60w/config.h
new file mode 100644
index 000000000..2196e6c53
--- /dev/null
+++ b/keyboards/tr60w/config.h
@@ -0,0 +1,47 @@
+#pragma once
+
+#include "config_common.h"
+
+/* USB Device descriptor parameter */
+#define VENDOR_ID 0xFEED
+#define PRODUCT_ID 0x4140
+#define DEVICE_VER 0x0001
+#define MANUFACTURER Triangle_Lab
+#define PRODUCT TR60W
+#define DESCRIPTION Keyboard
+
+/* key matrix size */
+#define MATRIX_ROWS 6
+#define MATRIX_COLS 14
+
+/* key matrix pins */
+#define MATRIX_ROW_PINS { D0, D1, B1, B2, E6, B3 }
+#define MATRIX_COL_PINS { F5, F4, F1, F0, B0, D5, D3, D6, D7, B4, B5, B6, C6, D2 }
+#define UNUSED_PINS
+
+/* COL2ROW or ROW2COL */
+#define DIODE_DIRECTION COL2ROW
+
+/* number of backlight levels */
+#define BACKLIGHT_PIN B7
+#ifdef BACKLIGHT_PIN
+#define BACKLIGHT_LEVELS 3
+#endif
+
+/* Set 0 if debouncing isn't needed */
+#define DEBOUNCE 5
+
+/* Mechanical locking support. Use KC_LCAP, KC_LNUM or KC_LSCR instead in keymap */
+#define LOCKING_SUPPORT_ENABLE
+
+/* Locking resynchronize hack */
+#define LOCKING_RESYNC_ENABLE
+
+#define RGB_DI_PIN F7
+#ifdef RGB_DI_PIN
+#define RGBLIGHT_ANIMATIONS
+#define RGBLED_NUM 4
+#define RGBLIGHT_HUE_STEP 8
+#define RGBLIGHT_SAT_STEP 8
+#define RGBLIGHT_VAL_STEP 8
+#endif