aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/v60_type_r/keymaps
diff options
context:
space:
mode:
authorLuke Wesley-Holley <luke.wesley-holley@canonical.com>2019-07-22 10:06:06 +0100
committerDrashna Jaelre <drashna@live.com>2019-07-22 02:06:06 -0700
commit4532caf5f2781f7fc3b28ab847e06a147c091e60 (patch)
tree7bc056b6a3256a9bbaace523df6be1e7979d068c /keyboards/v60_type_r/keymaps
parente08e6c11e31a0c5cdf112e6832f493992e438312 (diff)
downloadfirmware-4532caf5f2781f7fc3b28ab847e06a147c091e60.tar.gz
firmware-4532caf5f2781f7fc3b28ab847e06a147c091e60.tar.bz2
firmware-4532caf5f2781f7fc3b28ab847e06a147c091e60.zip
[Keyboard] KBP V60 Type R Added ISO default (#6372)
* [Layout] KBP V60 Type R ISO default * Remove ifdef * Apply suggestions from code review @noroadsleft I've accepted your suggestions. Tried locally any everything works as expected. Thanks again - this if my first keyboard and first time looking at/ using/ contributing to qmk so I appreciate the feedback :+1: Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com>
Diffstat (limited to 'keyboards/v60_type_r/keymaps')
-rw-r--r--keyboards/v60_type_r/keymaps/iso/config.h18
-rw-r--r--keyboards/v60_type_r/keymaps/iso/keymap.c54
-rw-r--r--keyboards/v60_type_r/keymaps/iso/readme.md5
-rw-r--r--keyboards/v60_type_r/keymaps/iso/rules.mk2
4 files changed, 79 insertions, 0 deletions
diff --git a/keyboards/v60_type_r/keymaps/iso/config.h b/keyboards/v60_type_r/keymaps/iso/config.h
new file mode 100644
index 000000000..6a1994d6f
--- /dev/null
+++ b/keyboards/v60_type_r/keymaps/iso/config.h
@@ -0,0 +1,18 @@
+/* Copyright 2019 Lukewh
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+#pragma once
+
+// place overrides here
diff --git a/keyboards/v60_type_r/keymaps/iso/keymap.c b/keyboards/v60_type_r/keymaps/iso/keymap.c
new file mode 100644
index 000000000..74aee86ed
--- /dev/null
+++ b/keyboards/v60_type_r/keymaps/iso/keymap.c
@@ -0,0 +1,54 @@
+/* This is the default ISO layout provided by the KBP V60 Type R
+* as depicted on the stock keycaps.
+*/
+#include QMK_KEYBOARD_H
+
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+ /* Keymap 0: Default Layer (Qwerty)
+ * ,-----------------------------------------------------------.
+ * |Esc| 1| 2| 3| 4| 5| 6| 7| 8| 9| 0| -| =| Bs |
+ * |-----------------------------------------------------------|
+ * |Tab | Q| W| E| R| T| Y| U| I| O| P| [| ]| Entr|
+ * |-------------------------------------------------------| |
+ * |Caps | A| S| D| F| G| H| J| K| L| ;| '| #| |
+ * |-----------------------------------------------------------|
+ * |LShif| || Z| X| C| V| B| N| M| ,| .| /| RShift |
+ * |-----------------------------------------------------------|
+ * |Ctrl|Gui |Alt | Space |Fn0 |Gui |App|Ctrl|
+ * `-----------------------------------------------------------'
+ */
+ [0] = LAYOUT_60_iso( \
+ KC_ESC, KC_1, KC_2, KC_3, KC_4, KC_5, KC_6, KC_7, KC_8, KC_9, KC_0, KC_MINS, KC_EQL, KC_BSPC, \
+ KC_TAB, KC_Q, KC_W, KC_E, KC_R, KC_T, KC_Y, KC_U, KC_I, KC_O, KC_P, KC_LBRC, KC_RBRC, \
+ KC_CAPS, KC_A, KC_S, KC_D, KC_F, KC_G, KC_H, KC_J, KC_K, KC_L, KC_SCLN, KC_QUOTE, KC_NUHS, KC_ENT, \
+ KC_LSFT, KC_NUBS, KC_Z, KC_X, KC_C, KC_V, KC_B, KC_N, KC_M, KC_COMM, KC_DOT, KC_SLSH, KC_RSFT, \
+ KC_LCTL, KC_LGUI, KC_LALT, KC_SPC, MO(1), KC_RGUI, KC_APP, KC_RCTL \
+ ),
+
+ /* Keymap 0: Default Layer (Qwerty)
+ * ,-----------------------------------------------------------.
+ * | ¬| F1| F2| F3| F4| F5| F6| F7| F8| F9| F10| -| =| Bs |
+ * |-----------------------------------------------------------|
+ * | | | up| | | | | |prt|scr|pus| up| | |
+ * |-------------------------------------------------------| |
+ * | |lft|dwn|rig| | | | |hom|pgu|lft|rig| | |
+ * |-----------------------------------------------------------|
+ * | | | | | | |vld|vlu|mut|end|pgd|dwn| |
+ * |-----------------------------------------------------------|
+ * | | | | | | | | |
+ * `-----------------------------------------------------------'
+ */
+ [1] = LAYOUT_60_iso( \
+ KC_GRV, KC_F1, KC_F2, KC_F3, KC_F4, KC_F5, KC_F6, KC_F7, KC_F8, KC_F9, KC_F10, KC_F11, KC_F12, KC_DEL, \
+ KC_TRNS, KC_TRNS, KC_UP, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_PSCR, KC_SLCK, KC_PAUS, KC_UP, KC_TRNS, \
+ KC_TRNS, KC_LEFT, KC_DOWN, KC_RIGHT, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_HOME, KC_PGUP, KC_LEFT, KC_RIGHT, KC_TRNS, KC_TRNS, \
+ KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_VOLD, KC_VOLU, KC_MUTE, KC_END, KC_PGDN, KC_DOWN, KC_TRNS, \
+ KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS
+ ),
+
+};
+
+void led_set_user(uint8_t usb_led) {
+
+}
diff --git a/keyboards/v60_type_r/keymaps/iso/readme.md b/keyboards/v60_type_r/keymaps/iso/readme.md
new file mode 100644
index 000000000..2d5e1a13d
--- /dev/null
+++ b/keyboards/v60_type_r/keymaps/iso/readme.md
@@ -0,0 +1,5 @@
+![KBP V60 Type R ISO Image](https://i.imgur.com/28xetL9.png)
+
+# Default ISO Layout
+
+This is the default layout that comes flashed on the KBP V60 Type R ISO version.
diff --git a/keyboards/v60_type_r/keymaps/iso/rules.mk b/keyboards/v60_type_r/keymaps/iso/rules.mk
new file mode 100644
index 000000000..b6c9a2580
--- /dev/null
+++ b/keyboards/v60_type_r/keymaps/iso/rules.mk
@@ -0,0 +1,2 @@
+BACKLIGHT_ENABLE = no
+RGBLIGHT_ENABLE = no