aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/vision_division/keymaps/default/Makefile
diff options
context:
space:
mode:
authorFred Sundvik <fsundvik@gmail.com>2016-08-25 23:26:02 +0300
committerFred Sundvik <fsundvik@gmail.com>2016-08-25 23:26:02 +0300
commit523dff3005193f72247addff70c8cb238ac6164b (patch)
tree43b0835c0dc3b59ad7366b8ae77acfb8e21fdc98 /keyboards/vision_division/keymaps/default/Makefile
parent2e3834edea1bc2f83477dff1a423adc87c357471 (diff)
parent4321f0af7d34f794a372964be49d225442671c45 (diff)
downloadfirmware-523dff3005193f72247addff70c8cb238ac6164b.tar.gz
firmware-523dff3005193f72247addff70c8cb238ac6164b.tar.bz2
firmware-523dff3005193f72247addff70c8cb238ac6164b.zip
Merge branch 'master' into makefile_overhaul
Diffstat (limited to 'keyboards/vision_division/keymaps/default/Makefile')
-rw-r--r--keyboards/vision_division/keymaps/default/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/keyboards/vision_division/keymaps/default/Makefile b/keyboards/vision_division/keymaps/default/Makefile
new file mode 100644
index 000000000..ecbe7e1ab
--- /dev/null
+++ b/keyboards/vision_division/keymaps/default/Makefile
@@ -0,0 +1,21 @@
+# Build Options
+# change to "no" to disable the options, or define them in the Makefile in
+# the appropriate keymap folder that will get included automatically
+#
+BOOTMAGIC_ENABLE = yes # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE = yes # Mouse keys(+4700)
+EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
+CONSOLE_ENABLE = yes # Console for debug(+400)
+COMMAND_ENABLE = yes # Commands for debug and configuration
+NKRO_ENABLE = yes # Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+MIDI_ENABLE = no # MIDI controls
+AUDIO_ENABLE = yes # Audio output on port C6
+UNICODE_ENABLE = no # Unicode
+BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
+RGBLIGHT_ENABLE = no # Enable WS2812 RGB underlight. Do not enable this with audio at the same time.
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+
+ifndef QUANTUM_DIR
+ include ../../../../Makefile
+endif \ No newline at end of file