aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/xd60/rev2
diff options
context:
space:
mode:
authorJames Young <18669334+noroadsleft@users.noreply.github.com>2019-11-04 23:05:51 -0800
committerDrashna Jaelre <drashna@live.com>2019-11-04 23:05:51 -0800
commitdc1137129d063975b3191853dc96d0095fcf94d6 (patch)
treef5647c18304e0e69bf4ce2745c4cb548e147182d /keyboards/xd60/rev2
parent1244d0e266dad4170ed0c63e68e00c74c87367b2 (diff)
downloadfirmware-dc1137129d063975b3191853dc96d0095fcf94d6.tar.gz
firmware-dc1137129d063975b3191853dc96d0095fcf94d6.tar.bz2
firmware-dc1137129d063975b3191853dc96d0095fcf94d6.zip
[Keyboard] Add LAYOUT_60_iso to XD60 (#7263)
* refactor iso keymap - remove redundant action_layer.h include - use enum for layer management - QMK coding conventions (four-space indent) * add LAYOUT_60_iso macro * enable 60_iso community layout for both revisions * swap KC_HOME to KC_RSFT * update ISO keymap readme * update default keymap readme `make` command no longer valid. * refactor keyboard readme Update to reflect current QMK template. * add LAYOUT_60_iso data to info.json * use #pragma once in header files
Diffstat (limited to 'keyboards/xd60/rev2')
-rw-r--r--keyboards/xd60/rev2/config.h5
-rw-r--r--keyboards/xd60/rev2/rules.mk2
2 files changed, 2 insertions, 5 deletions
diff --git a/keyboards/xd60/rev2/config.h b/keyboards/xd60/rev2/config.h
index 5f23f6eac..26dbb50e3 100644
--- a/keyboards/xd60/rev2/config.h
+++ b/keyboards/xd60/rev2/config.h
@@ -15,8 +15,7 @@ You should have received a copy of the GNU General Public License
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
-#ifndef CONFIG_H
-#define CONFIG_H
+#pragma once
#include "config_common.h"
@@ -70,5 +69,3 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
#define LOCKING_SUPPORT_ENABLE
/* Locking resynchronize hack */
#define LOCKING_RESYNC_ENABLE
-
-#endif
diff --git a/keyboards/xd60/rev2/rules.mk b/keyboards/xd60/rev2/rules.mk
index 37f281b0c..b6a8c05d2 100644
--- a/keyboards/xd60/rev2/rules.mk
+++ b/keyboards/xd60/rev2/rules.mk
@@ -26,4 +26,4 @@ BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
RGBLIGHT_ENABLE = yes # Enable WS2812 RGB underlight.
SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
-LAYOUTS = 60_ansi
+LAYOUTS = 60_ansi 60_iso