aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/xw60/config.h
diff options
context:
space:
mode:
authoritsdrdick <itsdrdick@gmail.com>2019-05-30 02:01:14 +0800
committerDrashna Jaelre <drashna@live.com>2019-05-29 11:01:14 -0700
commit2ca840d0b8e1c44365644c9c0e3059bfa4d2cd3e (patch)
tree5ff92e19d176e67e51c47b17e796492a5282b915 /keyboards/xw60/config.h
parenta1a7a84831230515bac68c9fe2c93cd90c02acb8 (diff)
downloadfirmware-2ca840d0b8e1c44365644c9c0e3059bfa4d2cd3e.tar.gz
firmware-2ca840d0b8e1c44365644c9c0e3059bfa4d2cd3e.tar.bz2
firmware-2ca840d0b8e1c44365644c9c0e3059bfa4d2cd3e.zip
[Keyboard] Added XW60 PCB (#6011)
* Added XW60 PCB * Update keyboards/xw60/config.h Co-Authored-By: fauxpark <fauxpark@gmail.com> * Update keyboards/xw60/rules.mk Co-Authored-By: fauxpark <fauxpark@gmail.com> * Update keyboards/xw60/rules.mk Co-Authored-By: fauxpark <fauxpark@gmail.com> * Update keyboards/xw60/xw60.h Co-Authored-By: fauxpark <fauxpark@gmail.com> * Update keyboards/xw60/xw60.h Co-Authored-By: fauxpark <fauxpark@gmail.com> * Update keyboards/xw60/xw60.h Co-Authored-By: fauxpark <fauxpark@gmail.com> * Update rules.mk * Removed redundant line * Update keyboards/xw60/config.h Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update keyboards/xw60/readme.md Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com>
Diffstat (limited to 'keyboards/xw60/config.h')
-rw-r--r--keyboards/xw60/config.h36
1 files changed, 36 insertions, 0 deletions
diff --git a/keyboards/xw60/config.h b/keyboards/xw60/config.h
new file mode 100644
index 000000000..95404fffb
--- /dev/null
+++ b/keyboards/xw60/config.h
@@ -0,0 +1,36 @@
+#pragma once
+
+#include "config_common.h"
+
+/* USB Device descriptor parameter */
+#define VENDOR_ID 0xFEED
+#define PRODUCT_ID 0x6060
+#define DEVICE_VER 0x0001
+#define MANUFACTURER Drclick
+#define PRODUCT XW60
+#define DESCRIPTION qmk keyboard firmware for XW60
+
+/* key matrix size */
+#define MATRIX_ROWS 5
+#define MATRIX_COLS 14
+
+#define MATRIX_ROW_PINS { D0, D1, D2, D3, D5 }
+#define MATRIX_COL_PINS { F0, F1, E6, C7, C6, B6, D4, B1, B7, B5, B4, D7, D6, B3 }
+#define UNUSED_PINS
+
+/* COL2ROW or ROW2COL */
+#define DIODE_DIRECTION COL2ROW
+
+/* Debounce reduces chatter (unintended double-presses) - set 0 if debouncing is not needed */
+#define DEBOUNCE 5
+
+/* define if matrix has ghost (lacks anti-ghosting diodes) */
+//#define MATRIX_HAS_GHOST
+
+/* Mechanical locking support. Use KC_LCAP, KC_LNUM or KC_LSCR instead in keymap */
+#define LOCKING_SUPPORT_ENABLE
+/* Locking resynchronize hack */
+
+#define SOLENOID_PIN F6
+#define SOLENOID_ACTIVE true
+#define SOLENOID_DEFAULT_DWELL 75