aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/ymdk/sp64/config.h
diff options
context:
space:
mode:
authorBrad Arnett <brad.arnett@gmail.com>2020-06-18 03:01:22 -0700
committerGitHub <noreply@github.com>2020-06-18 03:01:22 -0700
commit716924de3e07eb4a6f39a9c8da9ba0fc64c7f796 (patch)
tree64b1ae4de2f938a7900666f83f5de4e58b30afc5 /keyboards/ymdk/sp64/config.h
parentd88dca3ca79d908c34fb5bf4af40c52b4cfce7f8 (diff)
downloadfirmware-716924de3e07eb4a6f39a9c8da9ba0fc64c7f796.tar.gz
firmware-716924de3e07eb4a6f39a9c8da9ba0fc64c7f796.tar.bz2
firmware-716924de3e07eb4a6f39a9c8da9ba0fc64c7f796.zip
[Keyboard] Added ymdk split64 based on walston's work (#9183)
* Added ymdk split64 based on walson's work * Commented out features on walston's keymap as it was too big to compile * Update keyboards/ymdk_sp64/config.h * Update keyboards/ymdk_sp64/keymaps/daed/keymap.c * Update keyboards/ymdk_sp64/matrix.c * Update keyboards/ymdk_sp64/matrix.c * Update keyboards/ymdk_sp64/matrix.c * keymap changes * Update keyboards/ymdk_sp64/matrix.c * Update keyboards/ymdk_sp64/matrix.c * Update keyboards/ymdk_sp64/rules.mk * Update keyboards/ymdk_sp64/config.h * Update keyboards/ymdk_sp64/config.h * Update keyboards/ymdk_sp64/readme.md * Update keyboards/ymdk_sp64/rules.mk * Update keyboards/ymdk_sp64/config.h * Update keyboards/ymdk_sp64/rules.mk * Update keyboards/ymdk_sp64/ymdk_sp64.c * Update keyboards/ymdk_sp64/keymaps/walston/rules.mk * Update keyboards/ymdk_sp64/readme.md * Made requested changes and moved keyboard under ymdk directory * Update keyboards/ymdk/ymdk_sp64/keymaps/walston/keymap.c * Update keyboards/ymdk/ymdk_sp64/config.h * Update keyboards/ymdk/ymdk_sp64/config.h * Update keyboards/ymdk/ymdk_sp64/keymaps/default/keymap.c * Update keyboards/ymdk/ymdk_sp64/keymaps/default/keymap.c * updated changes for pr 9183 * updated changes for pr 9183 * updated changes for pr 9183 * Removed redundant "QMK_KEYBOARD_H" include
Diffstat (limited to 'keyboards/ymdk/sp64/config.h')
-rw-r--r--keyboards/ymdk/sp64/config.h45
1 files changed, 45 insertions, 0 deletions
diff --git a/keyboards/ymdk/sp64/config.h b/keyboards/ymdk/sp64/config.h
new file mode 100644
index 000000000..fc3e2d7dc
--- /dev/null
+++ b/keyboards/ymdk/sp64/config.h
@@ -0,0 +1,45 @@
+/*
+Copyright 2019 Neil Kettle
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 2 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#pragma once
+
+#include "config_common.h"
+
+#define VENDOR_ID 0x594D
+#define PRODUCT_ID 0x5364
+#define DEVICE_VER 0x0200
+#define MANUFACTURER YMDK
+#define PRODUCT SP64
+#define DESCRIPTION YMDK Split 64
+
+#define MATRIX_ROWS 6
+#define MATRIX_COLS 15
+
+#define RIGHT_HALF
+
+/* disable these deprecated features by default */
+#define NO_ACTION_MACRO
+#define NO_ACTION_FUNCTION
+
+/* RGB underglow */
+#define RGBLED_NUM 12
+#define RGBLIGHT_HUE_STEP 8
+#define RGBLIGHT_SAT_STEP 8
+#define RGBLIGHT_VAL_STEP 8
+#define RGBLIGHT_LIMIT_VAL 250 /* The maximum brightness level */
+#define RGBLIGHT_SLEEP /* If defined, the RGB lighting will be switched off when the host goes to sleep */
+#define RGBLIGHT_ANIMATIONS