aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/ymdk_np21/rules.mk
diff options
context:
space:
mode:
authorRyan <fauxpark@gmail.com>2020-09-01 15:30:07 +1000
committerGitHub <noreply@github.com>2020-08-31 22:30:07 -0700
commit0032cb026b7d4143fd61ed3cb3378eda5bb41292 (patch)
treedac28f633daecf3fca2e5cc11866df636b1482d7 /keyboards/ymdk_np21/rules.mk
parent854a94f383a3e292f783e845675ea4d8a269d552 (diff)
downloadfirmware-0032cb026b7d4143fd61ed3cb3378eda5bb41292.tar.gz
firmware-0032cb026b7d4143fd61ed3cb3378eda5bb41292.tar.bz2
firmware-0032cb026b7d4143fd61ed3cb3378eda5bb41292.zip
[Keyboard] YMDK NP21 refactor (#10181)
Diffstat (limited to 'keyboards/ymdk_np21/rules.mk')
-rw-r--r--keyboards/ymdk_np21/rules.mk34
1 files changed, 13 insertions, 21 deletions
diff --git a/keyboards/ymdk_np21/rules.mk b/keyboards/ymdk_np21/rules.mk
index c370c616a..ed7d082f0 100644
--- a/keyboards/ymdk_np21/rules.mk
+++ b/keyboards/ymdk_np21/rules.mk
@@ -2,28 +2,20 @@
MCU = atmega32a
# Bootloader selection
-# Teensy halfkay
-# Pro Micro caterina
-# Atmel DFU atmel-dfu
-# LUFA DFU lufa-dfu
-# QMK DFU qmk-dfu
-# ATmega32A bootloadHID
-# ATmega328P USBasp
BOOTLOADER = bootloadHID
-# build options
-BOOTMAGIC_ENABLE = no
-MOUSEKEY_ENABLE = no
-EXTRAKEY_ENABLE = yes
-CONSOLE_ENABLE = no
-COMMAND_ENABLE = yes
-
-BACKLIGHT_ENABLE = yes
-
-RGBLIGHT_ENABLE = yes
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = lite # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = no # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = no # Console for debug
+COMMAND_ENABLE = yes # Commands for debug and configuration
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+BACKLIGHT_ENABLE = yes # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = yes # Enable keyboard RGB underglow
WS2812_DRIVER = i2c
-KEY_LOCK_ENABLE = yes
-
-# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
-SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+LAYOUTS = ortho_6x4 numpad_6x4