aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/z150_blackheart/rules.mk
diff options
context:
space:
mode:
authorblindassassin111 <38090555+blindassassin111@users.noreply.github.com>2018-08-31 10:15:09 -0500
committerDrashna Jaelre <drashna@live.com>2018-08-31 08:15:09 -0700
commit4e45119796049f1c2f9e0c99a0ad6f0f932691b5 (patch)
treef1b745c76590999330bce9add2ea8022ec41897e /keyboards/z150_blackheart/rules.mk
parentf9eedd7ce741f15a1d5ff7327cb44d3979a46e35 (diff)
downloadfirmware-4e45119796049f1c2f9e0c99a0ad6f0f932691b5.tar.gz
firmware-4e45119796049f1c2f9e0c99a0ad6f0f932691b5.tar.bz2
firmware-4e45119796049f1c2f9e0c99a0ad6f0f932691b5.zip
Keyboard: Adding Z-150 PCB firmware (#3793)
* Adding the AT101 PCB firmware * Fixed AT101 keymap error * Fixing AT101 firmware * More Fixes for AT101 firmware * Rename AT101_Blackheart.c to at101_blackheart.c * Rename AT101_Blackheart.h to at101_blackheart.h * Update readme.md * Renaming AT101 folder pt1 * Renaming AT101 folder pt2 * Fixing AT101 LED function name * Redoing AT101 folder naming pt2 Last round had issues, should be the last rename. * Fixing missing comma in at101_blackheart.h * Adding Z-150 PCB * Adding Z-150 readme file * Fixing Z-150 firmware errors * Fixing Z-150 layout error * Fixing Z-150 firmware errors * Fixing Z-150 Issues Still unsure where the extra "\" is that through the error. * Fixing more Z-150 errors * Finally fixing the Z-150 error * Fixed Z-150 layout naming * Removed Z-150 layout fillers
Diffstat (limited to 'keyboards/z150_blackheart/rules.mk')
-rw-r--r--keyboards/z150_blackheart/rules.mk58
1 files changed, 58 insertions, 0 deletions
diff --git a/keyboards/z150_blackheart/rules.mk b/keyboards/z150_blackheart/rules.mk
new file mode 100644
index 000000000..b258bf35f
--- /dev/null
+++ b/keyboards/z150_blackheart/rules.mk
@@ -0,0 +1,58 @@
+# MCU name
+MCU = at90usb1286
+
+# Processor frequency.
+# This will define a symbol, F_CPU, in all source code files equal to the
+# processor frequency in Hz. You can then use this symbol in your source code to
+# calculate timings. Do NOT tack on a 'UL' at the end, this will be done
+# automatically to create a 32-bit value in your source code.
+#
+# This will be an integer division of F_USB below, as it is sourced by
+# F_USB after it has run through any CPU prescalers. Note that this value
+# does not *change* the processor frequency - it should merely be updated to
+# reflect the processor speed set externally so that the code can use accurate
+# software delays.
+F_CPU = 16000000
+
+#
+# LUFA specific
+#
+# Target architecture (see library "Board Types" documentation).
+ARCH = AVR8
+
+# Input clock frequency.
+# This will define a symbol, F_USB, in all source code files equal to the
+# input clock frequency (before any prescaling is performed) in Hz. This value may
+# differ from F_CPU if prescaling is used on the latter, and is required as the
+# raw input clock is fed directly to the PLL sections of the AVR for high speed
+# clock generation for the USB and other AVR subsections. Do NOT tack on a 'UL'
+# at the end, this will be done automatically to create a 32-bit value in your
+# source code.
+#
+# If no clock division is performed on the input clock inside the AVR (via the
+# CPU clock adjust registers or the clock division fuses), this will be equal to F_CPU.
+F_USB = $(F_CPU)
+
+# Interrupt driven control endpoint task(+60)
+OPT_DEFS += -DINTERRUPT_CONTROL_ENDPOINT
+
+# Bootloader selection
+BOOTLOADER = halfkay
+
+# Boot Section Size in *bytes*
+# OPT_DEFS += -DBOOTLOADER_SIZE=4096
+
+
+# Build Options
+# comment out to disable the options.
+#
+BOOTMAGIC_ENABLE = yes # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE = yes # Mouse keys(+4700)
+EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
+CONSOLE_ENABLE = no # Console for debug(+400)
+COMMAND_ENABLE = no # Commands for debug and configuration
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+NKRO_ENABLE = yes # USB Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+AUDIO_ENABLE = no
+RGBLIGHT_ENABLE = no \ No newline at end of file