aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/z150_blackheart
diff options
context:
space:
mode:
authorJames Young <18669334+noroadsleft@users.noreply.github.com>2020-05-30 13:14:59 -0700
committerGitHub <noreply@github.com>2020-05-30 13:14:59 -0700
commitfced377ac007d27f2650ccffbe0b18abcdcfe23d (patch)
treebd5b141987394a5a16cfc416bfe2b9efdb14d067 /keyboards/z150_blackheart
parent7b8a013826ad90714a05ea522de53adf964ab3b9 (diff)
downloadfirmware-fced377ac007d27f2650ccffbe0b18abcdcfe23d.tar.gz
firmware-fced377ac007d27f2650ccffbe0b18abcdcfe23d.tar.bz2
firmware-fced377ac007d27f2650ccffbe0b18abcdcfe23d.zip
2020 May 30 Breaking Changes Update (#9215)
* Branch point for 2020 May 30 Breaking Change * Migrate `ACTION_LAYER_TOGGLE` to `TG()` (#8954) * Migrate `ACTION_MODS_ONESHOT` to `OSM()` (#8957) * Migrate `ACTION_DEFAULT_LAYER_SET` to `DF()` (#8958) * Migrate `ACTION_LAYER_MODS` to `LM()` (#8959) * Migrate `ACTION_MODS_TAP_KEY` to `MT()` (#8968) * Convert V-USB usbdrv to a submodule (#8321) * Unify Tap Hold functions and documentation (#8348) * Changing board names to prevent confusion (#8412) * Move the Keyboardio Model01 to a keyboardio/ subdir (#8499) * Move spaceman keyboards (#8830) * Migrate miscellaneous `fn_actions` entries (#8977) * Migrate `ACTION_MODS_KEY` to chained mod keycodes (#8979) * Organizing my keyboards (plaid, tartan, ergoinu) (#8537) * Refactor Lily58 to use split_common (#6260) * Refactor zinc to use split_common (#7114) * Add a message if bin/qmk doesn't work (#9000) * Fix conflicting types for 'tfp_printf' (#8269) * Fixed RGB_DISABLE_AFTER_TIMEOUT to be seconds based & small internals cleanup (#6480) * Refactor and updates to TKC1800 code (#8472) * Switch to qmk forks for everything (#9019) * audio refactor: replace deprecated PLAY_NOTE_ARRAY (#8484) * Audio enable corrections (2/3) (#8903) * Split HHKB to ANSI and JP layouts and Add VIA support for each (#8582) * Audio enable corrections (Part 4) (#8974) * Fix typo from PR7114 (#9171) * Augment future branch Changelogs (#8978) * Revert "Branch point for 2020 May 30 Breaking Change"
Diffstat (limited to 'keyboards/z150_blackheart')
-rw-r--r--keyboards/z150_blackheart/config.h43
-rw-r--r--keyboards/z150_blackheart/info.json191
-rw-r--r--keyboards/z150_blackheart/keymaps/default/keymap.c48
-rw-r--r--keyboards/z150_blackheart/keymaps/default_tkl/keymap.c48
-rw-r--r--keyboards/z150_blackheart/readme.md14
-rw-r--r--keyboards/z150_blackheart/rules.mk26
-rw-r--r--keyboards/z150_blackheart/z150_blackheart.c32
-rw-r--r--keyboards/z150_blackheart/z150_blackheart.h31
8 files changed, 0 insertions, 433 deletions
diff --git a/keyboards/z150_blackheart/config.h b/keyboards/z150_blackheart/config.h
deleted file mode 100644
index fc33021ff..000000000
--- a/keyboards/z150_blackheart/config.h
+++ /dev/null
@@ -1,43 +0,0 @@
-#pragma once
-
-#include "config_common.h"
-
-/* USB Device descriptor parameter */
-#define VENDOR_ID 0xFEED
-#define PRODUCT_ID 0x6060
-#define DEVICE_VER 0x0001
-#define MANUFACTURER blindassassin111
-#define PRODUCT Z-150 PCB
-#define DESCRIPTION Replacement for Zenith Z-150 PCB
-
-/* key matrix size */
-#define MATRIX_ROWS 5
-#define MATRIX_COLS 20
-
-/* key matrix pins */
-#define MATRIX_ROW_PINS { C3, C2, C1, C0, E1 }
-#define MATRIX_COL_PINS { D0, D1, D2, D3, D4, D5, D7, E0, C7, C6, C5, C4, F0, F1, F2, F3, F4, F5, F6, F7 }
-#define UNUSED_PINS
-
-/* COL2ROW or ROW2COL */
-#define DIODE_DIRECTION COL2ROW
-
-/* Set 0 if debouncing isn't needed */
-#define DEBOUNCE 5
-
-/* Mechanical locking support. Use KC_LCAP, KC_LNUM or KC_LSCR instead in keymap */
-#define LOCKING_SUPPORT_ENABLE
-
-/* Locking resynchronize hack */
-#define LOCKING_RESYNC_ENABLE
-
-/* force n-key rollover*/
-#define FORCE_NKRO
-
-#ifdef RGB_DI_PIN
-#define RGBLIGHT_ANIMATIONS
-#define RGBLED_NUM 0
-#define RGBLIGHT_HUE_STEP 8
-#define RGBLIGHT_SAT_STEP 8
-#define RGBLIGHT_VAL_STEP 8
-#endif
diff --git a/keyboards/z150_blackheart/info.json b/keyboards/z150_blackheart/info.json
deleted file mode 100644
index 016641254..000000000
--- a/keyboards/z150_blackheart/info.json
+++ /dev/null
@@ -1,191 +0,0 @@
-{
- "keyboard_name": "Z-150 Blackheart",
- "url": "",
- "maintainer": "qmk, blindassassin111",
- "width": 21.25,
- "height": 5,
- "layouts": {
- "LAYOUT": {
- "key_count": 84,
- "layout": [
- {"label":"F1", "x":0, "y":0},
- {"label":"F2", "x":1, "y":0},
- {"label":"Esc", "x":2.5, "y":0},
- {"label":"!", "x":3.5, "y":0},
- {"label":"@", "x":4.5, "y":0},
- {"label":"#", "x":5.5, "y":0},
- {"label":"$", "x":6.5, "y":0},
- {"label":"%", "x":7.5, "y":0},
- {"label":"^", "x":8.5, "y":0},
- {"label":"&", "x":9.5, "y":0},
- {"label":"*", "x":10.5, "y":0},
- {"label":"(", "x":11.5, "y":0},
- {"label":")", "x":12.5, "y":0},
- {"label":"_", "x":13.5, "y":0},
- {"label":"+", "x":14.5, "y":0},
- {"label":"Backspace", "x":15.5, "y":0, "w":1.75},
- {"label":"Num Lock", "x":17.25, "y":0},
- {"label":"Scroll Lock", "x":18.25, "y":0, "w":1.5},
- {"label":"Sys Req", "x":19.75, "y":0, "w":1.5},
- {"label":"F3", "x":0, "y":1},
- {"label":"F4", "x":1, "y":1},
- {"label":"Tab", "x":2.5, "y":1, "w":1.5},
- {"label":"Q", "x":4, "y":1},
- {"label":"W", "x":5, "y":1},
- {"label":"E", "x":6, "y":1},
- {"label":"R", "x":7, "y":1},
- {"label":"T", "x":8, "y":1},
- {"label":"Y", "x":9, "y":1},
- {"label":"U", "x":10, "y":1},
- {"label":"I", "x":11, "y":1},
- {"label":"O", "x":12, "y":1},
- {"label":"P", "x":13, "y":1},
- {"label":"{", "x":14, "y":1},
- {"label":"}", "x":15, "y":1, "w":1.25},
- {"label":"Enter", "x":15.25, "y":2, "w":2},
- {"label":"7", "x":17.25, "y":1},
- {"label":"8", "x":18.25, "y":1},
- {"label":"9", "x":19.25, "y":1},
- {"label":"PrtSc", "x":20.25, "y":1},
- {"label":"F5", "x":0, "y":2},
- {"label":"F6", "x":1, "y":2},
- {"label":"Ctrl", "x":2.5, "y":2, "w":1.75},
- {"label":"A", "x":4.25, "y":2},
- {"label":"S", "x":5.25, "y":2},
- {"label":"D", "x":6.25, "y":2},
- {"label":"F", "x":7.25, "y":2},
- {"label":"G", "x":8.25, "y":2},
- {"label":"H", "x":9.25, "y":2},
- {"label":"J", "x":10.25, "y":2},
- {"label":"K", "x":11.25, "y":2},
- {"label":"L", "x":12.25, "y":2},
- {"label":":", "x":13.25, "y":2},
- {"label":"\"", "x":14.25, "y":2},
- {"label":"4", "x":17.25, "y":2},
- {"label":"5", "x":18.25, "y":2},
- {"label":"6", "x":19.25, "y":2},
- {"label":"-", "x":20.25, "y":2},
- {"label":"F7", "x":0, "y":3},
- {"label":"F8", "x":1, "y":3},
- {"label":"Shift", "x":2.5, "y":3, "w":2.25},
- {"label":"Z", "x":4.75, "y":3},
- {"label":"X", "x":5.75, "y":3},
- {"label":"C", "x":6.75, "y":3},
- {"label":"V", "x":7.75, "y":3},
- {"label":"B", "x":8.75, "y":3},
- {"label":"N", "x":9.75, "y":3},
- {"label":"M", "x":10.75, "y":3},
- {"label":"<", "x":11.75, "y":3},
- {"label":">", "x":12.75, "y":3},
- {"label":"?", "x":13.75, "y":3},
- {"label":"Shift", "x":14.75, "y":3, "w":1.5},
- {"label":"|", "x":16.25, "y":3},
- {"label":"1", "x":17.25, "y":3},
- {"label":"2", "x":18.25, "y":3},
- {"label":"3", "x":19.25, "y":3},
- {"label":"+", "x":20.25, "y":3, "h":2},
- {"label":"F9", "x":0, "y":4},
- {"label":"F10", "x":1, "y":4},
- {"label":"Alt", "x":2.5, "y":4, "w":1.75},
- {"label":"~", "x":4.25, "y":4},
- {"label":"Space", "x":5.25, "y":4, "w":9},
- {"label":"Caps Lock", "x":14.25, "y":4, "w":2},
- {"label":"0", "x":16.25, "y":4, "w":2},
- {"label":".", "x":18.25, "y":4, "w":2}
- ]
- },
- "LAYOUT_z150_tkl": {
- "key_count": 88,
- "layout": [
- {"label":"F1", "x":0, "y":0},
- {"label":"F2", "x":1, "y":0},
- {"label":"Esc", "x":2.5, "y":0},
- {"label":"1", "x":3.5, "y":0},
- {"label":"2", "x":4.5, "y":0},
- {"label":"3", "x":5.5, "y":0},
- {"label":"4", "x":6.5, "y":0},
- {"label":"5", "x":7.5, "y":0},
- {"label":"6", "x":8.5, "y":0},
- {"label":"7", "x":9.5, "y":0},
- {"label":"8", "x":10.5, "y":0},
- {"label":"9", "x":11.5, "y":0},
- {"label":"0", "x":12.5, "y":0},
- {"label":"-", "x":13.5, "y":0},
- {"label":"=", "x":14.5, "y":0},
- {"label":"Backspace", "x":15.5, "y":0, "w":2},
- {"label":"Insert", "x":18.25, "y":0},
- {"label":"Home", "x":19.25, "y":0},
- {"label":"PgUp", "x":20.25, "y":0},
- {"label":"F3", "x":0, "y":1},
- {"label":"F4", "x":1, "y":1},
- {"label":"Tab", "x":2.5, "y":1, "w":1.5},
- {"label":"Q", "x":4, "y":1},
- {"label":"W", "x":5, "y":1},
- {"label":"E", "x":6, "y":1},
- {"label":"R", "x":7, "y":1},
- {"label":"T", "x":8, "y":1},
- {"label":"Y", "x":9, "y":1},
- {"label":"U", "x":10, "y":1},
- {"label":"I", "x":11, "y":1},
- {"label":"O", "x":12, "y":1},
- {"label":"P", "x":13, "y":1},
- {"label":"[", "x":14, "y":1},
- {"label":"]", "x":15, "y":1},
- {"label":"\\", "x":16, "y":1, "w":1.5},
- {"label":"Delete", "x":18.25, "y":1},
- {"label":"End", "x":19.25, "y":1},
- {"label":"PgDn", "x":20.25, "y":1},
- {"label":"F5", "x":0, "y":2},
- {"label":"F6", "x":1, "y":2},
- {"label":"Caps Lock", "x":2.5, "y":2, "w":1.75},
- {"label":"A", "x":4.25, "y":2},
- {"label":"S", "x":5.25, "y":2},
- {"label":"D", "x":6.25, "y":2},
- {"label":"F", "x":7.25, "y":2},
- {"label":"G", "x":8.25, "y":2},
- {"label":"H", "x":9.25, "y":2},
- {"label":"J", "x":10.25, "y":2},
- {"label":"K", "x":11.25, "y":2},
- {"label":"L", "x":12.25, "y":2},
- {"label":";", "x":13.25, "y":2},
- {"label":"'", "x":14.25, "y":2},
- {"label":"Enter", "x":15.25, "y":2, "w":2.25},
- {"x":18.25, "y":2},
- {"x":19.25, "y":2},
- {"x":20.25, "y":2},
- {"label":"F7", "x":0, "y":3},
- {"label":"F8", "x":1, "y":3},
- {"label":"Shift", "x":2.5, "y":3, "w":1.25},
- {"label":"ISO \\", "x":3.75, "y":3},
- {"label":"Z", "x":4.75, "y":3},
- {"label":"X", "x":5.75, "y":3},
- {"label":"C", "x":6.75, "y":3},
- {"label":"V", "x":7.75, "y":3},
- {"label":"B", "x":8.75, "y":3},
- {"label":"N", "x":9.75, "y":3},
- {"label":"M", "x":10.75, "y":3},
- {"label":",", "x":11.75, "y":3},
- {"label":".", "x":12.75, "y":3},
- {"label":"/", "x":13.75, "y":3},
- {"label":"Shift", "x":14.75, "y":3, "w":1.75},
- {"label":"Fn", "x":16.5, "y":3},
- {"x":18.25, "y":3},
- {"label":"Up", "x":19.25, "y":3},
- {"x":20.25, "y":3},
- {"label":"F9", "x":0, "y":4},
- {"label":"F10", "x":1, "y":4},
- {"label":"Ctrl", "x":2.5, "y":4, "w":1.25},
- {"label":"Win", "x":3.75, "y":4, "w":1.25},
- {"label":"Alt", "x":5, "y":4, "w":1.25},
- {"label":"Space", "x":6.25, "y":4, "w":6.25},
- {"label":"Alt", "x":12.5, "y":4, "w":1.25},
- {"label":"Win", "x":13.75, "y":4, "w":1.25},
- {"label":"Menu", "x":15, "y":4, "w":1.25},
- {"label":"Ctrl", "x":16.25, "y":4, "w":1.25},
- {"label":"Left", "x":18.25, "y":4},
- {"label":"Down", "x":19.25, "y":4},
- {"label":"Right", "x":20.25, "y":4}
- ]
- }
- }
-}
diff --git a/keyboards/z150_blackheart/keymaps/default/keymap.c b/keyboards/z150_blackheart/keymaps/default/keymap.c
deleted file mode 100644
index ff4f6f7f9..000000000
--- a/keyboards/z150_blackheart/keymaps/default/keymap.c
+++ /dev/null
@@ -1,48 +0,0 @@
-/* Copyright 2018 blindassassin111
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-#include QMK_KEYBOARD_H
-
-const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
-
- [0] = LAYOUT(
- KC_F1, KC_F2, KC_ESC, KC_1, KC_2, KC_3, KC_4, KC_5, KC_6, KC_7, KC_8, KC_9, KC_0, KC_MINS, KC_EQL, KC_BSPC, KC_NLCK, KC_SLCK, MO(1),
- KC_F3, KC_F4, KC_TAB, KC_Q, KC_W, KC_E, KC_R, KC_T, KC_Y, KC_U, KC_I, KC_O, KC_P, KC_LBRC, KC_RBRC, KC_ENT, KC_P7, KC_P8, KC_P9, KC_PAST,
- KC_F5, KC_F6, KC_LCTL, KC_A, KC_S, KC_D, KC_F, KC_G, KC_H, KC_J, KC_K, KC_L, KC_SCLN, KC_QUOT, KC_P4, KC_P5, KC_P6, KC_PMNS,
- KC_F7, KC_F8, KC_LSFT, KC_Z, KC_X, KC_C, KC_V, KC_B, KC_N, KC_M, KC_COMM, KC_DOT, KC_SLSH, KC_RSFT, KC_BSLS, KC_P1, KC_P2, KC_P3, KC_PPLS,
- KC_F9, KC_F10, KC_LALT, KC_GRV, KC_SPC, KC_CAPS, KC_P0, KC_PDOT
- ),
-
- [1] = LAYOUT(
- _______, _______, RESET, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______,
- _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______,
- _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______,
- _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______,
- _______, _______, _______, _______, _______, _______, _______, _______
- ),
-};
-
-void matrix_init_user(void) {
-}
-
-void matrix_scan_user(void) {
-}
-
-bool process_record_user(uint16_t keycode, keyrecord_t *record) {
- return true;
-}
-
-void led_set_user(uint8_t usb_led) {
-} \ No newline at end of file
diff --git a/keyboards/z150_blackheart/keymaps/default_tkl/keymap.c b/keyboards/z150_blackheart/keymaps/default_tkl/keymap.c
deleted file mode 100644
index f1a24b8dd..000000000
--- a/keyboards/z150_blackheart/keymaps/default_tkl/keymap.c
+++ /dev/null
@@ -1,48 +0,0 @@
-/* Copyright 2018 blindassassin111
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-#include QMK_KEYBOARD_H
-
-const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
-
- [0] = LAYOUT_z150_tkl(
- KC_F1, KC_F2, KC_ESC, KC_1, KC_2, KC_3, KC_4, KC_5, KC_6, KC_7, KC_8, KC_9, KC_0, KC_MINS, KC_EQL, KC_BSPC, KC_INS, KC_HOME, KC_PGUP,
- KC_F3, KC_F4, KC_TAB, KC_Q, KC_W, KC_E, KC_R, KC_T, KC_Y, KC_U, KC_I, KC_O, KC_P, KC_LBRC, KC_RBRC, KC_BSLS, KC_DEL, KC_END, KC_PGDN,
- KC_F5, KC_F6, KC_CAPS, KC_A, KC_S, KC_D, KC_F, KC_G, KC_H, KC_J, KC_K, KC_L, KC_SCLN, KC_QUOT, KC_ENT, XXXXXXX, XXXXXXX, XXXXXXX,
- KC_F7, KC_F8, KC_LSFT, KC_BSLS, KC_Z, KC_X, KC_C, KC_V, KC_B, KC_N, KC_M, KC_COMM, KC_DOT, KC_SLSH, KC_RSFT, MO(1), XXXXXXX, KC_UP, XXXXXXX,
- KC_F9, KC_F10, KC_LCTL, KC_LGUI, KC_LALT, KC_SPC, KC_RALT, KC_RGUI, KC_MENU, KC_RCTL, KC_LEFT, KC_DOWN, KC_RGHT
- ),
-
- [1] = LAYOUT_z150_tkl(
- _______, _______, RESET, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______,
- _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______,
- _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______,
- _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______,
- _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______, _______
- ),
-};
-
-void matrix_init_user(void) {
-}
-
-void matrix_scan_user(void) {
-}
-
-bool process_record_user(uint16_t keycode, keyrecord_t *record) {
- return true;
-}
-
-void led_set_user(uint8_t usb_led) {
-} \ No newline at end of file
diff --git a/keyboards/z150_blackheart/readme.md b/keyboards/z150_blackheart/readme.md
deleted file mode 100644
index 331f85694..000000000
--- a/keyboards/z150_blackheart/readme.md
+++ /dev/null
@@ -1,14 +0,0 @@
-Z-150 Blackheart PCB
-===
-
-A replacement PCB for Zenith Z-150 keyboards.
-
-Keyboard Maintainer: QMK Community and blindassassin111
-Hardware Supported: Z-150 blackheart PCB
-Hardware Availability: [Deskthority Group Buy](https://deskthority.net/group-buys-f50/programmable-vintage-board-pcbs-omnikey-at101-and-z-150-t19325.html)
-
-Make example for this keyboard (after setting up your build environment):
-
- make z150_blackheart:default
-
-See the [build environment setup](https://docs.qmk.fm/#/getting_started_build_tools) and the [make instructions](https://docs.qmk.fm/#/getting_started_make_guide) for more information. Brand new to QMK? Start with our [Complete Newbs Guide](https://docs.qmk.fm/#/newbs).
diff --git a/keyboards/z150_blackheart/rules.mk b/keyboards/z150_blackheart/rules.mk
deleted file mode 100644
index 739bea393..000000000
--- a/keyboards/z150_blackheart/rules.mk
+++ /dev/null
@@ -1,26 +0,0 @@
-# MCU name
-MCU = at90usb1286
-
-# Bootloader selection
-# Teensy halfkay
-# Pro Micro caterina
-# Atmel DFU atmel-dfu
-# LUFA DFU lufa-dfu
-# QMK DFU qmk-dfu
-# ATmega32A bootloadHID
-# ATmega328P USBasp
-BOOTLOADER = halfkay
-
-# Build Options
-# comment out to disable the options.
-#
-BOOTMAGIC_ENABLE = yes # Virtual DIP switch configuration
-MOUSEKEY_ENABLE = yes # Mouse keys
-EXTRAKEY_ENABLE = yes # Audio control and System control
-CONSOLE_ENABLE = no # Console for debug
-COMMAND_ENABLE = no # Commands for debug and configuration
-SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
-NKRO_ENABLE = yes # USB Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
-BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
-AUDIO_ENABLE = no
-RGBLIGHT_ENABLE = no
diff --git a/keyboards/z150_blackheart/z150_blackheart.c b/keyboards/z150_blackheart/z150_blackheart.c
deleted file mode 100644
index b754c64a1..000000000
--- a/keyboards/z150_blackheart/z150_blackheart.c
+++ /dev/null
@@ -1,32 +0,0 @@
-#include "z150_blackheart.h"
-
-void matrix_init_kb(void) {
- setPinOutput(B0);
- setPinOutput(E6);
- setPinOutput(E7);
-
- matrix_init_user();
-};
-
-void led_set_kb(uint8_t usb_led) {
- // put your keyboard LED indicator (ex: Caps Lock LED) toggling code here
- if (IS_LED_ON(usb_led, USB_LED_NUM_LOCK)) {
- writePinHigh(E7);
- } else {
- writePinLow(E7);
- }
-
- if (IS_LED_ON(usb_led, USB_LED_CAPS_LOCK)) {
- writePinHigh(B0);
- } else {
- writePinLow(B0);
- }
-
- if (IS_LED_ON(usb_led, USB_LED_SCROLL_LOCK)) {
- writePinHigh(E6);
- } else {
- writePinLow(E6);
- }
-
- led_set_user(usb_led);
-}
diff --git a/keyboards/z150_blackheart/z150_blackheart.h b/keyboards/z150_blackheart/z150_blackheart.h
deleted file mode 100644
index f97ac1c03..000000000
--- a/keyboards/z150_blackheart/z150_blackheart.h
+++ /dev/null
@@ -1,31 +0,0 @@
-#pragma once
-
-#include "quantum.h"
-
-#define LAYOUT( \
- K00, K01, K02, K03, K04, K05, K06, K07, K08, K09, K0A, K0B, K0C, K0D, K0E, K0F, K0G, K0H, K0J, \
- K10, K11, K12, K13, K14, K15, K16, K17, K18, K19, K1A, K1B, K1C, K1D, K1E, K1F, K1G, K1H, K1I, K1J, \
- K20, K21, K22, K23, K24, K25, K26, K27, K28, K29, K2A, K2B, K2C, K2D, K2F, K2G, K2H, K2I, \
- K30, K31, K32, K33, K34, K35, K36, K37, K38, K39, K3A, K3B, K3C, K3D, K3E, K3F, K3G, K3H, K3I, \
- K40, K41, K42, K43, K47, K4E, K4F, K4H \
-) { \
- { K00, K01, K02, K03, K04, K05, K06, K07, K08, K09, K0A, K0B, K0C, K0D, K0E, K0F, K0G, K0H, KC_NO, K0J }, \
- { K10, K11, K12, K13, K14, K15, K16, K17, K18, K19, K1A, K1B, K1C, K1D, K1E, K1F, K1G, K1H, K1I, K1J }, \
- { K20, K21, K22, K23, K24, K25, K26, K27, K28, K29, K2A, K2B, K2C, K2D, KC_NO, K2F, K2G, K2H, K2I, KC_NO }, \
- { K30, K31, K32, K33, K34, K35, K36, K37, K38, K39, K3A, K3B, K3C, K3D, K3E, K3F, K3G, K3H, K3I, KC_NO }, \
- { K40, K41, K42, K43, KC_NO, KC_NO, KC_NO, K47, KC_NO, KC_NO, KC_NO, KC_NO, KC_NO, KC_NO, K4E, K4F, KC_NO, K4H, KC_NO, KC_NO } \
-}
-
-#define LAYOUT_z150_tkl( \
- K00, K01, K02, K03, K04, K05, K06, K07, K08, K09, K0A, K0B, K0C, K0D, K0E, K0F, K0H, K0I, K0J, \
- K10, K11, K12, K13, K14, K15, K16, K17, K18, K19, K1A, K1B, K1C, K1D, K1E, K1F, K1H, K1I, K1J, \
- K20, K21, K22, K23, K24, K25, K26, K27, K28, K29, K2A, K2B, K2C, K2D, K2E, K2G, K2H, K2I, \
- K30, K31, K32, K45, K33, K34, K35, K36, K37, K38, K39, K3A, K3B, K3C, K3D, K3E, K3G, K3H, K3I, \
- K40, K41, K42, K43, K44, K47, K4C, K4D, K4E, K4F, K4G, K4H, K4I \
-) { \
- { K00, K01, K02, K03, K04, K05, K06, K07, K08, K09, K0A, K0B, K0C, K0D, K0E, K0F, KC_NO, K0H, K0I, K0J }, \
- { K10, K11, K12, K13, K14, K15, K16, K17, K18, K19, K1A, K1B, K1C, K1D, K1E, K1F, KC_NO, K1H, K1I, K1J }, \
- { K20, K21, K22, K23, K24, K25, K26, K27, K28, K29, K2A, K2B, K2C, K2D, K2E, KC_NO, K2G, K2H, K2I, KC_NO }, \
- { K30, K31, K32, K33, K34, K35, K36, K37, K38, K39, K3A, K3B, K3C, K3D, K3E, KC_NO, K3G, K3H, K3I, KC_NO }, \
- { K40, K41, K42, K43, K44, K45, KC_NO, K47, KC_NO, KC_NO, KC_NO, KC_NO, K4C, K4D, K4E, K4F, K4G, K4H, K4I, KC_NO } \
-}