aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/zygomorph/readme.md
diff options
context:
space:
mode:
authorXScorpion2 <rcalt2vt@gmail.com>2019-05-12 00:42:57 -0500
committerDrashna Jaelre <drashna@live.com>2019-05-11 22:42:57 -0700
commit8d46bb9cabb9c8e81c7ca1266d97a0126cc80767 (patch)
tree703c68832f3714a847a67fb1fea2775caad8e32b /keyboards/zygomorph/readme.md
parentc6184d2e7ed9695c22635431394e501b1d5e6271 (diff)
downloadfirmware-8d46bb9cabb9c8e81c7ca1266d97a0126cc80767.tar.gz
firmware-8d46bb9cabb9c8e81c7ca1266d97a0126cc80767.tar.bz2
firmware-8d46bb9cabb9c8e81c7ca1266d97a0126cc80767.zip
[Keyboard] Adding RGBKB Zygomorph Keyboard (#5841)
* Initial Zygomorph 5x6 code Split is not working yet * layout changes implement 4 row config option (not done yet), remove layout comments in layout.c * Zygomorph layouts for 5x12, 5x6, 4x12, and 4x6 Also, info.json *should* be nearly usable for the configurator * temporary fix for pin D5 being broken * show D5 issue comment * add build notes * Pin B7 broken in split why? * remove fix * Fix some pin assignments * begin to fix keymap * Create new 5x6 layout * update key positions * Initial Zygomorph 5x6 code Split is not working yet * layout changes implement 4 row config option (not done yet), remove layout comments in layout.c * Zygomorph layouts for 5x12, 5x6, 4x12, and 4x6 Also, info.json *should* be nearly usable for the configurator * temporary fix for pin D5 being broken * show D5 issue comment * add build notes * Pin B7 broken in split why? * remove fix * Fix some pin assignments * begin to fix keymap * Create new 5x6 layout * Rough first pass at split common conversion. Keymap cleanup to cover just the basics. Broke OLED code out into separate example. * Fix readme * Removal of old encoder / oled driver, fix for layout macros * small update * xulkal zygomorph keymaps * Removed the LED_MIRRORED option as leds are always mirrored on Zygomorph * Xulkal keymaps update * split rgb light support * fix line endings * Apply suggestions from code review Co-Authored-By: zvecr <git@zvecr.com> * More layout and compile fixes from pr review * Cleaning up rules.mk files * Apply suggestions from code review Co-Authored-By: zvecr <git@zvecr.com> * Updating defaults * Apply suggestions from code review Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com>
Diffstat (limited to 'keyboards/zygomorph/readme.md')
-rw-r--r--keyboards/zygomorph/readme.md15
1 files changed, 15 insertions, 0 deletions
diff --git a/keyboards/zygomorph/readme.md b/keyboards/zygomorph/readme.md
new file mode 100644
index 000000000..c669fba65
--- /dev/null
+++ b/keyboards/zygomorph/readme.md
@@ -0,0 +1,15 @@
+# Zygomorph
+
+![Zygomorph](https://cdn.shopify.com/s/files/1/0008/8827/5005/products/20190107_004053_2048x2048.jpg?v=1549333933)
+
+Zygomorph is the thinnest keyboard with a fully enclosed case. It's only 3.2mm thick below the switches, including screws. It can be used in 5x6 and 4x6 split, or 5x12 and 4x12 combined. It has per-key RGB, supports Kailh Choc and MX switches, and has 10 rotary encoder positions per half (only one can be used per half). The board has pre-soldered components, including type C ports and ATmega32U4. The build guide can be found [here](https://rgbkb.gitbook.io/rgbkb-build-guides/zygomorph-build-guide/).
+
+Keyboard Maintainer: [Legonut](https://github.com/Legonut)
+Hardware Supported: Zygomorph R1.0
+Hardware Availability: [RGBKB](https://www.rgbkb.net)
+
+Make example for this keyboard (after setting up your build environment):
+
+ make zygomorph:default
+
+See the [build environment setup](https://docs.qmk.fm/#/getting_started_build_tools) and the [make instructions](https://docs.qmk.fm/#/getting_started_make_guide) for more information. Brand new to QMK? Start with our [Complete Newbs Guide](https://docs.qmk.fm/#/newbs).