aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards
diff options
context:
space:
mode:
authorholtenc <holtenc@primekb.com>2020-02-25 15:21:59 -0600
committerGitHub <noreply@github.com>2020-02-25 13:21:59 -0800
commitd52cd8886c2b3d201c8cdb0bf1a45ba98e4d9cf0 (patch)
tree302a6a08b7eba42da5f36a4257ad564f26609708 /keyboards
parent61b71320f79a663880bd70402d306722c1bbfe3e (diff)
downloadfirmware-d52cd8886c2b3d201c8cdb0bf1a45ba98e4d9cf0.tar.gz
firmware-d52cd8886c2b3d201c8cdb0bf1a45ba98e4d9cf0.tar.bz2
firmware-d52cd8886c2b3d201c8cdb0bf1a45ba98e4d9cf0.zip
[Keyboard] Add Prime_EXL Plus to handwired (#8238)
* Add VIA support for Prime_L * Update keyboards/primekb/prime_l/v1/config.h * Add prime_exl_plus keyboard * Temporary removal of prime_exl_plus * Add Prime_EXL Plus, including VIA support * Update keyboards/handwired/prime_exl_plus/readme.md * Update keyboards/handwired/prime_exl_plus/readme.md * Update keyboards/handwired/prime_exl_plus/readme.md * Update keyboards/handwired/prime_exl_plus/rules.mk * Update keyboards/handwired/prime_exl_plus/info.json * Update keyboards/handwired/prime_exl_plus/info.json * Update keyboards/handwired/prime_exl_plus/info.json * Update keymap.c * correct spacing of keymaps and layout macro. move indicator logic from user space to keyboard space * further corrections to keymaps and layout macro. * Update keyboards/handwired/prime_exl_plus/prime_exl_plus.c * Update keyboards/handwired/prime_exl_plus/prime_exl_plus.c * Update keyboards/handwired/prime_exl_plus/prime_exl_plus.c * Update keyboards/handwired/prime_exl_plus/prime_exl_plus.c * Update prime_exl_plus.c * small edit to prime_exl_plus.c
Diffstat (limited to 'keyboards')
-rw-r--r--keyboards/handwired/prime_exl_plus/config.h52
-rw-r--r--keyboards/handwired/prime_exl_plus/info.json12
-rw-r--r--keyboards/handwired/prime_exl_plus/keymaps/default/keymap.c50
-rw-r--r--keyboards/handwired/prime_exl_plus/keymaps/default/readme.md1
-rw-r--r--keyboards/handwired/prime_exl_plus/keymaps/via/keymap.c50
-rw-r--r--keyboards/handwired/prime_exl_plus/keymaps/via/readme.md1
-rw-r--r--keyboards/handwired/prime_exl_plus/keymaps/via/rules.mk1
-rw-r--r--keyboards/handwired/prime_exl_plus/prime_exl_plus.c49
-rw-r--r--keyboards/handwired/prime_exl_plus/prime_exl_plus.h36
-rw-r--r--keyboards/handwired/prime_exl_plus/readme.md16
-rw-r--r--keyboards/handwired/prime_exl_plus/rules.mk33
11 files changed, 301 insertions, 0 deletions
diff --git a/keyboards/handwired/prime_exl_plus/config.h b/keyboards/handwired/prime_exl_plus/config.h
new file mode 100644
index 000000000..7e9a440d2
--- /dev/null
+++ b/keyboards/handwired/prime_exl_plus/config.h
@@ -0,0 +1,52 @@
+/*
+Copyright 2020 Holten Campbell
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 2 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#pragma once
+
+#include "config_common.h"
+
+/* USB Device descriptor parameter */
+#define VENDOR_ID 0x5052
+#define PRODUCT_ID 0x6579
+#define DEVICE_VER 0x0001
+#define MANUFACTURER PrimeKB
+#define PRODUCT Prime_EXL Plus
+#define DESCRIPTION Ergo with left numpad
+
+/* key matrix size */
+#define MATRIX_ROWS 10
+#define MATRIX_COLS 10
+
+/* Keyboard Matrix Assignments */
+#define MATRIX_ROW_PINS { D2, D6, B4, F1, E6, F0, F4, B5, D7, D3 }
+#define MATRIX_COL_PINS { F5, F6, F7, C7, C6, B6, B7, B3, D1, D0 }
+#define UNUSED_PINS
+
+/* COL2ROW, ROW2COL*/
+#define DIODE_DIRECTION COL2ROW
+
+#define RGB_DI_PIN D4
+#define RGBLED_NUM 10
+#define RGBLIGHT_ANIMATIONS
+
+/* Debounce reduces chatter (unintended double-presses) - set 0 if debouncing is not needed */
+#define DEBOUNCE 5
+
+/* Mechanical locking support. Use KC_LCAP, KC_LNUM or KC_LSCR instead in keymap */
+#define LOCKING_SUPPORT_ENABLE
+/* Locking resynchronize hack */
+#define LOCKING_RESYNC_ENABLE
diff --git a/keyboards/handwired/prime_exl_plus/info.json b/keyboards/handwired/prime_exl_plus/info.json
new file mode 100644
index 000000000..3fca8c829
--- /dev/null
+++ b/keyboards/handwired/prime_exl_plus/info.json
@@ -0,0 +1,12 @@
+{
+ "keyboard_name": "Prime_EXL Plus",
+ "url": "https://www.primekb.com",
+ "maintainer": "holtenc",
+ "width": 21,
+ "height": 5,
+ "layouts": {
+ "LAYOUT": {
+ "layout": [{"label":"K040", "x":0, "y":0}, {"label":"K050", "x":1, "y":0}, {"label":"K041", "x":2, "y":0}, {"label":"K051", "x":3, "y":0}, {"label":"K042", "x":4, "y":0}, {"label":"K052", "x":5, "y":0}, {"label":"K043", "x":6.5, "y":0}, {"label":"K053", "x":7.5, "y":0}, {"label":"K044", "x":8.5, "y":0}, {"label":"K054", "x":9.5, "y":0}, {"label":"K045", "x":10.5, "y":0}, {"label":"K055", "x":11.5, "y":0}, {"label":"K046", "x":14, "y":0}, {"label":"K056", "x":15, "y":0}, {"label":"K047", "x":16, "y":0}, {"label":"K057", "x":17, "y":0}, {"label":"K048", "x":18, "y":0}, {"label":"K058", "x":19, "y":0, "w":2}, {"label":"K030", "x":0, "y":1}, {"label":"K060", "x":1, "y":1}, {"label":"K031", "x":2, "y":1}, {"label":"K061", "x":3, "y":1}, {"label":"K032", "x":4, "y":1}, {"label":"K062", "x":5, "y":1}, {"label":"K033", "x":6.5, "y":1}, {"label":"K063", "x":7.5, "y":1}, {"label":"K034", "x":8.5, "y":1}, {"label":"K064", "x":9.5, "y":1}, {"label":"K035", "x":10.5, "y":1}, {"label":"K065", "x":11.5, "y":1}, {"label":"K036", "x":14, "y":1}, {"label":"K066", "x":15, "y":1}, {"label":"K037", "x":16, "y":1}, {"label":"K067", "x":17, "y":1}, {"label":"K038", "x":18, "y":1}, {"label":"K068", "x":19, "y":1}, {"label":"K039", "x":20, "y":1}, {"label":"K020", "x":0, "y":2}, {"label":"K070", "x":1, "y":2}, {"label":"K021", "x":2, "y":2}, {"label":"K071", "x":3, "y":2}, {"label":"K022", "x":4, "y":2}, {"label":"K072", "x":5, "y":2}, {"label":"K023", "x":6.5, "y":2, "w":1.25}, {"label":"K073", "x":7.75, "y":2}, {"label":"K024", "x":8.75, "y":2}, {"label":"K074", "x":9.75, "y":2}, {"label":"K025", "x":10.75, "y":2}, {"label":"K075", "x":11.75, "y":2}, {"label":"K026", "x":14.25, "y":2}, {"label":"K076", "x":15.25, "y":2}, {"label":"K027", "x":16.25, "y":2}, {"label":"K077", "x":17.25, "y":2}, {"label":"K028", "x":18.25, "y":2}, {"label":"K029", "x":19.25, "y":2, "w":1.75}, {"label":"K010", "x":0, "y":3}, {"label":"K080", "x":1, "y":3}, {"label":"K011", "x":2, "y":3}, {"label":"K081", "x":3, "y":3}, {"label":"K012", "x":4, "y":3}, {"label":"K082", "x":5, "y":3}, {"label":"K013", "x":6.5, "y":3, "w":1.75}, {"label":"K083", "x":8.25, "y":3}, {"label":"K014", "x":9.25, "y":3}, {"label":"K084", "x":10.25, "y":3}, {"label":"K015", "x":11.25, "y":3}, {"label":"K085", "x":12.25, "y":3}, {"label":"K016", "x":13.75, "y":3}, {"label":"K086", "x":14.75, "y":3}, {"label":"K017", "x":15.75, "y":3}, {"label":"K087", "x":16.75, "y":3}, {"label":"K018", "x":17.75, "y":3}, {"label":"K088", "x":18.75, "y":3}, {"label":"K019", "x":19.75, "y":3, "w":1.25}, {"label":"K000", "x":0, "y":4}, {"label":"K090", "x":1, "y":4}, {"label":"K001", "x":2, "y":4}, {"label":"K091", "x":3, "y":4}, {"label":"K002", "x":4, "y":4}, {"label":"K092", "x":5, "y":4}, {"label":"K003", "x":6.5, "y":4, "w":1.25}, {"label":"K093", "x":7.75, "y":4, "w":1.25}, {"label":"K004", "x":10.25, "y":4, "w":1.25}, {"label":"K095", "x":11.5, "y":4, "w":1.75}, {"label":"K006", "x":13.75, "y":4, "w":1.75}, {"label":"K097", "x":15.5, "y":4, "w":1.25}, {"label":"K098", "x":18.5, "y":4, "w":1.25}, {"label":"K009", "x":19.75, "y":4, "w":1.25}]
+ }
+ }
+}
diff --git a/keyboards/handwired/prime_exl_plus/keymaps/default/keymap.c b/keyboards/handwired/prime_exl_plus/keymaps/default/keymap.c
new file mode 100644
index 000000000..8f9fa84f7
--- /dev/null
+++ b/keyboards/handwired/prime_exl_plus/keymaps/default/keymap.c
@@ -0,0 +1,50 @@
+/* Copyright 2020 Holten Campbell
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+#include QMK_KEYBOARD_H
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+ LAYOUT(
+ KC_ESC, KC_LPRN, KC_RPRN, KC_PSLS, KC_PAST, KC_BSPC, KC_ESC, KC_1, KC_2, KC_3, KC_4, KC_5, KC_6, KC_7, KC_8, KC_9, KC_0, KC_BSPC,
+ KC_F1, KC_F2, KC_P7, KC_P8, KC_P9, KC_DEL, KC_GRV, KC_Q, KC_W, KC_E, KC_R, KC_T, KC_Y, KC_U, KC_I, KC_O, KC_P, KC_LBRC, KC_RBRC,
+ KC_F3, KC_F4, KC_P4, KC_P5, KC_P6, KC_PMNS, KC_TAB, KC_A, KC_S, KC_D, KC_F, KC_G, KC_H, KC_J, KC_K, KC_L, KC_QUOT, KC_ENT,
+ KC_F5, KC_F6, KC_P1, KC_P2, KC_P3, KC_PPLS, KC_LSFT, KC_Z, KC_X, KC_C, KC_V, KC_B, MO(3), KC_N, KC_M, KC_COMM, KC_DOT, KC_SLSH, KC_RSFT,
+ KC_F7, KC_F8, TO(1), KC_PDOT, KC_P0, KC_PENT, KC_LCTL, KC_LGUI, KC_LALT, MO(2), KC_SPC, KC_MINS, KC_RGUI, KC_RCTL
+ ),
+
+ LAYOUT(
+ KC_ESC, KC_1, KC_2, KC_3, KC_4, KC_F9, KC_ESC, KC_1, KC_2, KC_3, KC_4, KC_5, KC_6, KC_7, KC_8, KC_9, KC_0, KC_BSPC,
+ KC_TAB, KC_Q, KC_W, KC_E, KC_R, KC_T, KC_GRV, KC_Q, KC_W, KC_E, KC_R, KC_T, KC_Y, KC_U, KC_I, KC_O, KC_P, KC_LBRC, KC_RBRC,
+ KC_TAB, KC_A, KC_S, KC_D, KC_F, KC_G, KC_TAB, KC_A, KC_S, KC_D, KC_F, KC_G, KC_H, KC_J, KC_K, KC_L, KC_QUOT, KC_ENT,
+ KC_LSFT, KC_Z, KC_X, KC_C, KC_V, KC_V, KC_LSFT, KC_Z, KC_X, KC_C, KC_V, KC_B, MO(3), KC_N, KC_M, KC_COMM, KC_DOT, KC_SLSH, KC_RSFT,
+ KC_LCTL, KC_LALT, TO(0), KC_P, KC_H, KC_SPC, KC_LCTL, KC_LGUI, KC_LALT, MO(2), KC_SPC, KC_MINS, KC_RGUI, KC_RCTL
+ ),
+
+ LAYOUT(
+ KC_NLCK, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_DEL,
+ RGB_TOG, RGB_MOD, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_UP, KC_TRNS, KC_SCLN, KC_BSLS, KC_TRNS,
+ RGB_VAI, RGB_VAD, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_CAPS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_LEFT, KC_DOWN, KC_RGHT, KC_TRNS, KC_TRNS,
+ RGB_M_R, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS,
+ KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS
+ ),
+
+ LAYOUT(
+ KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS,
+ KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS,
+ KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS,
+ KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS,
+ KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS
+ )
+};
diff --git a/keyboards/handwired/prime_exl_plus/keymaps/default/readme.md b/keyboards/handwired/prime_exl_plus/keymaps/default/readme.md
new file mode 100644
index 000000000..2df977448
--- /dev/null
+++ b/keyboards/handwired/prime_exl_plus/keymaps/default/readme.md
@@ -0,0 +1 @@
+# The default keymap for prime_exl plus \ No newline at end of file
diff --git a/keyboards/handwired/prime_exl_plus/keymaps/via/keymap.c b/keyboards/handwired/prime_exl_plus/keymaps/via/keymap.c
new file mode 100644
index 000000000..8f9fa84f7
--- /dev/null
+++ b/keyboards/handwired/prime_exl_plus/keymaps/via/keymap.c
@@ -0,0 +1,50 @@
+/* Copyright 2020 Holten Campbell
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+#include QMK_KEYBOARD_H
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+ LAYOUT(
+ KC_ESC, KC_LPRN, KC_RPRN, KC_PSLS, KC_PAST, KC_BSPC, KC_ESC, KC_1, KC_2, KC_3, KC_4, KC_5, KC_6, KC_7, KC_8, KC_9, KC_0, KC_BSPC,
+ KC_F1, KC_F2, KC_P7, KC_P8, KC_P9, KC_DEL, KC_GRV, KC_Q, KC_W, KC_E, KC_R, KC_T, KC_Y, KC_U, KC_I, KC_O, KC_P, KC_LBRC, KC_RBRC,
+ KC_F3, KC_F4, KC_P4, KC_P5, KC_P6, KC_PMNS, KC_TAB, KC_A, KC_S, KC_D, KC_F, KC_G, KC_H, KC_J, KC_K, KC_L, KC_QUOT, KC_ENT,
+ KC_F5, KC_F6, KC_P1, KC_P2, KC_P3, KC_PPLS, KC_LSFT, KC_Z, KC_X, KC_C, KC_V, KC_B, MO(3), KC_N, KC_M, KC_COMM, KC_DOT, KC_SLSH, KC_RSFT,
+ KC_F7, KC_F8, TO(1), KC_PDOT, KC_P0, KC_PENT, KC_LCTL, KC_LGUI, KC_LALT, MO(2), KC_SPC, KC_MINS, KC_RGUI, KC_RCTL
+ ),
+
+ LAYOUT(
+ KC_ESC, KC_1, KC_2, KC_3, KC_4, KC_F9, KC_ESC, KC_1, KC_2, KC_3, KC_4, KC_5, KC_6, KC_7, KC_8, KC_9, KC_0, KC_BSPC,
+ KC_TAB, KC_Q, KC_W, KC_E, KC_R, KC_T, KC_GRV, KC_Q, KC_W, KC_E, KC_R, KC_T, KC_Y, KC_U, KC_I, KC_O, KC_P, KC_LBRC, KC_RBRC,
+ KC_TAB, KC_A, KC_S, KC_D, KC_F, KC_G, KC_TAB, KC_A, KC_S, KC_D, KC_F, KC_G, KC_H, KC_J, KC_K, KC_L, KC_QUOT, KC_ENT,
+ KC_LSFT, KC_Z, KC_X, KC_C, KC_V, KC_V, KC_LSFT, KC_Z, KC_X, KC_C, KC_V, KC_B, MO(3), KC_N, KC_M, KC_COMM, KC_DOT, KC_SLSH, KC_RSFT,
+ KC_LCTL, KC_LALT, TO(0), KC_P, KC_H, KC_SPC, KC_LCTL, KC_LGUI, KC_LALT, MO(2), KC_SPC, KC_MINS, KC_RGUI, KC_RCTL
+ ),
+
+ LAYOUT(
+ KC_NLCK, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_DEL,
+ RGB_TOG, RGB_MOD, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_UP, KC_TRNS, KC_SCLN, KC_BSLS, KC_TRNS,
+ RGB_VAI, RGB_VAD, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_CAPS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_LEFT, KC_DOWN, KC_RGHT, KC_TRNS, KC_TRNS,
+ RGB_M_R, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS,
+ KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS
+ ),
+
+ LAYOUT(
+ KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS,
+ KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS,
+ KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS,
+ KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS,
+ KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS, KC_TRNS
+ )
+};
diff --git a/keyboards/handwired/prime_exl_plus/keymaps/via/readme.md b/keyboards/handwired/prime_exl_plus/keymaps/via/readme.md
new file mode 100644
index 000000000..bcd7f1d8b
--- /dev/null
+++ b/keyboards/handwired/prime_exl_plus/keymaps/via/readme.md
@@ -0,0 +1 @@
+# The default VIA keymap for Prime_EXL Plus \ No newline at end of file
diff --git a/keyboards/handwired/prime_exl_plus/keymaps/via/rules.mk b/keyboards/handwired/prime_exl_plus/keymaps/via/rules.mk
new file mode 100644
index 000000000..1e5b99807
--- /dev/null
+++ b/keyboards/handwired/prime_exl_plus/keymaps/via/rules.mk
@@ -0,0 +1 @@
+VIA_ENABLE = yes
diff --git a/keyboards/handwired/prime_exl_plus/prime_exl_plus.c b/keyboards/handwired/prime_exl_plus/prime_exl_plus.c
new file mode 100644
index 000000000..266a3b638
--- /dev/null
+++ b/keyboards/handwired/prime_exl_plus/prime_exl_plus.c
@@ -0,0 +1,49 @@
+/* Copyright 2020 Holten Campbell
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+#include "prime_exl_plus.h"
+
+void matrix_init_kb(void) {
+ // set CapsLock LED to output and low
+ setPinOutput(B0);
+ writePinLow(B0);
+ // set NumLock LED to output and low
+ setPinOutput(B1);
+ writePinLow(B1);
+ // set ScrollLock LED to output and low
+ setPinOutput(B2);
+ writePinLow(B2);
+}
+
+bool led_update_kb(led_t led_state) {
+ bool res = led_update_user(led_state);
+ if(res) {
+ writePin(B1, led_state.num_lock);
+ writePin(B0, led_state.caps_lock);
+ //writePin(B2, led_state.scroll_lock);
+ }
+ return res;
+}
+
+//function for layer indicator LED
+layer_state_t layer_state_set_kb(layer_state_t state)
+{
+ if (get_highest_layer(state) == 1) {
+ writePinHigh(B2);
+ } else {
+ writePinLow(B2);
+ }
+ return layer_state_set_user(state);
+}
diff --git a/keyboards/handwired/prime_exl_plus/prime_exl_plus.h b/keyboards/handwired/prime_exl_plus/prime_exl_plus.h
new file mode 100644
index 000000000..bb1c8b174
--- /dev/null
+++ b/keyboards/handwired/prime_exl_plus/prime_exl_plus.h
@@ -0,0 +1,36 @@
+/* Copyright 2020 Holten Campbell
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#include "quantum.h"
+
+#define LAYOUT( \
+ K040, K050, K041, K051, K042, K052, K043, K053, K044, K054, K045, K055, K046, K056, K047, K057, K048, K058, \
+ K030, K060, K031, K061, K032, K062, K033, K063, K034, K064, K035, K065, K036, K066, K037, K067, K038, K068, K039, \
+ K020, K070, K021, K071, K022, K072, K023, K073, K024, K074, K025, K075, K026, K076, K027, K077, K028, K029, \
+ K010, K080, K011, K081, K012, K082, K013, K083, K014, K084, K015, K085, K016, K086, K017, K087, K018, K088, K019, \
+ K000, K090, K001, K091, K002, K092, K003, K093, K004, K095, K006, K097, K098, K009 \
+) { \
+ { K000, K001, K002, K003, K004, KC_NO, K006, KC_NO, KC_NO, K009 }, \
+ { K010, K011, K012, K013, K014, K015, K016, K017, K018, K019 }, \
+ { K020, K021, K022, K023, K024, K025, K026, K027, K028, K029 }, \
+ { K030, K031, K032, K033, K034, K035, K036, K037, K038, K039 }, \
+ { K040, K041, K042, K043, K044, K045, K046, K047, K048, KC_NO }, \
+ { K050, K051, K052, K053, K054, K055, K056, K057, K058, KC_NO }, \
+ { K060, K061, K062, K063, K064, K065, K066, K067, K068, KC_NO }, \
+ { K070, K071, K072, K073, K074, K075, K076, K077, KC_NO, KC_NO }, \
+ { K080, K081, K082, K083, K084, K085, K086, K087, K088, KC_NO }, \
+ { K090, K091, K092, K093, KC_NO, K095, KC_NO, K097, K098, KC_NO } \
+}
diff --git a/keyboards/handwired/prime_exl_plus/readme.md b/keyboards/handwired/prime_exl_plus/readme.md
new file mode 100644
index 000000000..e35fa1f2e
--- /dev/null
+++ b/keyboards/handwired/prime_exl_plus/readme.md
@@ -0,0 +1,16 @@
+# Prime_EXL Plus
+
+![Prime_EXL Plus](https://i.imgur.com/XGj53Nb.jpg)
+
+An ergonomic 45% keyboard with a numrow and macro/numpad added to the left side.
+
+* Keyboard Maintainer: [Holtenc](https://github.com/holtenc/)
+* Hardware Supported: Prime_EXL Plus PCB, ATmega32U4
+* Hardware Availability: Prototype/personal project
+
+Make example for this keyboard (after setting up your build environment):
+
+ make handwired/prime_exl_plus:default
+ make handwired/prime_exl_plus:via
+
+See the [build environment setup](https://docs.qmk.fm/#/getting_started_build_tools) and the [make instructions](https://docs.qmk.fm/#/getting_started_make_guide) for more information. Brand new to QMK? Start with our [Complete Newbs Guide](https://docs.qmk.fm/#/newbs).
diff --git a/keyboards/handwired/prime_exl_plus/rules.mk b/keyboards/handwired/prime_exl_plus/rules.mk
new file mode 100644
index 000000000..c0493d993
--- /dev/null
+++ b/keyboards/handwired/prime_exl_plus/rules.mk
@@ -0,0 +1,33 @@
+# MCU name
+MCU = atmega32u4
+
+# Bootloader selection
+# Teensy halfkay
+# Pro Micro caterina
+# Atmel DFU atmel-dfu
+# LUFA DFU lufa-dfu
+# QMK DFU qmk-dfu
+# ATmega32A bootloadHID
+# ATmega328P USBasp
+BOOTLOADER = atmel-dfu
+
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = no # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = no # Console for debug
+COMMAND_ENABLE = no # Commands for debug and configuration
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+NKRO_ENABLE = yes # USB Nkey Rollover
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = yes # Enable keyboard RGB underglow
+MIDI_ENABLE = no # MIDI support
+UNICODE_ENABLE = no # Unicode
+BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
+AUDIO_ENABLE = no # Audio output on port C6
+FAUXCLICKY_ENABLE = no # Use buzzer to emulate clicky switches
+HD44780_ENABLE = no # Enable support for HD44780 based LCDs