aboutsummaryrefslogtreecommitdiffstats
path: root/layouts/community/60_iso/unxmaal/config.h
diff options
context:
space:
mode:
authorJack Humbert <jack.humb@gmail.com>2017-08-23 22:29:07 -0400
committerGitHub <noreply@github.com>2017-08-23 22:29:07 -0400
commitd2ff66a985b938e87fffe55c1d9f1dc55e356f91 (patch)
tree561b3e203033849573a17f5ac6248077ab687676 /layouts/community/60_iso/unxmaal/config.h
parent7260fc3eef98fb7b0e2ed24d3d0d14cf2e613000 (diff)
downloadfirmware-d2ff66a985b938e87fffe55c1d9f1dc55e356f91.tar.gz
firmware-d2ff66a985b938e87fffe55c1d9f1dc55e356f91.tar.bz2
firmware-d2ff66a985b938e87fffe55c1d9f1dc55e356f91.zip
Creates a layouts/ folder for keymaps shared between keyboards (#1609)
* include variables and .h files as pp directives * start layout compilation * split ergodoxes up * don't compile all layouts for everything * might seg fault * reset layouts variable * actually reset layouts * include rules.mk instead * remove includes from rules.mk * update variable setting * load visualizer from path * adds some more examples * adds more layouts * more boards added * more boards added * adds documentation for layouts * use lowercase names for LAYOUT_ * add layout.json files for each layout * add community folder, default keymaps for layouts * touch-up default layouts * touch-up layouts, some keyboard rules.mk * update documentation for layouts * fix up serial/i2c switches
Diffstat (limited to 'layouts/community/60_iso/unxmaal/config.h')
-rw-r--r--layouts/community/60_iso/unxmaal/config.h32
1 files changed, 32 insertions, 0 deletions
diff --git a/layouts/community/60_iso/unxmaal/config.h b/layouts/community/60_iso/unxmaal/config.h
new file mode 100644
index 000000000..7a500b1bb
--- /dev/null
+++ b/layouts/community/60_iso/unxmaal/config.h
@@ -0,0 +1,32 @@
+/*
+Copyright 2012 Jun Wako <wakojun@gmail.com>
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 2 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#ifndef KEYMAP_CONFIG_H
+#define KEYMAP_CONFIG_H
+
+#include QMK_KEYBOARD_CONFIG_H
+
+#ifndef RGB_DI_PIN
+ #define RGB_DI_PIN F4
+ #define RGBLIGHT_ANIMATIONS
+ #define RGBLED_NUM 8 // Number of LEDs
+ #define RGBLIGHT_HUE_STEP 8
+ #define RGBLIGHT_SAT_STEP 8
+ #define RGBLIGHT_VAL_STEP 8
+#endif
+
+#endif