aboutsummaryrefslogtreecommitdiffstats
path: root/lib/lufa/BuildTests/StaticAnalysisTest/makefile
diff options
context:
space:
mode:
authorFabian Topfstedt <topfstedt@schneevonmorgen.com>2017-07-20 08:22:44 +0200
committerFabian Topfstedt <topfstedt@schneevonmorgen.com>2017-07-20 08:22:44 +0200
commitee43856ff7ba37ea89d1a8a4700efba4e4f69571 (patch)
treeb0ed5b538396b0b2b027e69ad8ceac443c067c79 /lib/lufa/BuildTests/StaticAnalysisTest/makefile
parent99b6e918eab31d4f53cabc04a995da945335ac7f (diff)
parent14c5160b1a94d5dc416002791b3c207ba0dca789 (diff)
downloadfirmware-ee43856ff7ba37ea89d1a8a4700efba4e4f69571.tar.gz
firmware-ee43856ff7ba37ea89d1a8a4700efba4e4f69571.tar.bz2
firmware-ee43856ff7ba37ea89d1a8a4700efba4e4f69571.zip
Merge https://github.com/qmk/qmk_firmware
Diffstat (limited to 'lib/lufa/BuildTests/StaticAnalysisTest/makefile')
-rw-r--r--lib/lufa/BuildTests/StaticAnalysisTest/makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/lib/lufa/BuildTests/StaticAnalysisTest/makefile b/lib/lufa/BuildTests/StaticAnalysisTest/makefile
new file mode 100644
index 000000000..0041234d1
--- /dev/null
+++ b/lib/lufa/BuildTests/StaticAnalysisTest/makefile
@@ -0,0 +1,47 @@
+#
+# LUFA Library
+# Copyright (C) Dean Camera, 2017.
+#
+# dean [at] fourwalledcubicle [dot] com
+# www.lufa-lib.org
+#
+
+# Static anlysis of the entire LUFA source tree, using the free cross-platform "cppcheck" tool.
+
+# Path to the LUFA library core
+LUFA_PATH := ../../LUFA/
+
+CPPCHECK_EXCLUDES := FATFs/ \
+ PetiteFATFs/ \
+ uip/
+
+CPPCHECK_INCLUDES := $(patsubst %/,%,$(LUFA_PATH))/CodeTemplates/ \
+ $(patsubst %/,%,$(LUFA_PATH))/../Projects/AVRISP-MKII/
+
+CPPCHECK_FLAGS := -U TEMPLATE_FUNC_NAME -U __GNUC__ -U __DOXYGEN__
+
+CPPCHECK_SUPPRESS := variableScope missingInclude unusedFunction
+
+SRC := $(patsubst %/,%,$(LUFA_PATH))/..
+
+# Build test cannot be run with multiple parallel jobs
+.NOTPARALLEL:
+
+all: begin cppcheck end
+
+begin:
+ @echo Executing build test "StaticAnalysisTest".
+ @echo
+
+end:
+ @echo Build test "StaticAnalysisTest" complete.
+ @echo
+
+%:
+
+.PHONY: all begin end
+
+# Include common DMBS build system modules
+DMBS_PATH ?= $(LUFA_PATH)/Build/DMBS/DMBS
+include $(DMBS_PATH)/core.mk
+include $(DMBS_PATH)/cppcheck.mk