aboutsummaryrefslogtreecommitdiffstats
path: root/protocol/lufa/LUFA-120730/LUFA/Build/HID_EEPROM_Loader
diff options
context:
space:
mode:
authortmk <hasu@tmk-kbd.com>2015-04-10 01:25:48 +0900
committertmk <hasu@tmk-kbd.com>2015-04-10 01:25:48 +0900
commit6746e37088ce8ba03529c1226bd216705edb2b1f (patch)
treea256db88ec3e9e8b1b70839fcd9459d972ce26e0 /protocol/lufa/LUFA-120730/LUFA/Build/HID_EEPROM_Loader
parentb4e2d325f355a4d083106476393775e75e11f284 (diff)
downloadfirmware-6746e37088ce8ba03529c1226bd216705edb2b1f.tar.gz
firmware-6746e37088ce8ba03529c1226bd216705edb2b1f.tar.bz2
firmware-6746e37088ce8ba03529c1226bd216705edb2b1f.zip
Remove core library and build files
Diffstat (limited to 'protocol/lufa/LUFA-120730/LUFA/Build/HID_EEPROM_Loader')
-rw-r--r--protocol/lufa/LUFA-120730/LUFA/Build/HID_EEPROM_Loader/HID_EEPROM_Loader.c61
-rw-r--r--protocol/lufa/LUFA-120730/LUFA/Build/HID_EEPROM_Loader/makefile40
2 files changed, 0 insertions, 101 deletions
diff --git a/protocol/lufa/LUFA-120730/LUFA/Build/HID_EEPROM_Loader/HID_EEPROM_Loader.c b/protocol/lufa/LUFA-120730/LUFA/Build/HID_EEPROM_Loader/HID_EEPROM_Loader.c
deleted file mode 100644
index 600469fa1..000000000
--- a/protocol/lufa/LUFA-120730/LUFA/Build/HID_EEPROM_Loader/HID_EEPROM_Loader.c
+++ /dev/null
@@ -1,61 +0,0 @@
-/*
- LUFA Library
- Copyright (C) Dean Camera, 2012.
-
- dean [at] fourwalledcubicle [dot] com
- www.lufa-lib.org
-*/
-
-/*
- Copyright 2012 Dean Camera (dean [at] fourwalledcubicle [dot] com)
-
- Permission to use, copy, modify, distribute, and sell this
- software and its documentation for any purpose is hereby granted
- without fee, provided that the above copyright notice appear in
- all copies and that both that the copyright notice and this
- permission notice and warranty disclaimer appear in supporting
- documentation, and that the name of the author not be used in
- advertising or publicity pertaining to distribution of the
- software without specific, written prior permission.
-
- The author disclaim all warranties with regard to this
- software, including all implied warranties of merchantability
- and fitness. In no event shall the author be liable for any
- special, indirect or consequential damages or any damages
- whatsoever resulting from loss of use, data or profits, whether
- in an action of contract, negligence or other tortious action,
- arising out of or in connection with the use or performance of
- this software.
-*/
-
-/** \file
- *
- * Special application to extract an EEPROM image stored in FLASH memory, and
- * copy it to the device EEPROM. This application is designed to be used with
- * the HID build system module of LUFA to program the EEPROM of a target device
- * that uses the HID bootloader protocol, which does not have native EEPROM
- * programming support.
- */
-
-#include <avr/io.h>
-#include <avr/eeprom.h>
-#include <avr/pgmspace.h>
-
-/* References to the binary EEPROM data linked in the AVR's FLASH memory space */
-extern const char _binary_InputEEData_bin_start[];
-extern const char _binary_InputEEData_bin_end[];
-extern const char _binary_InputEEData_bin_size[];
-
-/* Friendly names for the embedded binary data stored in FLASH memory space */
-#define InputEEData _binary_InputEEData_bin_start
-#define InputEEData_size ((int)_binary_InputEEData_bin_size)
-
-int main(void)
-{
- /* Copy out the embedded EEPROM data from FLASH to EEPROM memory space */
- for (uint16_t i = 0; i < InputEEData_size; i++)
- eeprom_update_byte((uint8_t*)i, pgm_read_byte(&InputEEData[i]));
-
- /* Infinite loop once complete */
- for (;;);
-}
diff --git a/protocol/lufa/LUFA-120730/LUFA/Build/HID_EEPROM_Loader/makefile b/protocol/lufa/LUFA-120730/LUFA/Build/HID_EEPROM_Loader/makefile
deleted file mode 100644
index f6dcbea67..000000000
--- a/protocol/lufa/LUFA-120730/LUFA/Build/HID_EEPROM_Loader/makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-#
-# LUFA Library
-# Copyright (C) Dean Camera, 2012.
-#
-# dean [at] fourwalledcubicle [dot] com
-# www.lufa-lib.org
-#
-# --------------------------------------
-# LUFA Project Makefile.
-# --------------------------------------
-
-MCU = at90usb1287
-ARCH = AVR8
-F_CPU = 1000000
-F_USB = $(F_CPU)
-OPTIMIZATION = s
-TARGET = HID_EEPROM_Loader
-SRC = $(TARGET).c
-LUFA_PATH = ../../../LUFA
-CC_FLAGS =
-LD_FLAGS =
-OBJECT_FILES = InputEEData.o
-
-# Default target
-all:
-
-# Determine the AVR sub-architecture of the build main application object file
-FIND_AVR_SUBARCH = avr$(shell avr-objdump -f $(TARGET).o | grep architecture | cut -d':' -f3 | cut -d',' -f1)
-
-# Create a linkable object file with the input binary EEPROM data stored in the FLASH section
-InputEEData.o: InputEEData.bin $(TARGET).o $(MAKEFILE_LIST)
- @echo $(MSG_OBJCPY_CMD) Converting \"$<\" to a object file \"$@\"
- avr-objcopy -I binary -O elf32-avr -B $(call FIND_AVR_SUBARCH) --rename-section .data=.progmem.data,contents,alloc,readonly,data $< $@
-
-# Include LUFA build script makefiles
-include $(LUFA_PATH)/Build/lufa_core.mk
-include $(LUFA_PATH)/Build/lufa_build.mk
-include $(LUFA_PATH)/Build/lufa_cppcheck.mk
-include $(LUFA_PATH)/Build/lufa_doxygen.mk
-include $(LUFA_PATH)/Build/lufa_hid.mk