aboutsummaryrefslogtreecommitdiffstats
path: root/quantum/serial_link/cgreen
diff options
context:
space:
mode:
authorFred Sundvik <fsundvik@gmail.com>2016-07-05 23:27:47 +0300
committerFred Sundvik <fsundvik@gmail.com>2016-07-05 23:27:47 +0300
commit639cdd363e35c13fe331939d0972aa4db5f5198d (patch)
treefe30e1b4e2aba61b3a9db42b281c7e18acf548de /quantum/serial_link/cgreen
parent7d28d6a7bc81578bb5a83f1d55810ee3d1458e96 (diff)
parenta20d513e3cdacbf6e0e70a80402497ad10166434 (diff)
downloadfirmware-639cdd363e35c13fe331939d0972aa4db5f5198d.tar.gz
firmware-639cdd363e35c13fe331939d0972aa4db5f5198d.tar.bz2
firmware-639cdd363e35c13fe331939d0972aa4db5f5198d.zip
Add 'quantum/serial_link/' from commit 'a20d513e3cdacbf6e0e70a80402497ad10166434'
git-subtree-dir: quantum/serial_link git-subtree-mainline: 7d28d6a7bc81578bb5a83f1d55810ee3d1458e96 git-subtree-split: a20d513e3cdacbf6e0e70a80402497ad10166434
Diffstat (limited to 'quantum/serial_link/cgreen')
-rw-r--r--quantum/serial_link/cgreen/Makefile38
-rw-r--r--quantum/serial_link/cgreen/Makefile.build33
m---------quantum/serial_link/cgreen/cgreen0
3 files changed, 71 insertions, 0 deletions
diff --git a/quantum/serial_link/cgreen/Makefile b/quantum/serial_link/cgreen/Makefile
new file mode 100644
index 000000000..6b31a3f92
--- /dev/null
+++ b/quantum/serial_link/cgreen/Makefile
@@ -0,0 +1,38 @@
+# This Makefile ensures that the build is made out of source in a subdirectory called 'build'
+# If it doesn't exist, it is created and a Makefile created there (from Makefile.build)
+#
+# This Makefile also contains delegation of the most common make commands
+#
+# If you have cmake installed you should be able to do:
+#
+# make
+# make test
+# make install
+# make package
+#
+# That should build cgreen for C and C++, run some tests, install it locally and
+# generate two distributable packages.
+
+all: build
+ cd $(CGREEN_BUILD_DIR); make all
+
+test: build
+ cd $(CGREEN_BUILD_DIR); make test
+
+clean: build
+ cd $(CGREEN_BUILD_DIR); make clean
+
+package: build
+ cd $(CGREEN_BUILD_DIR); make package
+
+install:
+ cd $(CGREEN_BUILD_DIR); make install
+
+############# Internal
+
+build:
+ mkdir -p $(CGREEN_BUILD_DIR)
+ cp Makefile.build $(CGREEN_BUILD_DIR)/Makefile
+
+
+.SILENT:
diff --git a/quantum/serial_link/cgreen/Makefile.build b/quantum/serial_link/cgreen/Makefile.build
new file mode 100644
index 000000000..f76165244
--- /dev/null
+++ b/quantum/serial_link/cgreen/Makefile.build
@@ -0,0 +1,33 @@
+# This Makefile is copied from the cgreen top directory (where it is
+# named Makefile.build) and put in a subdirectory called 'build' where
+# builds are made This Makefile then automatically creates
+# subdirectories for C and C++ builds configuring them using the cmake
+# command. Once created you can always tweak the cmake setup as with
+# any cmake build directory
+
+all: build-c build-c++
+ for d in build-* ; do cd $$d; make ; cd .. ; done
+
+clean:
+ for d in build-* ; do cd $$d; make clean ; cd .. ; done
+
+check test:
+ for d in build-* ; do cd $$d; make check ; cd .. ; done
+
+package:
+ for d in build-* ; do cd $$d; make package ; cd .. ; done
+
+install:
+ for d in build-* ; do cd $$d; make install ; cd .. ; done
+
+############ Internal
+
+build-c:
+ mkdir build-c
+ cd build-c; cmake -G "Unix Makefiles" $(CGREEN_DIR)
+
+build-c++:
+ mkdir build-c++
+ cd build-c++; cmake -G "Unix Makefiles" -DWITH_CXX:bool=ON $(CGREEN_DIR)
+
+.SILENT:
diff --git a/quantum/serial_link/cgreen/cgreen b/quantum/serial_link/cgreen/cgreen
new file mode 160000
+Subproject d4d438dda1b7131f0bd0530b2c258e9dea6a2a9