aboutsummaryrefslogtreecommitdiffstats
path: root/tmk_core/avr.mk
diff options
context:
space:
mode:
authordi0ib <git@porkhash.net>2016-08-14 10:58:22 -1000
committerdi0ib <git@porkhash.net>2016-08-14 10:58:22 -1000
commitb4218a2b3e928468110eb034fbac61631b71d30d (patch)
tree7d5f318b5bc81b01bf7a97e95eba6c65b2feacec /tmk_core/avr.mk
parentc6c2c3fc14736e4d226c5f410d8c3faf3d36629f (diff)
parent6323f3d1e74350ef52dddc1f31d8b36ba637d254 (diff)
downloadfirmware-b4218a2b3e928468110eb034fbac61631b71d30d.tar.gz
firmware-b4218a2b3e928468110eb034fbac61631b71d30d.tar.bz2
firmware-b4218a2b3e928468110eb034fbac61631b71d30d.zip
Merge remote-tracking branch 'refs/remotes/jackhumbert/master'
Diffstat (limited to 'tmk_core/avr.mk')
-rw-r--r--tmk_core/avr.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/tmk_core/avr.mk b/tmk_core/avr.mk
index 6c03e1650..b48173341 100644
--- a/tmk_core/avr.mk
+++ b/tmk_core/avr.mk
@@ -138,6 +138,11 @@ else
endif
dfu-programmer $(MCU) reset
+# Convert hex to bin.
+flashbin: $(BUILD_DIR)/$(TARGET).hex
+ $(OBJCOPY) -Iihex -Obinary $(BUILD_DIR)/$(TARGET).hex $(BUILD_DIR)/$(TARGET).bin
+ $(COPY) $(BUILD_DIR)/$(TARGET).bin $(TARGET).bin;
+ $(COPY) $(BUILD_DIR)/$(TARGET).bin FLASH.bin;
# Generate avr-gdb config/init file which does the following:
# define the reset signal, load the target file, connect to target, and set