aboutsummaryrefslogtreecommitdiffstats
path: root/users/curry/rules.mk
diff options
context:
space:
mode:
authorAkaash Suresh <casa.akaash@gmail.com>2020-01-02 11:52:23 -0600
committerAkaash Suresh <casa.akaash@gmail.com>2020-01-02 11:52:23 -0600
commit3650d59afe69484c7d8c489763e04ddd3d79c03b (patch)
tree71577d528142f51f3610c81486074eb5af079311 /users/curry/rules.mk
parent8ec0b378bc5cd0f0154e24c4a765f91b60791f2c (diff)
downloadfirmware-3650d59afe69484c7d8c489763e04ddd3d79c03b.tar.gz
firmware-3650d59afe69484c7d8c489763e04ddd3d79c03b.tar.bz2
firmware-3650d59afe69484c7d8c489763e04ddd3d79c03b.zip
Merge upstream/master with userspace
Diffstat (limited to 'users/curry/rules.mk')
-rw-r--r--users/curry/rules.mk61
1 files changed, 61 insertions, 0 deletions
diff --git a/users/curry/rules.mk b/users/curry/rules.mk
new file mode 100644
index 000000000..2ebb80794
--- /dev/null
+++ b/users/curry/rules.mk
@@ -0,0 +1,61 @@
+SRC += curry.c \
+ process_records.c
+
+LTO_ENABLE = yes
+SPACE_CADET_ENABLE = no
+
+ifneq ($(strip $(NO_SECRETS)), yes)
+ ifneq ("$(wildcard $(USER_PATH)/secrets.c)","")
+ SRC += secrets.c
+ endif
+ ifeq ($(strip $(NO_SECRETS)), lite)
+ OPT_DEFS += -DNO_SECRETS
+ endif
+endif
+
+ifeq ($(strip $(TAP_DANCE_ENABLE)), yes)
+ SRC += tap_dances.c
+endif
+
+ifeq ($(strip $(OLED_DRIVER_ENABLE)), yes)
+ SRC += oled.c
+endif
+
+ifeq ($(strip $(RGBLIGHT_ENABLE)), yes)
+ SRC += rgb_stuff.c
+ ifeq ($(strip $(INDICATOR_LIGHTS)), yes)
+ OPT_DEFS += -DINDICATOR_LIGHTS
+ endif
+ ifeq ($(strip $(RGBLIGHT_TWINKLE)), yes)
+ OPT_DEFS += -DRGBLIGHT_TWINKLE
+ endif
+ ifeq ($(strip $(RGBLIGHT_NOEEPROM)), yes)
+ OPT_DEFS += -DRGBLIGHT_NOEEPROM
+ endif
+ ifeq ($(strip $(RGBLIGHT_STARTUP_ANIMATION)), yes)
+ OPT_DEFS += -DRGBLIGHT_STARTUP_ANIMATION
+ endif
+endif
+
+RGB_MATRIX_ENABLE ?= no
+ifneq ($(strip $(RGB_MATRIX_ENABLE)), no)
+ SRC += rgb_stuff.c
+endif
+
+
+ifdef CONSOLE_ENABLE
+ ifeq ($(strip $(KEYLOGGER_ENABLE)), yes)
+ OPT_DEFS += -DKEYLOGGER_ENABLE
+ endif
+endif
+
+ifeq ($(strip $(MAKE_BOOTLOADER)), yes)
+ OPT_DEFS += -DMAKE_BOOTLOADER
+endif
+
+# At least until build.mk or the like drops, this is here to prevent
+# VUSB boards from enabling NKRO, as they do not support it. Ideally
+# this should be handled per keyboard, but until that happens ...
+ifeq ($(strip $(PROTOCOL)), VUSB)
+ NKRO_ENABLE = no
+endif