aboutsummaryrefslogtreecommitdiffstats
path: root/users/wanleg/rules.mk
diff options
context:
space:
mode:
authorAlex Ong <the.onga@gmail.com>2019-01-04 19:43:45 +1100
committerAlex Ong <the.onga@gmail.com>2019-01-04 19:43:45 +1100
commit2bb2977c133646c4e056960e72029270d77cc1eb (patch)
tree235d491f992121ac1716c5bf2fafb80983748576 /users/wanleg/rules.mk
parenta55c838961c89097ab849ed6cb1f261791e6b9b4 (diff)
parent47c91fc7f75ae0a477e55b687aa0fc30da0a283c (diff)
downloadfirmware-2bb2977c133646c4e056960e72029270d77cc1eb.tar.gz
firmware-2bb2977c133646c4e056960e72029270d77cc1eb.tar.bz2
firmware-2bb2977c133646c4e056960e72029270d77cc1eb.zip
Merge branch 'master' into debounce_refactor
# Conflicts: # tmk_core/common/keyboard.c
Diffstat (limited to 'users/wanleg/rules.mk')
-rw-r--r--users/wanleg/rules.mk35
1 files changed, 30 insertions, 5 deletions
diff --git a/users/wanleg/rules.mk b/users/wanleg/rules.mk
index ac8676953..b069cd8d3 100644
--- a/users/wanleg/rules.mk
+++ b/users/wanleg/rules.mk
@@ -1,8 +1,4 @@
-ifeq ($(strip $(KEYBOARD)), lets_split_rev2)
-SRC += ../../keyboards/lets_split/lets_split.c
-endif
-
-SRC += wanleg.c tapdances.c
+SRC += wanleg.c tapdances.c
TAP_DANCE_ENABLE = yes
MOUSEKEY_ENABLE = yes
@@ -12,3 +8,32 @@ MOUSEKEY_ENABLE = yes
ifeq ($(strip $(dfu)), qmk)
BOOTLOADER = qmk-dfu
endif
+
+#use alternate settings for boards using ProMicro instead of Micro
+#example usage: make 4x4:wanleg PM=yes
+ifeq ($(strip $(PM)), yes)
+ OPT_DEFS += -DPRO_MICRO
+endif
+
+#use alternate settings for boards using "Adafruit Feather 32u4 Bluefruit LE" instead of Micro
+#example usage: make 5x5:wanleg BT=yes
+ifeq ($(strip $(BT)), yes)
+ #opt_defs for alternate pin usage
+ OPT_DEFS += -DBLUEFRUIT
+ #Adafruit Bluefruit controller settings
+ BLUETOOTH = AdafruitBLE
+ BLUETOOTH_ENABLE = yes
+ F_CPU = 8000000
+ CONSOLE_ENABLE = no # Console for debug(+400)
+ COMMAND_ENABLE = no # Commands for debug and configuration
+ RGBLIGHT_ENABLE = no # Enable keyboard RGB underglow
+endif
+
+#move numpad to Left/Centre/Right(default) on 5x15 boards
+#example usage: make 4x4:wanleg padc=yes
+ifeq ($(strip $(padc)), yes)
+ OPT_DEFS += -DPADC
+endif
+ifeq ($(strip $(padl)), yes)
+ OPT_DEFS += -DPADL
+endif \ No newline at end of file