aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--keyboards/wete/config.h7
-rw-r--r--keyboards/wete/rules.mk1
2 files changed, 7 insertions, 1 deletions
diff --git a/keyboards/wete/config.h b/keyboards/wete/config.h
index 2440d147f..33906fd45 100644
--- a/keyboards/wete/config.h
+++ b/keyboards/wete/config.h
@@ -33,7 +33,7 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
#define MATRIX_ROW_PINS { A9, B12, B11, B10, B2, B1 }
#define DIODE_DIRECTION COL2ROW
-//LEDS A6, RGB B15
+//LEDS A6
#define BACKLIGHT_PIN A6
#define BACKLIGHT_PWM_DRIVER PWMD3
#define BACKLIGHT_PWM_CHANNEL 1
@@ -42,6 +42,11 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
#define BACKLIGHT_BREATHING
#define BREATHING_PERIOD 6
+// RGB B4
+#define RGB_DI_PIN B4
+#define RGBLED_NUM 24
+#define RGBLIGHT_ANIMATIONS
+
/* define if matrix has ghost */
//#define MATRIX_HAS_GHOST
diff --git a/keyboards/wete/rules.mk b/keyboards/wete/rules.mk
index 3999511fa..81c717c57 100644
--- a/keyboards/wete/rules.mk
+++ b/keyboards/wete/rules.mk
@@ -14,6 +14,7 @@ SLEEP_LED_ENABLE = yes # Breathing sleep LED during USB suspend
NKRO_ENABLE = yes # USB Nkey Rollover
CUSTOM_MATRIX = no # Custom matrix file
BACKLIGHT_ENABLE = yes
+RGBLIGHT_ENABLE = yes
# Enter lower-power sleep mode when on the ChibiOS idle thread
OPT_DEFS += -DCORTEX_ENABLE_WFI_IDLE=TRUE