aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.pjrc
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.pjrc')
-rw-r--r--Makefile.pjrc28
1 files changed, 28 insertions, 0 deletions
diff --git a/Makefile.pjrc b/Makefile.pjrc
new file mode 100644
index 000000000..4c0e83504
--- /dev/null
+++ b/Makefile.pjrc
@@ -0,0 +1,28 @@
+# Following variables need to be set in <target>/Makefile:
+# TARGET
+# COMMON_DIR
+# TARGET_DIR
+# TARGET_SRC
+# MCU
+# F_CPU
+
+
+# List C source files here. (C dependencies are automatically generated.)
+SRC = usb_keyboard.c \
+ usb_debug.c \
+ usb.c \
+ jump_bootloader.c
+SRC += $(TARGET_SRC)
+
+# Option modules
+ifdef $(or MOUSEKEY_ENABLE, PS2_MOUSE_ENABLE)
+ SRC += usb_mouse.c
+endif
+
+ifdef USB_EXTRA_ENABLE
+ SRC += usb_extra.c
+endif
+
+
+# C source file search path
+VPATH = $(TARGET_DIR):$(COMMON_DIR):$(COMMON_DIR)/pjrc