aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/blockey
diff options
context:
space:
mode:
Diffstat (limited to 'keyboards/blockey')
-rw-r--r--keyboards/blockey/config.h5
-rw-r--r--keyboards/blockey/rules.mk4
2 files changed, 2 insertions, 7 deletions
diff --git a/keyboards/blockey/config.h b/keyboards/blockey/config.h
index b099a816b..53860bfbc 100644
--- a/keyboards/blockey/config.h
+++ b/keyboards/blockey/config.h
@@ -51,11 +51,8 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
/* ws2812 RGB LED */
#define RGB_DI_PIN B1
-#define RGBLIGHT_TIMER
-#define RGBLED_NUM 4
-#define ws2812_PORTREG PORTB
-#define ws2812_DDRREG DDRB
+#define RGBLED_NUM 4
#define RGBLIGHT_HUE_STEP 10
#define RGBLIGHT_SAT_STEP 17
diff --git a/keyboards/blockey/rules.mk b/keyboards/blockey/rules.mk
index e217305bf..fb628cfaa 100644
--- a/keyboards/blockey/rules.mk
+++ b/keyboards/blockey/rules.mk
@@ -1,5 +1,3 @@
-SRC += ws2812.c
-
# MCU name
#MCU = at90usb1286
MCU = atmega32u4
@@ -54,7 +52,7 @@ OPT_DEFS += -DBOOTLOADER_SIZE=4096
# change yes to no to disable
#
BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration(+1000)
-MOUSEKEY_ENABLE = yes # Mouse keys(+4700)
+MOUSEKEY_ENABLE = no # Mouse keys(+4700)
EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
CONSOLE_ENABLE = yes # Console for debug(+400)
COMMAND_ENABLE = yes # Commands for debug and configuration